IRC channel logs

2016-01-04.log

back to list of logs

<davidh`>how can i tell autoconf to use the system guile, not that in my $HOME?
***davidh` is now known as davidh
<ft>Amend $PATH?
<davidh>ft: shouldn't pkg-config figure out the right thing?
<davidh>that's how i run configure PKG_CONFIG_PATH="" ./configure
<davidh>it actually says it found "2.0" and in my $HOME is devel
<davidh>so i suspect it's some pkg config stuff that finds the wrong binary
<ft>I don't know. I may have answered to quickly without knowing the complete problem. ☺
<davidh>but as i wrote configure.ac it's very likely that the error sits in front of the screen. Is it problematic to have stable and devel installed?
<ft>I don't think it should be a problem since everything is kept pretty separate. But then, I don't how then autoconf integration works.
<madsy>davidh: Native build or cross-compiling?
<madsy>pkg-config should work with no problems for native builds. When cross-compiling however, you need pkg-config for that toolchain, not the native pkg-config
<madsy>Or else pkg-config returns paths for a different toolchain
<madsy>davidh: Also, if you built the dependencies yourself, the .pc and .la files might contain incomplete information
<madsy>Just pushed my mingw automated build script https://github.com/Madsy/guile-automatic-build/blob/master/build-commit :)
<madsy>Guile 2.0.9 and 2.0.11 binaries for Windows can be found here http://www.mechcore.net/files/guile/win32/
<madsy>Built without thread support, for now
<neiljerram>Morning all, anyone around?
<civodul>yes?
<rjmacready>im here, but im an insignificant guile user
<neiljerram>Just looking at my FOSDEM planning, and wondering if Guile stuff is going on on Sunday as well as Saturday?
<neiljerram>Saturday is unfortunately starting to look difficult for me...
<civodul>neiljerram: the schedule for sessions is pretty much set in stone now
<civodul>how difficult is it? :-)
<civodul>it might be possible to move your talk, but only within that slot that we have
<neiljerram>Well something that I can't miss (at my son's school) has been announced for the Friday evening, and I'm also presenting (in a different dev room) mid Sunday. So I'm quite strongly inclined now to come on Sunday only.
<wingo>it would be too bad if you weren't able to present! if you can't make it though, someone can fill it
***profan_ is now known as profan
<civodul>yeah
<civodul>neiljerram: please email Pjotr to let him know
<civodul>someone else may have to fill the slot, indeed
<civodul>BTW wingo, you didn't submit a talk, did you?
<neiljerram>ok, thanks, just finalizing my thinking here...
<wingo>civodul: i didn't, ran out of time. i'd be happy to fill in if needed tho
<neiljerram>Thanks ludo and andy; I'm sorry to let you down on this. But I will email Pjotr, and I will also be around on Sunday afternoon in case any Guilers are still there then.
<civodul>sure, i hope we can meet!
<civodul>wingo: cool, let's do that if neiljerram cannot make it
<sirgazil>Hi :) Do you know any library to do desktop notification?
<sirgazil>Maybe GNOME-Guile has something for GNOME's libnotify? I can't seem to find anything...
<daviid>sirgazil: Guile-Gnome does not bind libnotify, the complete list of wrappers is here https://www.gnu.org/software/guile-gnome/
<sirgazil>Ah, ok. Thanks daviid :)
<autogen>Hey there.
<neiljerram>Seems sirgazil has gone, but I couldn't resist knocking up his/her request using the FFI...
<neiljerram>(use-modules (system foreign))
<neiljerram>(define libnotify (dynamic-link "libnotify"))
<neiljerram>(define notify-init
<neiljerram> (pointer->procedure int
<neiljerram>(notify-init (string->pointer "notify.scm"))
<neiljerram>(define notify-notification-new
<neiljerram> (pointer->procedure '*
<neiljerram>(define notify-notification-show
<neiljerram> (pointer->procedure int
<neiljerram>(notify-notification-show (notify-notification-new (string->pointer "Hello!")
<daviid>neiljerram: cool. do you have this code as a module somewhere?
<neiljerram>No, just typed it in just now.
<daviid>ok
<madsy>My script for building Guile for Windows from git should work just about everywhere now https://github.com/Madsy/guile-automatic-build
<madsy>Would be nice if someone not on Ubuntu or Debian could test it
<mark_weaver>thanks neiljerram! alas, sirgazil is no longer on channel
<mark_weaver>sirgazil is the creator of the new guile and guix web sites, by the way.
<mark_weaver>and the new logos
<neiljerram>Ah, OK, I didn't know that. I could drop that into an email, then :-)
<daviid>neiljerram: notify-init should go in a eval-when expr imo
<madsy>mark_weaver: I managed to make Guile truly freestanding on Windows. That is, it can be put anywhere
<mark_weaver>madsy: oooh, nice!
<mark_weaver>maybe send your patches to guile-devel?
<madsy>I'm not sure it is patches that would benefit the general build system really.
<madsy>I patched libguile/Makefile.in to tell libtool to link guile.exe with -all-static
<madsy>And when starting Guile on Windows, it is done with a batch script which temporarily sets up the load paths correctly, agnostic to the actual directory tree
<madsy>Basically by finding the installation "root"
<madsy>mark_weaver: Still only got 2.0.9 and 2.0.11 working though. Some bug introduced in 2.1.0 breaks builds without <sys/mman.h>
<daviid>neiljerram: cool, just played with your code. I wonder what would be the best way to check that there is a desktop and it is libnotify compat ?
<wingo>that sounds like what guix does
<madsy>wingo: Thanks for the link to make-bootstrap.scm yesterday. That gave me some insights
<autogen>Hello fellows
<ArneBab_>madsy: nice!
<ArneBab_>madsy: can you test whether what I build for Windows actually runs on Windows?
<ArneBab_>madsy: I’m on Gentoo
<daviid>guile rocks!
<daviid>and guilers too!
<civodul>yes!
<wingo>evening
<madsy>ArneBab_: Yes, that's no problem :)
<madsy>Or you could just use my script and do it yourself
<madsy>ArneBab_: I can find the exact versions of the tools and library dependencies I've used, if that helps
<madsy>Or, if you can already successfully build guile for gentoo, then my script doesn't require anything else
<ArneBab_>madsy: I get libtool: compile: unrecognized option `-DPACKAGE_VERSION_STRING=\\"1.14\\"'
<ArneBab_>for rule libiconv.res.lo
<ArneBab_>evening wingo :)
<madsy>Hm.. what's your libtool version?
<madsy>And automake and autoconfig versions
<ArneBab_>libtool (GNU libtool) 2.4.6
<ArneBab_>automake (GNU automake) 1.15
<ArneBab_>autoconf (GNU Autoconf) 2.69
<madsy>ArneBab_: Uh.. silly question, but have you actually installed MinGW-w64?
<madsy>And did ./configure find its binaries? Check config.log
<ArneBab_>madsy: not so silly… *ducks*
<madsy>:D
<ArneBab_>I first just ran the script to see whether it would work with what I already had installed
<madsy>Remember to erase the ./builds and ./binaries directories before retrying
<madsy>Or the subdirectory for the tag/commit under those directories
<madsy>When building with MinGW-w64 you might run into an issue with building libiconv though, which has to do with threading.
<madsy>Does not happen here on my Ubuntu laptop, but does happen on Debian
<wingo>ACTION tries to golf down compilation time
<civodul>wingo: neat!
<civodul>surely a difficult task
<ArneBab_>madsy: I have to look into Gentoo crossdev…
<madsy>wingo: Yeah, I saw your commit yesterday. It would be amazing if you can shave some minutes off :)
<ArneBab_>for that (there’s a warning to use that instead of installing mingw directly)
<madsy>ArneBab_: Hm? I don't follow.
<madsy>A warning when installing MinGW-w64?
<ArneBab_>madsy: gentoo specific stuff :)
<madsy>Yeah, I'm too old for using gentoo
<madsy>Don't have time to optimize my calculator GUI app with -O3 -fomit-frame-pointers anymore
<madsy>:p
<ArneBab_>madsy: it seems to be just crossdev -t mingw64
<ArneBab_>madsy: I tried using other distros. I always came back because I broke everything else…
<madsy>By the way, I have not tested 64-bit builds yet
<ArneBab_>madsy: few distros make it easy to say “everything stable, but cutting edge KDE”
<madsy>ArneBab_: If you wait around 20-30 minutes, I have a new commit done
<madsy>I'm stupid, and I forgot to let users override the toolchain prefix in the script
<madsy>I.e it won't work unless your MinGW executable prefix is i686-w64-mingw32-
<ArneBab_>crossdev started a stage1 build — I might have to delay this (will compile GCC at least 3 times)
<madsy>Bootstrapping <3
<ArneBab_>:)
<daviid>folks, for info, I improved <clus-drag>, reviewed the drag example, then added <clus-drop> and a new drop example, here http://git.savannah.gnu.org/cgit/grip.git?h=devel
<daviid>sneek: later tell amz3 I improved <clus-drag>, reviewed the drag example, then added <clus-drop> and a new drop example, grip devel branch still: http://git.savannah.gnu.org/cgit/grip.git?h=devel you should pull and run the autool danse ... have fun!
<sneek>Okay.
<madsy>Off-topic, but is Guix support for other platforms planned in the future?
<madsy>Mac, Windows, etc
<civodul>madsy: nope
<ArneBab_>madsy: I’ll have to delay till in a few days — I need to shut down the computer for the night