IRC channel logs

2015-12-13.log

back to list of logs

<MrProlong>Hello! I'm trying to figure out how to catch an error when a socket connection is refused
<mark_weaver>MrProlong: use 'catch' to catch and handle exceptions
<mark_weaver>e.g. do something like (catch 'system-error (lambda () (connect ...)) (lambda (key . args) ...))
<CustosLimen>if someone has time please have a look at this (patch specifically): https://lists.gnu.org/archive/html/bug-guile/2015-12/msg00004.html
<civodul>Hello Guilers!
<turbopape>Hi, please consider voting for our little scheme implementation in the Clojure Cup ! visit clojurecup.com/voting !
<turbopape>besides, you can see a polished version here: https://github.com/turbopape/scheje
<CustosLimen>if someone has time please have a look at this (patch specifically): https://lists.gnu.org/archive/html/bug-guile/2015-12/msg00004.html
<davexunit>ACTION is having some troubles working with some foreign C structs
<davexunit>in particular, the SDL_Event struct in SDL2
<davexunit>it's a union of some ~40 other structs
<VG234>Hello. Is there a way in guile to list the functions I've defined?
<davexunit>at the REPL, you can do things like ",apropos"
<davexunit>type ",help" to see all available meta-commands
<VG234>Hmm.. apropos only shows the apropos procedure. If I type the name of the defined function, I get the same(the procedure). What if I don't remember the name of the procedure? How do I find it?
<davexunit>,apropos
<davexunit>read the documentation
<davexunit>if you can remember part of the name then ,apropos will help you identify it
<VG234>Here is what I get guile> ,apropos ex
<VG234>
<VG234>In standard input:
<VG234> 19: 0* (unquote apropos)
<VG234>
<VG234>standard input:19:1: In expression (unquote apropos):
<VG234>standard input:19:1: Unbound variable: unquote
<VG234>Backtrace:
<VG234>ABORT: (unbound-variable)
<VG234>guile> ERROR: Unbound variable: ex
<VG234>ABORT: (unbound-variable)
<davexunit>what version of guile?
<davexunit>are you actually at the REPL?
<davexunit>',apropos ex' is a totally valid metacommand
<VG234>guile> (version)
<VG234>"1.8.8"
<davexunit>so something is wrong with your setup
<davexunit>wow.
<davexunit>that's ancient.
<davexunit>I'm giving instructions for Guile 2.0.x
<VG234>Really. Hmm..
<davexunit>1.8.8 has been unsupported for years
<VG234>Ah. I see.
<davexunit>2.0.11 is the latest release. I recommend updating to that version.
<VG234>OK. let me see what I can do.
<VG234>I'm using cygwin should I go windows side or cywin side?
<davexunit>oh you're on windows?
<davexunit>I've never used guile on windows so I don't know what the story is there
<VG234>OK. Let me check.
<davexunit>I suggest posting to the guile-user mailing list about your specific issues so that more people have a chance to see it
<davexunit>specifically people that don't use IRC that might know a thing or two about cygwin
<VG234>If there is a windows version, I'll use it. I'm using guile through emacs for windows. IT's a hybrid setup so I can take advantage of both worlds.
<VG234>davexunit: thanks for the help.
<roelj>Just for the record, MSYS2 ships with Guile 2.0 for Windows..
<davexunit>oh really? didn't know that
<roelj>Yeah, I used it for a school project.
<mark_weaver>CustosLimen: thanks for the bug report and patch! I'll try to study the issue sometime in the next week or two, and in any case will make sure to do so before Guile 2.0.12 is released. I'm sorry I can't promise to do it sooner, but right now I've got a lot on my plate, and also that's old code that I've never studied carefully.
<mark_weaver>but in the meantime, if the fix works for you, go ahead and apply it on your own systems, and I'll make sure this issue is addressed for the next release.
<mark_weaver>maybe civodul or wingo can take a look sooner than that, but I cannot speak for them.
<mark_weaver> https://bugs.gnu.org/22152
<civodul>paroneayea: didn't you write Postgres bindings recently?
<civodul>or was it davexunit?
<davexunit>civodul: paroneayea started some, yeah.
<davexunit> https://notabug.org/cwebber/guile-squee
<davexunit>not much yet. not even autotools'd
<daviid>davexunit: it is fully autotooled, I did :) check the devel branch ...
<davexunit>daviid: oh!
<davexunit>awesome
<davexunit>I happily stand corrected!
<daviid>:)
<civodul>good :-)
***jjmarin_ is now known as jjmarin
***michaniskin_ is now known as michaniskin
<paroneayea>civodul: yeah I need to spend more time on it...
<paroneayea>daviid did help tho :)
<daviid>davexunit: these 40 lower levels struct in SDL2... scary!
<turbopape>Hi guys, any one experienced this issue on geiser with guile 2.1.1 ?
<amz3>yes
<turbopape>evaling sexp before point yields this:
<amz3>geiser doesn't work with guile 2.1.1
<turbopape>ERROR: In procedure scm-error:
<turbopape>ERROR: no such language objcode
<turbopape> 0 (scm-error misc-error #f "~A ~S" ("no such language" objcode) #f)
<turbopape>ah okay ...
<turbopape>but compiling works...
<turbopape>are the geiser guys aware of this ?
<amz3>some things works
<amz3>expand macros
<CustosLimen>thanks mark_weaver
<davexunit>turbopape: https://github.com/jaor/geiser/issues/112
<davexunit>oh
<davexunit>I see you already know
<turbopape>Oh yeah I've seen it, thank you davexunit :
<turbopape>:)
<davexunit>the fix is likely simple, but I haven't had the time or motivation to get my hands dirty and fix it
<turbopape>can you explain it to me davexunit? maybe I'll give it a shot ?
<paroneayea>o/
<paroneayea>turbopape: I have some similar problems
<paroneayea>with geiser and latest guile
<paroneayea>I think it's known that work needs to be done to update it to the 2.1/2.2x series
<davexunit>turbopape: see the IRC quote in the issue
<davexunit>wingo explains
<turbopape>yep paroneayea. as far as I understand, that has a lot to do with the new VMs etc...
<turbopape>okay davexunit, will try to wrap my head around it
<paroneayea>had an interesting conversation with Jonathan Rees of the scheme w7 capability security kernel
<paroneayea>I used to work with him though didn't know about any of those things then; was also nice to catch up with him. but he pointed me in some intersting areas to research, assuming I do ever pick up that thread to explore
<paroneayea>so many interesting things to work on
<civodul>paroneayea: you get to meet all the Scheme superstars!
<turbopape>davexunit: what elisp file do I have to load to have my local geiser fork running in my machine plz ?
<turbopape>(load-file .../geiser.el), right ?
<turbopape>yes that was this.
<turbopape>I made a pull request to geiser with the test upon guile version, if it is strictly superior to 2.0.X we use bytecode and laod-thunk-from-memry !
<turbopape>So now it shall be working for 2.1.1 :)
<paroneayea>turbofail: oh nice!