IRC channel logs

2015-11-30.log

back to list of logs

<davexunit>I thought of steve ballmer yelling "DEVELOPERS DEVELOPERS ..."
<davexunit>and then I turned it into a functional programming joke
<adhoc>davexunit: starting with one of the most disturbing videos ...
<paroneayea> .---
<paroneayea> / \\
<paroneayea> "G > <
<paroneayea> __" C_ DEVELOPERS DEVELOPERS
<paroneayea> / \\__\\ \\ DEVELOPERS
<adhoc>o_O
<davexunit>hahahaha
<adhoc>i don't know why, but i had an admiral akbar moment there with i saw that
<paroneayea>that's no combinator!
<rm-r>hello
<rm-r>i have question
<rm-r>C is compiled to assembly code, next that asm code is making a elf, how scheme guile doing this ?
<rm-r>its translating to assembler or what ?
<ft>Guile does not compile to native code. It compiles to byte-code that is run by its vm.
<rm-r>okay
<rm-r>vm communicates to processor instructions
<rm-r>?
<davexunit>the vm is a native application
<davexunit>written in C
<rm-r>hmm okay
<rm-r>but
<rm-r>how processor know how to execute that programs
<rm-r>they must use processor instructions
<davexunit>the VM is written in C, which compiles to a native executable i.e. something that the processor can work with
<rm-r>oh
<rm-r>hmmm
<rm-r>im still dont get it ;p
<rm-r>i need deeper explaination
<davexunit>what specifically is confusing?
<rm-r>hmmm
<rm-r>im have scheme source code
<rm-r>im compile it to byte code
<rm-r>vm interpreter that ?
<davexunit>yes
<rm-r>interpreter it to what
<rm-r>or wait
<rm-r>for best
<rm-r>ill read source code of that vm
<davexunit>those VM instructions trigger the relevant things in the VM
<rm-r>if its written in c
<rm-r>and ill figure it out maybe
<rm-r>:)
<rm-r>thats the idea
<rm-r>relevant things in the VM
<rm-r>things like what ?
<davexunit>it's as if the guile program is running on a special chip made for running guile programs
<davexunit>rm-r: adding numbers, for instances
<davexunit>instance*
<rm-r>adding numbers to what
<davexunit>are you trolling?
<rm-r>? -.-
<davexunit>the VM understands a set of primitive operations. every guile program is defined in terms of those primitive operations.
<rm-r>nah im asking where this adding numbers
<rm-r> https://github.com/cky/guile
<davexunit>primitive operations include arithmetic on numbers
<rm-r>where i can find
<rm-r>these things here ?
<rm-r>which files
<davexunit>that's not the canonical guile repo
<rm-r>hmm
<davexunit>rm-r: http://git.savannah.gnu.org/cgit/guile.git/tree/libguile/vm.c
<rm-r>thanks
<davexunit>yw
<rm-r>oh i get it
<rm-r>its know how to contact to processor cuz vm is written in c, c is compiled to assembler
<rm-r>so its working like that
<rm-r>ok :)
<davexunit>yes, that's the whole point
<rm-r>where is main function
<rm-r>of it ?
<rm-r>oh okay
<rm-r>im found this
<rm-r>thanks, time to sleep, night p/
<nalaginrut>afternoon guilers~
<paroneayea> http://www.safetyresearch.net/blog/articles/toyota-unintended-acceleration-and-big-bowl-%E2%80%9Cspaghetti%E2%80%9D-code yikes! 10k global variables
***lloda`` is now known as lloda
<amz3>o/
<amz3>sneek: help
<dsmith-work>Monday Greetings, Guilers
***dje is now known as xdje