IRC channel logs

2015-11-07.log

back to list of logs

<nalaginrut>alright, all works done
<nalaginrut>ACTION go sleep..
<nalaginrut>.zzZZZZ
<codemac>what kind of string can go into read-string!/partial ?
<codemac>I do a (let ((strtouse "")) (read-string!/partial strtouse port 0 10)) and it obviously fails, as strtouse is immutable
<codemac>Is there a 'make-mutable-string' or something?
<dart>I, i have just compiled guile 2.1.1 on osx from sources, installed geiser on emacs, but when i try to evaluate something with C-x C-e i get "Error: no such language objcode". How can i solve it ?
<dart>*Hi
<Xe>how would I make a HTTP request on a domain socket in guile?
<davexunit>Xe: see (http request)
<Xe>where specifically / do you know of a code example?
<davexunit>the write-request procedure will right an http request object to a port
<davexunit>Xe: see section 7.3 of the manual
<davexunit>full of good docs including examples
<Xe>how would I format the URI to correlate it is a unix socket and the path in the socket?
<Xe>and i don't see the examples in 7.3
<Xe>oh
<davexunit>not knowing how to connect to a unix domain socket is a separate issue
<Xe>they're in their own section and not inline
<davexunit>artanis is on the HN front page: https://news.ycombinator.com/item?id=10522631
<profan>so whats the deal with the API reference? things listed as functions are in fact macros in a few places
<profan>pretty much every function that deals with booleans as an example
<ArneBab>Guile Emacs doesn’t load an *.el file in the folder where I started it. Is there a difference in the LOAD path? Cannot open load file: no such file or directory, htmlize
<androclus>15:06 *** galex-713 QUIT Quit: ERC (IRC client for Emacs 24.5.1)
<taylan>ArneBab: I didn't know Emacs loads files from the dir it was started in?
<ArneBab>I think it does (or I missed that error all the time)
<ArneBab>adding -L @abs_top_srcdir@ worked.
<ArneBab>(in my automakefile)
<ArneBab>Makefile.am
<ArneBab>Guile Emacs can build my PhD-thesis! (org-mode export to latex)
<amz3>héllo
<amz3>is it correct that eta-expansion can be replaced with delay/force in guile?
<fikusz>hi, I'm new to guile and trying to get a simple scm_shell shell within a GTK+ application
<fikusz>I imagine I need to do this on a separate thread from gtk_main
<fikusz>and if I want to interact with gtk, somehow get the scm_shell to call the gtk locks
<fikusz>anyone done this before? maybe there's some scaffolding for this?
<fikusz>thanks
<ArneBab>IIRC there’s a guide for that in the guile manual
<ArneBab> http://www.gnu.org/software/guile/manual/guile.html#Linking-Guile-into-Programs
<ArneBab>I did not do that before, though
<ArneBab> http://www.gnu.org/software/guile/manual/guile.html#Dia-Structure
<ArneBab>fikusz: ^ this could help
<fikusz>ArneBab: thanks, will check it out
<ArneBab>have fun!
<amz3>Woot! I've got recursive queries working with a tuple database using minikanren:)
<dmiles_afk>Horray!
<davexunit>sounds cool
<Korhonen>So I compiled the "live guile" using portage with an overlay which is 2.2 after that, it wants to recompile two programs, one, automake can't compile because it says that it can't link to libguile
<Korhonen>Even though locate finds it at /usr/lib64/libguile-2-2.so
<davexunit>is /usr/lib64 on the library path?
<davexunit>I don't use gentoo so I don't really have a clue what is causing the issue
<artyom-poptsov>Korhonen: Hi. Could you please post Automake building logs with the described error somewhere and post a link here?
<artyom-poptsov>It at least could give people here a chance to look through the logs and (probably) a chance to figure out what's wrong.
<cestdiego>hello guys, is there some kind of MELPA for guile?
<mark_weaver>sneek: guildhall?
<sneek>Someone once said guildhall is https://github.com/ijp/guildhall/wiki/Getting-Started
<mark_weaver>cestdiego: ^^
<mark_weaver>it's not built-in yet, nor is the repository there official, but there are many useful libraries available there, and guildhall is likely to become official at some point.
<cestdiego>thank you mark_weaver
<cestdiego>is sneek a bot ?
<mark_weaver>yes
<mark_weaver>sneek: botsnack
<sneek>:)
<ArneBab>mark_weaver: what would be needed to make guildhall official? (ideally to have it available with guile)
<amz3>I'm trying to build a stream of lines from a file
<amz3>using with-input-from-file
<amz3> https://friendpaste.com/56a5fDxmTNjKFueAarU1fo
<amz3>neither does call-with-input-file doesn't work as I expect
<amz3>what I expect is not what is documented
<amz3> https://www.gnu.org/software/guile/manual/html_node/File-Ports.html#index-with_002dinput_002dfrom_002dfile
<amz3>the port is closed when the thunk returns, and the thunk returns the (broken) stream
<rlb>mark_weaver: I've been meaning to take a look at guildhall - wondering what the security/verification model is, i.e. is it at least using https (maven wasn't for a long time...), and what's the model with respect to package integrity, authenticity, etc. I'll probably poke around in a while.
<amz3>I think it's not possible to improve the situation, because no outer form can be aware of what happens in the stream
<amz3>*can't
<davexunit>wingo: Yukihiro Matsumoto, creator of Ruby, tweeted your "type folding in guile" article.
<davexunit>pretty cool for Guile to be on his radar.
<davexunit>my websocket server is working!
<davexunit>it's so cool to see this actually work
<daviid>davexunit: great!
<davexunit>I still need to handle things like fragmented messages and add error handling, but all the essentials are in place.
<amz3>davexunit: congrats!
<amz3>btw I'm trying (ice-9 json) found the implementation in activitystuff
<davexunit>amz3: cool :)
<davexunit>ACTION still needs to clean that patch up on guile-devel
<ArneBab>amz3: I guess you’ll have to open the port and keep it open
<amz3>ArneBab: yes, I had to write a custom proc and close the port only when the stream is finished
<ArneBab>so you checked for EOF?
<amz3>yes
<amz3>ArneBab: https://friendpaste.com/18wJtR5eC4i8fSA15ovU5B
<amz3>improvements welcome :)
<ArneBab>amz3: you could ask (eof-object? (peek-char port))
<ArneBab> https://www.gnu.org/software/guile/manual/html_node/Reading.html
<amz3>thx!
<amz3>Now I recall that I don't use eof-object? because the file has a specific layout, it's a json file which is a list of dict
<amz3>each line is a dict except the first and the last each are respectively [ and ]
<amz3>so I "drop" the first line and check for a single char line as the last line of the file
<amz3>so instead of reading the 50G file in one go, I read line by line
<amz3>the file in question is "wikidata json dump"
<amz3>sneek: wikidata?
<amz3>sneek: wikidata is a structured wiki database
<sneek>I'll keep that in mind.
<amz3>sneek: wikidata?
<sneek>I could be wrong, but wikidata is a structured wiki database
<amz3>sneek: stream?