IRC channel logs

2015-10-30.log

back to list of logs

<davexunit>wingo: great stuff! https://wingolog.org/archives/2015/10/29/type-folding-in-guile
***karswell` is now known as karswell
<taylan>vectors have a maximum size other than the amount of memory I have?
<wingo>moin
<wingo>taylan: yes, currently 2**24 elements on 32-bit and 2**56 on 64-bit
<nalaginrut>heya
<taylan>hi :)
<taylan>wingo: ah, fixnum range?
<wingo>no, less than fixnum
<wingo>the length is packed in with the type tag in the first word
<taylan>I see
<wingo>it's actually a problem on 32-bit systems; 16M slots is not that much
<wingo>probably we should change
<madsy>When using guile's FFI, such as pointer->procedure, do I have to use bytevectors for pointer arguments?
<wingo>you use "foreign pointers"
<madsy>Right, so what I'm asking is if there is a way to convert other foreign variables to pointers without going through the bytevector hoops
<madsy>Suppose I have a number, but the function expects a pointer to int32
<wingo>yeah there's no way around making a bytevector and then turning it into a pointer
<madsy>thanks
<taylan>madsy: if you do it a lot, https://github.com/taylanub/scheme-bytestructures might make things a bit nicer. I'll also eventually integrate this properly with the FFI, but it's not done yet
<madsy>taylan: Cool, I'll check it out
<taylan>(define my-int32 (bytestructure int32)) (foreign-func (bytevector->pointer (bytestructure-bytevector my-int32))). the (bytevector->pointer (bytestructure-bytevector x)) part could be made into an auxiliary function, like (bs-pointer x)
<taylan>generally the library is veeery verbose. need to do something about that. importing with a renamer that turns 'bytestructure-' into 'bs-' might provide some relief for the time being.
<ArneBab>wingo: thank you for your article! I love the way you share your understanding.
<wingo>tx :)
<mario-goulart>add1
<civodul>Hello Guilers!
<madsy>hello :)
<davexunit>is it released yet? ;)
<civodul>ACTION hides
<davexunit>;)
<wingo>civodul: are there changes you want into 2.0.12?
<wingo>i thought we left our conversation in that the foreign object thing was acceptable
<dsmith-work>Happy Friday, Guilers!!
<civodul>wingo: sort-of acceptable, but we should summarize it and/or get mark_weaver to comment
<civodul>rotty: your (old!) SRFI-25 patch LGTM!
<civodul>unless mark_weaver or wingo objects, it's OK for stable-2.0
<civodul>feeling idle? pick an item of you choice at http://debbugs.gnu.org/cgi/pkgreport.cgi?pkg=guile and win all our recognition!
<civodul>*your
<lloda>#18224 should be closed, that was fixed in master by eb3d623da57e6d31a58d95f932345fb761f9b701, stable will probably have to wait for 2.2
<civodul>lloda: could you email 18224-done@debbugs.gnu.org with this information?
<civodul>wingo: nice post on unboxing, it's great to see the big picture this clearly
<lloda>civodul: done
<civodul>thanks!
<davexunit>civodul: there's an sxml patch in there from rekado that seems pretty good to me regarding namespaces
<davexunit> http://debbugs.gnu.org/cgi/bugreport.cgi?bug=20339
<davexunit>rekado: to revive this discussion, I think your patch just needs a test case added to test-suite/tests/sxml.simple.test
<civodul>yes a test case is necessary
<civodul>also make sure that the behavior is unchanged when #:namespaces is unused or empty
<civodul>the documentation needs to be updated to
<davexunit>rekado: and then do you need copyright assignment done?
<davexunit>civodul: the actual code change looks fine to you, right?
<civodul>overall, but i haven't looked very carefully
<civodul>i rely on the two of you here :-)
<civodul>davexunit: rekado is on file, regarding copyright assignment, so no problem here
<paroneayea>mark_weaver: ping
<paroneayea>mark_weaver: my orgmode agenda is reminding me to remind you about the stuff needed to get https support in :)
<davexunit>hehe, this is why we should release more often. look at how many people come out of the woodwork when they know release time is near!
<paroneayea>:)
<davexunit>patches come to the surface that we all forgot about :)
<dsmith-work>#21515 should be closed. Recent updates by wingo seem to have made it go away
<daviid>#18570 has been fixed as well, but i can't remeber by which commit
<daviid>I'm going to email 18570-done@debbugs.gnu.org do you just repeat 18570-done in the subject?
<daviid>or empty subject maybe, it seems it's built as part of the mial processing ?
<daviid>^^ anyone ?
<ArneBab>how about the windows fixes mentioned in the mailing list?
<daviid>ok, i just found out the subhject is ignored: "The Subject of the message is ignored, except for generating the Subject of the reply..."