IRC channel logs

2015-10-23.log

back to list of logs

<amz3>karhunguixi: yes it's only shadows for the current scope
<karhunguixi>right
<amz3>for instance you do something like (define map string-map) in a module, if you don't import that bindings in another module map will be vanilla map
<amz3>mind the fact, that the old map is not erased, just shadowed
<amz3>you can do something like (define old-map map) and then (define map string-map)
<amz3>old-map will be the new name of 'map procedure'
<karhunguixi>i'm struggling a bit to understand what is going on here. "(define old-map map)" does this make a new map called old-map?
<paroneayea>karhunguixi: it creates a new variable which points to our original map procedure
<karhunguixi>ok, and "(define map string-map)" redefines the map procedure as string-map, right?
<karhunguixi>i'm off, thanks for all your help
<davexunit>good evening, guilers.
<nalaginrut>morning guilers~
<nalaginrut>seems fencepost is done?
<nalaginrut>down
<mark_weaver>nalaginrut: not for me
<mark_weaver>I'm logged into it now
<mark_weaver>and I just logged in again successfully
<nalaginrut>Could not connect to fencepost.gnu.org: Host lookup failed: fencepost.gnu.org: Name or service not known
<nalaginrut>alright, I have to figure it out...
<nalaginrut>ok, I started dnsmasq, then it works now
<nalaginrut>mark_weaver: thanks ;-)
<mark_weaver>nalaginrut: np!
<amz3>héllo :)
<thorwil>hi!
<artyom-poptsov>Hello everybody
<nalaginrut>migration works, with scaffolding
<amz3>ACTION doing unit tests
<amz3>I pushed a small documentation for wiredtigerz, a small set of procedures to help work with wiredtiger
<amz3> http://hypermove.net/reference-api-guile-wiredtigerz.html
<amz3>I should use it to in the soon to be written article about the "search engine"
<amz3>I should use it in the soon to be written article about a "search engine"
<nalaginrut>amz3: should I support wiredtiger?
<amz3>nalaginrut: no :)
<nalaginrut>amz3: or it's better you write a dbd for guile-dbi
<amz3>I mean, I'll figure it
<amz3>I don't know guile-dbi, I think it's only for rdbms
<amz3>how do you plan to support Redis or memcached for instance?
<nalaginrut>guile-dbi saved lot of the work, although there still be much work for DB, MVC/RM/Migration
<nalaginrut>fortunately, there're almost done
<nalaginrut>s/there/they
<amz3>you have specific drivers for them?
<nalaginrut>amz3: I want to support nosql, but don't have time for this release
<amz3>of course
<nalaginrut>I must release 0.1 end of the year, unnecessary to be delay
<nalaginrut>you can find many enhancement/fix before you want to release
<nalaginrut>so as RMS said, hold your horses...
<mbuf>nalaginrut, would it be possible to remove the animation in http://hypermove.net/reference-api-guile-wiredtigerz.html, it is distracting when reading the text
<amz3>mbuf: it's me
<amz3>huhu
<mbuf>amz3, okay
<amz3>I'll try to do something about it
<nalaginrut>amz3: html5?
<amz3>mbuf: resize the window it will disappear
<amz3>nalaginrut: yes, html video :>
<amz3>anyway you get use it, I mean I got use to it
<amz3>mbuf: are you interested in wiredtiger?
<mbuf>amz3, just want to start with guile
<amz3>this can be an option, a good option compared to SQL since you write all the code in guile, but be aware that errors in configs are not checked
<amz3>mbuf: I wrote this http://hypermove.net/do-it-yourself-a-search-engine-in-scheme-guile.html
<amz3>it's only the beginning but there is bunch of guile code
<mbuf>amz3, will go through your blog posts
<mbuf>amz3, is there a place to see available guile libraries?
<mbuf>amz3, or modules
<amz3>the mailling list is a good place to watch for new release https://lists.gnu.org/mailman/listinfo/guile-user/
<amz3>There is a list on the website https://www.gnu.org/software/guile/gnu-guile-projects.html#Core
<amz3>there is also https://github.com/ijp/guildhall/wiki/Getting-Started
<amz3>I personnaly rely on guix and search engine
<nalaginrut>amz3: the guile projects list is bit dated, I think it'll be refreshed when we have a new main page...
<mbuf>amz3, nalaginrut thanks!
<nalaginrut>hope you're happy when playing guile ;-)
<lloda>I would remove 1+ and other acquired-taste practices from the tutorial :/
<nalaginrut>maybe it's useful when we have AOT, it could be helpful to generate 'inc' instruction, just guessing... '
<nalaginrut>;-P
<artyom-poptsov>FWIW, just come across this image that compares relation between problem complexity and fun value in Haskell and Bash: https://github.com/mikeplus64/fun.sh/blob/master/funsh.png
<artyom-poptsov>I think the graph for Guile would be simiar to Haskell.
<nalaginrut>ACTION is compiling master with -j8 from 15:00 till now...
<nalaginrut>ah, done
<lloda>remember to clear your compilation cache, otherwise the new Guile may segfault weirdly (happened to me yesterday)
<nalaginrut>nice, it abort when loading colorized repl...
<nalaginrut>lloda: how to clear?
<lloda>rm -rf ~/.cache/guile/ccache/
<nalaginrut>alright, my bad, I should install guile-colorized again
<atheia>Morning Guile!
<nalaginrut>morning
<nalaginrut>artanis works fine with the master again
<nalaginrut>ACTION is so glad
<taylan>nalaginrut: Guile already optimizes (+ 1 x) to (1+ x), so using (+ 1 x) in code is fine. (IIRC we already have a VM instruction for 1+.)
<taylan>(+ x 1) too of course
<nalaginrut>taylan: nice to know that ;-)
<nalaginrut>hmmmmmmmmmmmmm..........
<nalaginrut>I believe MVC+migration works fine now, the design is finalized, just need to fix some bugs before release
<nalaginrut>well, and documentation...
<rekado>Could Guile's bytecode be further compiled to native instructions by GCC?
<davexunit>no.
<taylan>ISTR a brief mention of possible future use of GCC's new JIT feature but I don't know what it takes as input
<rekado>davexunit: "no" == "never"?
<davexunit>GCC is too different.
<davexunit>Scheme has special needs.
<davexunit>I asked about this awhile ago.
<davexunit>brb
<rekado>well, GCH compiles Haskell from a minimal language to native code; and each binary includes the fancy runtime.
<davexunit>haskell is a static language
<rekado>why would this matter?
<rekado>chicken scheme compiles to C, which can then be compiled to native code.
<davexunit>I don't know the details.
<davexunit>I just know that it won't work.
<davexunit>wingo or mark explained to me once, but I don't remember specifics.
<taylan>AFAIK Chicken only works because they use the "Cheney on the MTA" strategy, which requires one to structure the whole Scheme implementation around that, so to say
<taylan>to get tail calls and to be able to use the stack as a heap for young objects, IIRC
<rekado>yesterday I learned about the propeller chip (P8X32A), an 8 core 32 bit microcontroller with a hardware design under GPL. I'd love to be able to use a subset of Scheme to programme this fellow.
<taylan>hmm, why 64b in this time? (assuming it's new?)
<taylan>does anyone know what ijp is up to?
<taylan>rudybot last saw him 13 weeks ago and his last github commit is from 14 weeks ago
<davexunit>yeah he's been radio silent
<davexunit>I hope nothing bad happened.
<amz3>yes, I hope he was not too much under pressure to achieve the gsoc
<amz3>actually, I'm thinking about droping my current project and try something simpler
<amz3>and more useful
<daviid>I liked that funsh.png, a good idea to cook something similar and publish on our new website, maybe [not me though :) overloaded already]
<daviid>wrt gule-lib, anyone can help me to translate this to posix compliant automake code? I set -Werror in configure.ac now, and this does not pass:
<daviid>depfiles=$(addprefix $(top_srcdir)/src/,$(shell test ! -f $(doc)scmfiles || cat $(doc)scmfiles))
<daviid>the code is here, line 18: http://git.savannah.gnu.org/cgit/guile-lib.git/tree/doc/docs.mk