IRC channel logs

2015-09-23.log

back to list of logs

<daviid>paroneayea: if you're interested, I'm happy to 'autotool chain' guile-squee. I could even work on it with you, but not right now, I mean no promises, wdt?
<daviid>amz3: what is [where is] the article you wrote nalaginrut was refering to?
<paroneayea>daviid: sure, I'd be happy to have guile-squee autotool'ed
<paroneayea>and thanks :)
<daviid>cool! could you grant me write privileges?
<daviid>i suggest i create a devel branch and work on it, then master would be stable, i like this schema
<daviid>for the basic things i commit, but if suspect to taste or what ever could be a diff opinion, i mail before
<daviid>also, we could ask for a savannah nongnu page wdt? I felle much more confortable using savannah, I can do the admin prep and ask them
<paroneayea>daviid: I'll look at write privileges; maybe a good start for the moment is to put up a branch on notabug or do a git-format-patch I can apply
<paroneayea>I'm wrapped up in something atm
<daviid>no problem, let me know when you'll have granted priv and I'll start, I prefer to wait till then if you don't mind
<daviid>later also tell me what you think about a savannah nongnu project page
<daviid>sneek: later tell davexunit I did not start to work on guild init yet, but will do, I have to get guile-clutter 1.12.2 our first
<sneek>Okay.
***Fuuzetsu is now known as Guest26566
<mark_weaver>daviid: no, that should not be done within eval-when
<mark_weaver>it happens when the module is loaded, at run-time
<mark_weaver>no need to have it at expansion time
<mark_weaver>however, the result of 'dynamic-link' is not valid across sessions.
<mark_weaver>each session calls 'dynamic-link' once, when the module is loaded, and gets its own value. think of it like opening a file and getting a file descriptor.
<daviid>ok thanks
<mark_weaver>np!
***Guest26566 is now known as Fuuzetsu`
***Fuuzetsu` is now known as Fuuzetsu
<amz3>daviid: I did not wrote it, he was talking about http://cultureandempire.com
<daviid>ah ok, I thought he said that, but will read later, thanks
***__uu___ is now known as uu____
<paroneayea>ArneBab: btw, maybe see civodul's response re: wisp on the guix ML
<nalaginrut>morning guilers~
<ArneBab_>sneek: later tell wingo: this could be useful for optimizing Guile: http://static.googleusercontent.com/media/research.google.com/en//pubs/archive/37631.pdf (improving the speed of neural networks on CPUs, from Google research)
<sneek>Okay.
<ArneBab_>sneek: botsnack
<sneek>:)
<daviid>sneek: later tell amz3 wrt your chat on #scheme, related to a CPAN 'like' repo, I suggest you look at guile-lib: "Guile-Lib is intended as an accumulation place for pure-scheme Guile modules, allowing for people to cooperate integrating their generic Guile modules into a coherent library. Think a down-scaled, limited-scope CPAN for Guile."
<sneek>Okay.
<ArneBab_>paroneayea: thank you!
<ArneBab_>paroneayea: I’ll explain the reason for setlocale in #guix
<uu____>hi, I am still got stuck with my c++ integration. Here is the code I have made up. http://pastebin.com/kFqpUjNw
<uu____>when I call from guile with: (eval-mview-pose "a config file.json")
<uu____>it reports error: Wrong type (expecting string)
<uu____>what is the right way?
<roelj>When compiling Guile I see a lot of warnings regarding comparisons between signed and unsigned types. Are they worth solving? (I could attempt to do so).
<lloda>uu____: you probably wanted scm_c_define_gsubr ("eval-mview-pose", 1, 0, 0 ...) instead of scm_c_define_gsubr ("eval-mview-pose", 0, 0, 1 ...)
<uu____>lloda: I am referencing http://lonelycactus.com/guilebook/x2109.html
<uu____>and I have to admit that I do not understand the params for scm_c_define_gsubr very much, what is the difference betwwen req. and rst?
<uu____>(const char *name, int req, int opt, int rst, [Function]
<uu____>fcn)
<uu____>here is the declaration:
<lloda>required is how many arguments must be present at the start of the arglist. rest is if the function takes a rest list.
<lloda>your function takes 1 argument, so req must be 1 and rst 0.
<uu____>then what's the difference between opt and rst?
<lloda>in the body of the function, the rest argument will be a list, but the opt arguments (may be more than one) will have their own argument names
<lloda>(define (f a b #:optional opt) ...)
<lloda>you can call (f a b) or (f a b opt)
<lloda>(define (f a b . rst) ...)
<lloda>you can call (f a b) or (f a b c) or (f a b c d e)
<lloda>rst will respectively be (), (c) or (c d e)
<lloda>there's probably a better explanation of all this in the manual
<uu____>lloda: oh, thanks so much
<lloda>the lonelycactus example uses a rest list because his function takes a list
<lloda>for example you would define + to take a rest list, then you can call (+ a b) or (+ a b c) and so on
<lloda>I meam his function takes any number of arguments, which in the body of the function are a list
<uu____>lloda: you explained it so clearly
<uu____>lloda: I grasped it!
<uu____>I made the fix, and it runs right
<amz3>héllo :)
<sneek>amz3, you have 1 message.
<sneek>amz3, daviid says: wrt your chat on #scheme, related to a CPAN 'like' repo, I suggest you look at guile-lib: "Guile-Lib is intended as an accumulation place for pure-scheme Guile modules, allowing for people to cooperate integrating their generic Guile modules into a coherent library. Think a down-scaled, limited-scope CPAN for Guile."
<ArneBab_>isn’t that also what guildhall is about?
<ArneBab_>(though without the integration?)
<amz3>the integration would be a revolution
<amz3>my idea is another application of P2P social network for code development
<amz3>with in my dreams language and editor integration
<amz3>I keep rambling about that and do something else instead
<amz3>s/with //
<amz3>try to do something will be more correct
<ArneBab_>something like getting notified when someone else provides new functions or a remote API changes?
<amz3>yes that would be features of the system
<amz3>in my dream this system will make stackoverflow, pastebin, github and CPAN irrevelant
<amz3>the editor integration can be omitted, but you need something in the source that says "this proc comes from gnunet://guildhall/ijp/bloomfilter"
<amz3>with full version information, something like go does
<amz3>and also code search, for instance someone can search for all uses of (ice-9 match) and have examples of this code
<amz3>it's easy to come up with ideas, when you set your imagination loose :))
<amz3>maybe it's just some persons
<davexunit>ACTION is now a moderator of r/guile
<davexunit>oh and r/guix
<amz3>can I post dragons pics? #please
<davexunit> https://www.reddit.com/r/guile
<davexunit>Guilers should feel free to post interesting Guile-related things here
<davexunit>and help make it active
<paroneayea>davexunit: noted!
<amz3>what the policy difference between r/guile and the ML
<amz3>user ML i mean
<amz3>should I prefer r/guile to discuss and the ML for release annoucement something like that?
<davexunit>amz3: the mailing list is the central place for discussions
<davexunit>like this IRC channel
<davexunit>r/guile isn't a replacement for anything
<davexunit>having a presence on Reddit means that maybe some more people will learn about Guile.
<davexunit>and serves as a bit of a news feed for some
<paroneayea>subreddits are good for visibility of the "I'm bored at work, what's happening in areas I care about" variety
<davexunit>yeah, that's a nice way to put it :)
<davexunit>r/guix has a few subscribers now
<davexunit>it's a good way to get news and blog posts circulated
<davexunit>outside of our own little central hub here on IRC and the mailing list
<civodul>oh https://www.reddit.com/r/guix
<civodul>davexunit: can you change "GUIX" to "Guix" there? :-)
<davexunit>civodul: I've asked
<davexunit>and there's complications
<davexunit>subreddit names can't be changed
<davexunit>I might try to appeal to some reddit admin about it
<davexunit>because the subreddit is established and people read it
<davexunit>so I'd just like the name to be fixed
<civodul>ok
<davexunit>unfortunate :(
<davexunit>I don't know why people keep thinking guix is an acronym :(
<civodul>maybe people don't pay a lot of attention to spelling in general :-)
<davexunit>that's true
<zacts>I think of guix as geeks sometimes
<zacts>like a fancy spelling for 'geeks'
<zacts>or a pun on it
<zacts>(don't know if this is correct)
<wleslie>it sounds like that kind of paint
<wleslie>guache?
<civodul>zacts: that's correct
<zacts>cool
<zacts>wleslie: I think the pronunciation of guix is 'geeks'
<wleslie>well yes, I know that's the pronunciation
<wleslie>but it's not how I read it
<wleslie>it took a long time for me to pronounce 'guile' correctly in my head too
<wleslie>and gweeks (like gauche) is not far from how it would sound in my inner-city accent
<wleslie>(bed)
<zacts>wleslie: guile is also a word in english though
<zacts>I don't know if they chose the project name for guile as a pun on the english word, or not
<zacts>but guile I think _is_ an acronym
<zacts>or is it not?
<zacts>the homepage mentions, 'the GNU Ubiquitous Intelligent Language for Extension'
<zacts> http://gnu.org/s/guile
<zacts>davexunit: so perhaps that's why people think guix may be an acronym
<zacts>which would make sense to me from an initial impression, especially since guix makes heavy use of guile, and most gnu projects are acronyms
<zacts>and Hurd is even a recursive one
<amz3>:)
<davexunit>zacts: yeah, that's likely the reason.
<lloda>AFAIU Guile /is/ chosen for the english word, after Scheme, quite like Racket. GUILE is a 'backronym'
<lloda>but I wasn't present at the naming so I may be wrong
<civodul>there's also the possibility of a pun with "Guy L. (Steele)"
<daviid>haha
<davexunit>hehe never thought of that
<davexunit>I wish Guy Steele still participated in the Scheme community. guess he doesn't think it's a good language these days.
<civodul>i guess he's not married to any single language
<civodul>he's worked on a large number of them already
<davexunit>which makes sense
<paroneayea>ArneBab_: ping
<amz3>remi`bd: unbelievable you are everywhere i go
<remi`bd>well, #guile & #guix & #gnunet
<paroneayea>okay
<paroneayea>this is awesome
<remi`bd>indeed.