IRC channel logs

2015-09-07.log

back to list of logs

***heroux_ is now known as heroux
***_hanhart_ is now known as _hanhart
***adhoc_ is now known as adhoc
<nalaginrut>morning guilers~
***wleslie_ is now known as wleslie
<nalaginrut>so sad, gmail is very unstable for me
<paroneayea>hey thanks for that tip taylanub
<paroneayea>I updated my blogpost accordingly
<amz3>héllo :)
<mark_weaver>sneek: seen ijp?
<sneek>I last saw ijp on Jul 08 at 10:14 am UTC, saying: probably negligible if any.
<civodul>Hello Guilers!
<wleslie>hi ludo!
<nalaginrut>heya
<os_>hi, guile-gnome 2.16.3 link is broken in this page: https://www.gnu.org/software/guile-gnome/download.html
<os_>ok, i will use the mailist
***petercom1and is now known as petercommand
<taylanub>I'd love to hear opinions on http://taylanub.github.io/doc/r7rs-hashtables.html specifically with contrast to HashTablesCowan (currently down, soon to appear as SRFI-125). please be as blunt as you can.
<adhoc>"weak and ephemeral hashtables"
<adhoc>taylanub: i've little experience with that in scheme/lisp
<adhoc>used it a bit in perl
<adhoc>is the aim that they can be lazy ?
<taylanub>ephemeral is the correct implementation, non-ephemeral weak is the fast implementation.
<adhoc>ok
<amz3>I think it's the concepet of weak reference in python
<amz3> https://docs.python.org/3.5/library/weakref.html
<amz3>but it well explained in the document
<roelj>Is there an example to simply read a file using Guile?
<taylanub>roelj: reading sexprs, or text?
<roelj>taylanub: Just text
<taylanub>roelj: you can read it line-by-line via the (ice-9 rdelim) module
<roelj>taylanub: Ok, thanks.
<taylanub>(or by other delimiters. see read-line, read-delimited, etc.)
<roelj>I think this is exactly what I was looking for.
<roelj>But I have to read first
<amz3>I always look for that module
<amz3>:))
<amz3>really
<lloda>(help) searches all modules in the path if you use (use-modules (texinfo reflection)), e.g. in ~/.guile. For example (help read-line) works even when (ice-9 rdelim) isn't loaded. Would be great if ,a worked like that, too.
<amz3>what is ,a ?
<artyom-poptsov>amz3: I think it is the standard extension of a static library: https://en.wikipedia.org/wiki/Static_library
<amz3>no, it's metacommand in guile REPL
<amz3>got it
<amz3>there is even ,d which stands for ,describe
<amz3>my ~/.guile is growing
<artyom-poptsov>Ah, I thought it was a dot before "a"
<nalaginrut>hi folks, what's the suggested graphic tools?
<nalaginrut>for drawing how to capture stack frames
<nalaginrut>hi folks, what's the suggested graphic tools?
<nalaginrut>for drawing how to capture stack frames
<davexunit>nalaginrut: do you want a guile program to produce the image?
<nalaginrut>davexunit: I'm drawing it with inkscape now, but yes, I would like to do that in the future, what's it? ;-)
<nalaginrut>I think something like Scheme-postscript would be nice
<davexunit>nalaginrut: there's a guile-rsvg
<davexunit> http://wingolog.org/projects/guile-rsvg/
<nalaginrut>davexunit: oh, gitorious is empty now
<davexunit>nalaginrut: we have a guix package
<davexunit>so there's an altnerative tarball location
<nalaginrut>hmm...I need to setup my guix environment first
<nalaginrut>maybe later
<nalaginrut>davexunit: thanks for the hint ;-)
<davexunit>nalaginrut: http://wingolog.org/pub/guile-rsvg/
<davexunit>tarballs should be there
<davexunit>thanks to 'guix edit guile-rsvg' for opening it in emacs automagically :)
<nalaginrut>seems I failed to compile it
<nalaginrut>LIBRSVG_MAJOR_VERSION' undeclared
<nalaginrut>I've installed librsvg-devel
<alezost>davexunit: you can also use "M-x guix-edit"
<daviid>nalaginrut: see guile-charting as well
<davexunit>alezost: ;)
<davexunit>I don't seem to have that, though.
<davexunit>guess my emacs interface is busted.
<paroneayea>hopefully today will be a plesant day with guile and implementing json-ld
<paroneayea>let's see if i can have running code by the end of the day this time, as opposed to a pile of untested algorithms ;)
<davexunit>:)
<paroneayea>you know what's great? writing code that doesn't have users yet ;)
<davexunit>hell yeah
<paroneayea>it won't be great forever
<paroneayea>but for now
<paroneayea>I'm doing insane amounts of experimentation and refactoring that would be hard to get away with elsewhere
<paroneayea>I really need to get a up an actual automake file and and an easy way to dump in tests before that bites me though
<daviid>davexunit: fi, guile-srvg-2.18.1 compiles here
<paroneayea>ACTION stumbles into sussman's assigned readings for a class he's teaching http://groups.csail.mit.edu/mac/users/gjs/6.945/readings/
<paroneayea>some interesting stuff in here
<paroneayea>ACTION opens the robusthness paper on his other monitor to read idly while hacking
<davexunit>paroneayea: 2 papers by sussman and stallman in there
<davexunit>very cool
<davexunit>oh wow, still using MIT/GNU Scheme in 2015
<davexunit>I hear tell that I can sit in on such classes
<davexunit> https://groups.csail.mit.edu/mac/users/gjs/6.945/dont-panic/
<alezost>davexunit: it was added recently and should be available only if you use emacs ui from the guix git repo
<davexunit>paroneayea: you might like this: https://groups.csail.mit.edu/mac/users/gjs/6.945/psets/ps09/ps.txt
<davexunit>alezost: I thought I did
<davexunit>but I guess not
<alezost>davexunit: probably not, to check you may "M-x find-function guix-<anything>" and see if it is from your git repo
<paroneayea>davexunit: haha, edwin
<davexunit>alezost: yeah it's loading it from /gnu/store. I thought I had edited my load path to use my git repo...
<paroneayea>arg, I need to write some stuff that folds over either vhashes but doesn't process a key twice if there are older values... I'm writing a fold-unique procedure that secretly keeps track of what keys it has seen in a hash table but hides that from the user
<paroneayea>guess I'll leave myself a functional interface but secretly do this imperative thing
<daviid>ah! the dark side ... :)
<paroneayea>the alternative is to make the result being built up from the fold be a pair that contains both the real result and what's ben seen
<sneek>Okay.
<paroneayea>oooh
<paroneayea>davexunit: thanks for that actor model link
<davexunit>paroneayea: if a procedure only performs mutation on internal variables then it is still referentially transparent.
<davexunit>memoization is a good example of this.
<davexunit>or Clojure's concept of "transients"
<paroneayea>davexunit: yeah true
<paroneayea> http://groups.csail.mit.edu/mac/users/gjs/propagators/ huh
<paroneayea>seems like kind of a combination of the actor model, capabilities, and reactive programming
<paroneayea>not functional though ;)
<davexunit>paroneayea: there's a video somewhere where sussman discusses his propagaters
<davexunit>the implementation of reactive systems isn't functional, either.
<paroneayea>oh maybe it is
<paroneayea>semi-functional
<davexunit>though I don't know how different propagaters are from the "system of constraints" in SICP
<please_help>The following results in leaks but the hook still gets called while the leak is happening (so the problem isn't exactly the same): paste.lisp.org/+3BIF am I using scm-gc-register-allocation correctly?
<paroneayea>hello bipt!
<paroneayea>bipt: how goes things?
<taylanub>mark_weaver: I'm sorta kinda trying to drag R7RS-large in a better direction. I have no idea if I'm cut for this. if you have time, I'd be grateful if you could give some comments on http://taylanub.github.io/doc/r7rs-hashtables.html contrasted to http://trac.sacrideo.us/wg/wiki/HashTablesCowan?version=125 and tell me if I seem to be on the right track
<taylanub>others feel free to chime in, but I especially trust mark_weaver's judgment :)
<taylanub>oh, this might be a better link for the mentioned SRFI-125 than the trac link: http://www.ccil.org/~cowan/temp/srfi-125.html
<please_help>taylanub: exposing the hashing functions for the eq? and eqv? procedures is a hindrance for Scheme implementations with a moving garbage collector; what does that mean?