IRC channel logs

2015-08-31.log

back to list of logs

<ArneBab_>sneek: seen wingo
<sneek>wingo was here Aug 29 at 01:25 pm UTC, saying: hoo, sneekpounce.
<daviid>good news!
<ArneBab_>yepp :)
<daviid>ArneBab_: here is another relatively good design imo: http://www.lowrisc.org/
<ArneBab_>daviid: it’s not that easy, because my site has a lot of content and the structure has to fit it all — and I don’t have time (don’t want to take it due to other priorities) to embark on a serious design quest.
<daviid>ok
<ArneBab_>I can fix some parts, but I can’t currently do it right (for my website that’s been the same sorry state for the past few years)
<ArneBab_>piling hotfix on hotfix, because the right solution would be either designing a beautiful and full-featured drupal theme from scratch or importing the whole database and all the structure into another system (which then needs all the authentication and online-editing stuff Drupal has).
<daviid>oh no. use hant and write sxml
<ArneBab_>that’s the second right solution :)
<ArneBab_>it needs different views (like the book-view and the printable book view) and a host of other features which only become visible when they are missing…
<daviid>ArneBab_: save your time here because i'm not that interested :) just wanted to be nice and honest wrt my first impression...
<ArneBab_>I appreciate that a lot!
<ArneBab_>(I’ve been trying to simplify the site for years, but in small steps)
<daviid>you should ask help from someone who1s job is desinging pro web site imo
<ArneBab_>ideally I’d hire someone for that, but I don’t earn money with my sites…
<ArneBab_>and a good web designer is expensive
<ArneBab_>(understandably)
<davexunit>today I wrote a blog about using Guix to develop Ruby applications, maybe some of you will enjoy reading it: http://dthompson.us/ruby-on-guix.html
<ArneBab_>guix environment -l package.scm ← that is really cool!
<ArneBab_>I asked our second cluster whether they could provide a pre-installed guix for us so we could do exactly that :)
<davexunit>oh cool :)
<ArneBab_>no answer yet — I hope I’ll get one next week :)
<davexunit>all of my Guile projects provide a package.scm file for use with Guix.
<davexunit>makes it easy to get up and running on new machines.
<ArneBab_>I wish I had that, too…
<ArneBab_>for me the limiting part is installing guix — it feels more daunting than it is.
<ArneBab_>is there a `guix setup` command already?
<ArneBab_>⇒ create all the workers and such
<davexunit>we have a binary installation method available
<ArneBab_>the building isn’t the daunting part for me (maybe I’m strange…)
<davexunit>we don't provide such a script because there's only a few additional steps and we feel that users should be conscious of the changes made.
<ArneBab_>I’m conscious of the steps needed — but sadly that kept me from doing them on all my machines…
<davexunit>I think some quick-and-dirty deb/yum packages would be nice
<ArneBab_>a Gentoo ebuild would be cool…
<davexunit> https://gnu.org/software/guix/manual/html_node/Binary-Installation.html#Binary-Installation
<davexunit>this page is quite short. is it really daunting?
<ArneBab_>I always use the source-based one…
<davexunit>well that's always going to be a more intensive route
<ArneBab_>this is daunting: https://gnu.org/software/guix/manual/html_node/Build-Environment-Setup.html#Build-Environment-Setup
<ArneBab_>“step 4: read this other chapter on how to do this step”
<ArneBab_>that command should simply be part of the guide
<davexunit>there's a few lines of bash to run
<ArneBab_>why is it called binary installation?
<ArneBab_>yepp, but it’s necessary to switch to another part of the manual
<davexunit>ArneBab_: because you are installing pre-built binaries
<davexunit>not building from source
<ArneBab_>do they include guile?
<davexunit>yes
<ArneBab_>do they get rebuilt when I say “now use my real system, not the generic x86_64”?
<davexunit>I don't follow.
<ArneBab_>(or is that not advisable?)
<davexunit>the builds are performed the same way on all machines
<ArneBab_>I’m used to specifying -march=native for the build
<ArneBab_>(making the build non-portable)
<ArneBab_>hm, I had used -mtune=generic for my system, no wonder it felt slower…
<ArneBab_>leftover from a try to use PyInstaller…
<ArneBab_>so the question is: Are the CFLAGS part of the hash of the build — leading to a changed hash when I use different CFLAGS?
<ArneBab_>maybe I should ask that in guix…
<ArneBab_>davexunit: I’m currently installing the binary guix, by the way.
<nalaginrut>morning guilers~
<paron_remote>o/
<paron_remote>davexunit: I'm making progress on this json-ld library stuff using yer new library. I have yet to fully run things against the tests but so far coding using the api is nice
<paron_remote>(though.... once I start expanding and then compacting json-ld documents against http://www.w3.org/ns/activitystreams I start to worry that I might want to use something not alist based for access time reasons... though for now I'm just plunging ahead and sticking to the same structures)
<civodul>Hello Guilers!
<nalaginrut>heya
<waqarali>hi
<waqarali>I need help using guile. I have a module M1 that has a queue of Worker objects
<waqarali>that module M1 is used by Module 2 M2
<waqarali>now module 2 wants to get count of worker objects queue defined in M1
<davexunit>waqarali: sounds like you need to export the variable from M1
<waqarali>ok I have exported it
<waqarali>but then I need to use-modules M1 from M2 to be able to use the variable exported from M1
<davexunit>yes
<waqarali>and then I will will ne to use-modules M2 from M1 to be able to call the function of M2
<waqarali>and when I do that I get a circular dependency?
<waqarali>sorry I am very new to guile, sorry if the question is too naive
<remi`bd>waqarali: yes, you’ll have a circular dependency
<waqarali>is it valid in guile to have circular dependency
<waqarali>because I am unable to compile
<waqarali>and not sure if it is something that I am not doing write with syntax or due to circular dependecy
<waqarali>and not sure if it is something that I am not doing write with syntax or due to circular dependency
<remi`bd>what does the compiler says?
<waqarali>ah a sec
<waqarali>2951: 4 [define-module* (ngw semaphore) #:filename ...]
<waqarali>2926: 3 [resolve-imports (((ice-9 threads)) ((oop goops)) ((srfi srfi-1)) ((ngw)))]
<waqarali>2867: 2 [resolve-interface (ngw) #:select ...]
<waqarali>In unknown file:
<waqarali> ?: 1 [scm-error misc-error #f "~A ~S" ("no code for module" (ngw)) #f]
<waqarali>In ice-9/boot-9.scm:
<waqarali> 106: 0 [#<procedure 25149c0 at ice-9/boot-9.scm:97:6 (thrown-k . args)> misc-error ...]
<remi`bd>well, thus circular dependencies for modules aren’t allowed
<davexunit>you can delay the evaluation of the thing that would cause the circularity
<waqarali>ok
<waqarali>how to delay the evaluation
<remi`bd>waqarali: search for `eval-when` info "(guile) Eval When"
<remi`bd>oops; I meant: $ info "(guile) Eval When"
<taylanub>FWIW https://github.com/taylanub/scheme-bytestructures now supports basic struct field alignment. I don't know if I did it right. I should learn by the time I try to actually write some code that uses the library. :P
<lloda`>waqarali: if you're new to Scheme & Guile and you aren't writing macros I'd advise not to mess with eval-when. Please try first to remove the circular dependency by reorganizing your code.
<waqarali>ok thanks boss
<waqarali>I will try to reorganize the code and will also look at eval-when side by side
<waqarali>I will update you if I could make any progress
<waqarali>thanks for your support guys
<dsmith-work>Monday Greetings, Guilers
***michel_mno is now known as michel_mno_afk
<taylanub>how can I make stat() available via the FFI? (I want to test my bytestructures library so looking for C functions working with complex structures.) '(dynamic-func "stat" (dynamic-link))' errors, says it can't find stat.
<civodul>taylanub: i think it's __xstat and __xstat64 in libc
<civodul>with different ABIs depending on _FILE_OFFSET_SIZE
<civodul>*in glibc
<taylanub>__xstat worked indeed. I wonder what the reason of this strangeness is
<civodul>taylanub: BTW, foreign.test in Guile has a few corner cases regarding alignment, might be a useful starting point
<taylanub>aha, thanks for the pointer :)
<taylanub>ACTION reads https://refspecs.linuxbase.org/LSB_2.1.0/LSB-generic/LSB-generic/baselib-xstat-1.html and scratches head
<civodul>i like this bytestructure work
<taylanub>thanks :)
<serhart>taylanub: I was looking to build something like this with bytestructures, nice!
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
<alexshendi>Hi
<alexshendi>Hi, on gnu.org/s/guile guile is "marketed" as an extension language. Do people use guile for p
<alexshendi>"pure" scheme programming?
<davexunit>alexshendi: yes, most of us do just that.
<paroneayea>davexunit: want to see some truly monster scheme code
<alexshendi>Which version should I use 2.0.11 or the lastest 2.1 snapshot?
<paroneayea>davexunit: implementing the json-ld api algorithms verbatim https://github.com/cwebber/activitystuff/blob/new-json/activitystuff/json-ld.scm#L98 https://github.com/cwebber/activitystuff/blob/new-json/activitystuff/json-ld.scm#L272 (note: code untested, second function not yet complete)
<paroneayea> http://www.w3.org/TR/json-ld-api/#context-processing-algorithms
<davexunit>alexshendi: 2.0.11 is stable, I would recommend that.
<davexunit>2.1 and 2.2 will bring huge improvements, but if you're just starting out then I wouldn't go for the pre-release stuff.
<davexunit>paroneayea: those are some mighty big procedures
<alexshendi>davexunit: Many thanks!
<paroneayea>davexunit: yeah, I decided "well, I don't really totally understand what json-ld is doing, I guess I'll implement each procedure based off of that doc"
<paroneayea>well... it's been enlightening
<paroneayea>but I can't say that it's lead to nice to look at code :)
<davexunit>heh, you'll be able to clean it later when you have better internalized things