IRC channel logs

2015-08-27.log

back to list of logs

<hjpark>how to change scm_shell prompt name?
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
***michel_mno_afk is now known as michel_mno
<nalaginrut>ACTION is writing the blog...
<amz3>héllo :)
<ArneBab>hi :)
<ArneBab>nalaginrut: yay!
<nalaginrut>heya
<sneek>nalaginrut, you have 1 message.
<sneek>nalaginrut, davexunit says: the scheduler surely can be optimized to allocate less, but I don't think it's the culprit. also, the scheduler isn't used on a per game object basis. 10,000 is a big number, if all of those objects changed every frame then Sly couldn't keep up.
<nalaginrut>sneek: later tell davexunix I asked so for my server core design, not the problem you encounter, maybe you have more experience for the performance, anyway thanks ;-)
<sneek>Got it.
<amz3>what is the use of force and delay?
<amz3>nm, I will ask in context later
<dsmith-work>Thursday Greetings, Guilers
<taylanub>amz3: you can use them for all kinds of stuff http://sprunge.us/dCYd
<taylanub>amz3: e.g. I have a library imitating C's type system on bytevectors, and I (ab)use delay/force to allow defining recursive structures: http://sprunge.us/BdQj
<taylanub>sneek: later tell please_help I finished the macro-based version of bytestructures. I'll work on a new test suite next; meanwhile you can ping me on any bugs you find (or other issues you have).
<sneek>Okay.
<ArneBab>amz3: AFAIK: delay: calculate this at some time. force: give me the result when force returns.
<ArneBab>(= now)
<paroneayea>o/
<paroneayea>davexunit: interesting blogpost https://dzone.com/articles/martin-fowler-orm-hate
<paroneayea>although I suspect the term "ORM" is probably not welcomed with open arms here, some interesting points in there
<paroneayea>specifically of the challenges of mapping data back and forth between some representation
<paroneayea>however, ORM does usually mean a mutable representation
<paroneayea>which is maybe one way in which things become hard
<paroneayea>anyway I'm keeping it simple and dumping everything in jsonb encoded fields for activitystuff for various reasons, but it also helps worrying about that whole thing ;)
***michel_mno is now known as michel_mno_afk
<stis>evening guilers!
<davexunit>paroneayea: thanks for the link
<davexunit>pretty interesting read
<paroneayea>davexunit: np, glad you thought so
<davexunit>ORMs for Guile aren't really on my radar right now. I think first we need a solid way to represent queries without using strings.
<paroneayea>davexunit: I agree
<paroneayea>davexunit: still, using ORMs day-in day-out for other projects
<davexunit>I use ActiveRecord all the time
<paroneayea>davexunit: hard not to think about what more ideal data representations there could be, if there are any
<davexunit>I like ActiveRecord, but I don't like when I have to resort to feeding it SQL in string form
<davexunit>with all the issues of SQL injection that come with it
<davexunit>we can fix this by using real data types
<paroneayea>davexunit: yeah
<davexunit>for instance, to order by a column with ActiveRecord, I feed it a string: Users.order('age DESC')
<paroneayea>davexunit: I wish we weren't feeding SQL strings, at all.
<paroneayea>davexunit: it seems there could be some better representation than, as my brother says, "composing sentences for the database"
<davexunit>ActiveRecord has a sort-of combinator style interface, which I feel is the right approach
<davexunit>complex queries can be built on simpler ones.
<davexunit>I'm sure SQLAlchemy works similar
<davexunit>but I've only barely used it
<paroneayea>davexunit: yeah SQLAlchemy is similar there
<paroneayea>I think it's much better than django's interface, but not all mediagoblin contributors agree :)
<daviid>it's an old [orm] subject :) statice [the symbolics oop, which leaded to flavors, then clos] already had a persistent object 'mecanism', not called ORM of course. I've always wanted to work on that, pgoops, 1 day maybe, and once goops itself is fixed of course
<daviid>imo, the most advnaced system available on the planet :) is allegro cache, not free very unfortunately
<daviid>but of courese we guilers can iplement one, gcache would be a good name
<daviid>rotty1: I did find what triggers the ClutterParamSpecColor warning, here it is:
<daviid>scheme@(guile-user)> (find-property <clutter-actor> 'x-align)
<daviid>$3 = <<gparam-enum> x-align 3edcb40>
<daviid>
<daviid>does trigger the warning, which is unexpected and a guile 'problem', not a clutter one I mean
<daviid>for these non meta properties, find-property actually calls clutter_animatable_find_property, which itself calls g_object_class_find_property, and none of these methods/functions would access any other property then the one passes as an arg. so there must be some sort of lazy evaluation in guile's implementation which unexpectidlely, in this case, trigger this warning