IRC channel logs

2015-08-05.log

back to list of logs

<ArneBab>lloda: ah, ok. Thanks for the note from experience!
<sg2002>By the way, speaking of postgres. Anyone had any luck using sql-mode with it on windows?
<sg2002>Oh, wront channel. ;-)
<bipt>hi paroneayea, pretty good, how are you?
<bipt>i saw that your guile-emacs package made it into a guix release :)
<sg2002>How usable is Guix right now?
<mark_weaver>usable enough that I've been running GuixSD on my primary laptop for the last year or so
<mark_weaver>the main thing is that our package selection is relatively small right now
<mark_weaver>on the plus side, it's the first distro I've used that is both reliable and cutting edge.
<mark_weaver>because if something breaks, I can always roll back, reliably.
<mark_weaver>so I can update everything, including ordinarily scary things like glibc, without the least fear that I'll end up with a broken system.
<mark_weaver>but then there are little annoyances like the fact that in order to suspend my laptop to RAM I have to run a little script as root that writes something to /sys/power/state
<mark_weaver>the only real desktop environment we have at present is XFCE, although we have a few selected GNOME programs.
<mark_weaver>(we also have a selection of simpler window managers, like enlightenment, ratpoison, and windowmaker)
<sg2002>mark_weaver: I see. I have a question about rolling back. Can you roll back to and keep a particular version of some package? For example I see that the current emacs in Guix is 24.5. What if I need 24.4?
<mark_weaver>sg2002: if you need an older version of a particular package, the thing to do is to create a new package that inherits from our normal one, and just changes the version and source fields.
<mark_weaver>rollbacks are not per-package, but rather per-profile, or per-system.
<mark_weaver>also, even if you wanted an old version of emacs, you probably would want it linked against new versions of the underlying libraries.
<mark_weaver>sg2002: here's an example of me doing this for texinfo-4 (since texinfo-4 is more than an order of magnitude slower): http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/texinfo.scm#n71
<mark_weaver>texinfo-5 is slower, I mean.
<mark_weaver>having said that, if you happen to have an old copy of something still in /gnu/store, then you can just install that in your profile directly.
<mark_weaver>by running "guix package -i /gnu/store/...."
<mark_weaver>so, when you update your system in guix, it just creates a new entry in the grub menu and makes it the default. the old ones are still there, and so you can boot into any earlier generation of the system.
<mark_weaver>and that allows fearless experimentation with the fundamental libraries, boot process, etc.
<sg2002>mark_weaver: I've played a little bit with nixos and understand the basics. My concern is that sometimes I have to replicate some very specific(read: obsolete) configuration. Nowadays my distribution of choice for this is arch, because of aur. Do you think that eventualy I'd be able replace arch with guix? And of course the major advantage would be the ease of sharing of those configurations.
<mark_weaver>how does arch support replicating very specific obsolete configurations?
<mark_weaver>in guix, it can be done by running guix from a git checkout, and going back to some older commit.
<mark_weaver>that, combined with your OS configuration file, is sufficient to reproduce an exact system at any point in the past.
<mark_weaver>so you might want to put your OS config in version control as well.
<mark_weaver>I run out of a private git branch, and periodically rebase it on upstream master
<mark_weaver>run guix out of a private git branch, that is
<mark_weaver>that allows me to introduce and easily maintain arbitrary local modifications to my copy of guix.
<sg2002>mark_weaver: Arch has a library of recipies for building old major versions of packages. For example if I want emacs 22 and python 2.4 I can get it somewhat easily in current arch.
<mark_weaver>ah, well, it's easy to do that, but we don't maintain anything like that out of the box.
<mark_weaver>but I should mention that it sounds like the arch solution you mention above doesn't exactly replicate an old configuration, because although you might be able to recompile an old version of e.g. emacs, it will presumably be built and linked against whatever newer versions of libraries you have on the system.
<sg2002>mark_weaver: Yes, that's true.
<rlb>The immutable packaging systems definitely seem interesting.
<rlb>I've had fairly few problems just running mostly testing/unstable for a very long time, but there have been hiccups, and I have a suspicion that even though it's supposed to be safer to go from stable to stable, that it may not be.
<rlb>(in practice sometimes)
<rlb>i.e. I suspect I've missed a number of "big leap" issues by just updating to testing fairly often, and the systems that I keep mostly stable have far fewer packages.
<rlb>mark_weaver: so current half-baked proposal - maybe there are three targets: people who want to code in scheme, but would like to use some significant clj features (you?, and me sometimes), people who want to mostly prefer clojure symbols (me sometimes), and people who use the full clj dialect (me sometimes).
<rlb>mark_weaver: The first would (either by conventional practice, or tailored modules) end up with non-conflicting names for the clj functions (and no incidental genericization), the second would explicitly ask for clj to clobber things like when/count/rest/etc., and the third, well they're just in clojure.
<davexunit>does anyone know of a good css framework to use for non-designers that isn't bootstrap?
<davexunit>looking for something more minimal to use for Haunt's website
<adhoc>davexunit: we have moved to modernizr and kss
<adhoc>don't think that is the same model as bootstrap though
<adhoc>we build our CSS with a styleguide from the KSS, uses gulp
<davexunit>I'm basically looking for something small that looks good without any tweaking. I don't really want to design stuff.
<davexunit>because I suck at it.
<adhoc>understood
<adhoc>its javascript and css, its never simple or small =/
<adhoc>the nice thing is you can do most the smart responsive stuff in .css these days
<adhoc>with a little bit of triggering from some .js to embiggen/clapse certain elements like menus
<adhoc>and the KSS does most the heavy lifting there
<adhoc>the styleguide driven development model means you put examples in your .kss file, compile and view it straight away
<davexunit>adhoc: I should also point out that this is for a static site which I do not intend to run any JS on besides piwik analytics.
<adhoc>ok fair enough =)
<davexunit>:)
<adhoc>actually piwik is something that i'm still interested in
<adhoc>we were running it for a long time until security concerns, we disabled it
<adhoc>now, with lots more development we need to look at it again because GA is becoming useless
<adhoc>reporting on 5% of your traffic isn't statistically significant =(
<davexunit>piwik respects the "do not track" setting of browsers
<davexunit>so firefox users among others will probably be mostly filtered out
<davexunit>I would just use bootstrap because I'm familiar with it but the CSS isn't actually source code
<davexunit>it's generated from LESS
<davexunit>and I don't have or want the LESS toolchain
<adhoc>davexunit: understood, i'm not reall keen on the KSS+SASS toolchain either
<adhoc>but its a neccessary evil in our case
<adhoc>"our" == work
<nalaginrut>morning guilers~
<artyom-poptsov>Good morning, nalaginrut
<nalaginrut>heya
<nalaginrut>mark_weaver: do you still have the link about tail-call once you've pointed me to understand proper tail call in es6? I failed to find it in my bookmark ;-)
***michel_mno_afk is now known as michel_mno
<mark_weaver>nalaginrut: https://web.archive.org/web/20131018025351/http://bbenvie.com/articles/2013-01-06/JavaScript-ES6-Has-Tail-Call-Optimization
<nalaginrut>mark_weaver: that's it, thank you very much ;-)
<mark_weaver>you're welcome!
<amz3>héllo
<amz3>exwm looks good
<nalaginrut>amz3: yeah, I saw it
<nalaginrut> https://github.com/ch11ng/exwm
<nalaginrut>frankly, I think this should be tried in Hurd
<amz3>^^
<amz3>daviid: does guile-cairo support pdf?
<csed>nalaginrut: If this works, I will find you and I will sex you for linking it.
<csed>Multiple times, probably.
<amz3>??
<amz3>I imagine guixsd hurd with emacs architecture bottom-up
<amz3>csed: I don't think it's way good way to express your interest in exwm or else. This bound to fail :p
<csed>amz3: Probably... probably.
<csed>But, Emacs as a WM.
<csed>Yes.
<amz3>csed: no really, it doesn't work.
<amz3>yes emacs as WM looks good
<amz3>I should try it, but I promised myself to have a look a guile-wm
<nalaginrut>csed: I probably consider it if you're a girl, well, and I have to get permission from my wife first, which seems harder than Hurd hack ;-)
<csed>nalaginrut: I'm not. I'm a Sys Admin. I'm sorry.
<nalaginrut>csed: it's not a good way in tech community, but it's fine this time ;-)
<amz3>so today I will work on flexbox
<amz3>or maybe not
<amz3>I still need to make up my mind, what awaits me in my graphdb is kind of scary
<nalaginrut>hmm...there seems no emacs-x11 on hurd
<davexunit>hehe http://this-plt-life.tumblr.com/post/36425249337/when-i-read-a-discussion-about-scheme-fundamentals
<davexunit>paroneayea: I'm sure you've seen this ^
<paroneayea>davexunit: haha yeah
<funrep>hello, i wonder where i can get sly
<funrep>gitorious seems to be down
<davexunit>funrep: hey!
<davexunit>apologies for not updating my site in forever, sly can be found here: https://git.dthompson.us/sly.git
<davexunit>(pardon the self-signed ssl cert)
<davexunit>I've been busy with other projects and haven't yet taken the time to clean up all the pointers to sly at gitorious.
<funrep>alright thanks!
<davexunit>heh, I thought this was the #sly channel. :)
***michel_mno is now known as michel_mno_afk
<paroneayea>hey bipt
<paroneayea>yeah!
<paroneayea>whoo \\o/
<paroneayea>making guixsd the only distribution to be packaging guile-emacs afaik... yet! :)