IRC channel logs

2015-07-03.log

back to list of logs

<zacts>mark_weaver: http://dspace.mit.edu/bitstream/handle/1721.1/6255/AIM-380.pdf?sequence=4
<zacts>^ you may find this interesting and entertaining
<zacts>the authors are Stallman and Sussman
<zacts>dated: september 1966
<zacts>oops
<zacts>dated: september 1976
<zacts>:-)
<zacts>also see http://dspace.mit.edu/handle/1721.1/5803
<zacts> https://github.com/mame/quine-relay <-- I love this one
<mark_weaver>zacts: thanks for the links to those papers. I've been meaning to learn more about dependency-based backtracking, a.k.a. truth maintenance, for a long time.
<mark_weaver>interesting Quine relay also
<mark_weaver>that's pretty insane
<mark_weaver>(a quine that goes through 100 languages before it finally comes back to the original to start again)
<mark_weaver>I guess they had to sacrifice brevity though :)
<mark_weaver>well, not too bad actually. about 12k
<mark_weaver>unfortunately, some of those languages lack free implementations afaik.
<adhoc>and don't have packages on ubuntu
<nalaginrut>morning guilers~
<zacts>oh, yes
<zacts>yeah that's sad about the non-free languages on the quine relay
<zacts>I actually found out initially about the quine relay link via #minikanren on freenode
<zacts>but tbh, I really just skimmed the circular diagram of the languages, and thought it was a cool concept
<zacts>but I didn't really look further into it
<zacts>I think the computer programming linguistic term 'quine' is a reference to a reference to the logician named quine in goedel escher bach
<zacts>(but don't quote me on it)
<mark_weaver>zacts: yes, https://en.wikipedia.org/wiki/Willard_Van_Orman_Quine
<mark_weaver>some explanation of how it relates to him here: https://en.wikipedia.org/wiki/Quine_%28computing%29
<zacts>oh neat
<zacts>does guile have an interface into any of the graphviz languages?
<zacts>I may want to use guile to notate some dependency graphs
<zacts>and also to use some data generation / ML techniques to generate these too, perhaps
<zacts>ML = Machine Learning in this context (or that's what I intended)
<zacts>(not the language ML)
<nalaginrut>zacts: here's an example for you: https://github.com/NalaGinrut/nashkel/blob/master/nashkel/rbtree.scm#L364
<zacts>oh wow cool
<zacts>I guess dot is so simple I could write my own linguistic API or something into it... :-D
<zacts>that's cool nalaginrut
<nalaginrut>it appears in rbtree.scm, I made my own modification
<zacts>oh it is a lib
<zacts>nashkel is a lib
<zacts>sweet
<zacts>also there was this nodejs visualization library that was cool too
<zacts> http://d3js.org/
<zacts>^ this was it
<wleslie>d3 has nothing to do with node
<zacts>I wonder what possibilities the future may hold for d3 and guile scheme, considering that project ijp was working on
<wleslie>but it is kind of cool
<zacts>the guile --> js project
<zacts>oh wleslie nice to know
<zacts>I for some reason thought it relied on node specifically
<wleslie>it's all about building svg dom trees
<zacts>so far, personally I like the idea of d3 over even graphviz overall, from a philosophical point of view
<wleslie>just don't look at the code, it's hideous
<zacts>in that it's about effective communication of knowledge to people, and also the medium of making this data / knowledge public information
<zacts>heh yeah
<nalaginrut>nashkel hasn't done yet, but rbtree works, it's so important but I really don't have time for it...
<zacts>oh neat
<zacts>nalaginrut: I may fork it sometime, if I get the time myself or deep into scheme
<zacts>but I've found myself saying I'll do stuff, and I never do it... unfortunately
<zacts>but I'm working on this problem of mine
<nalaginrut>zacts: feel free to add more tree if you're interested in, there's meta-tree for you to avoid reinvent wheels
<zacts>I personally either get distracted really easily, or I get busy
<zacts>more the former than the latter
<nalaginrut> https://github.com/NalaGinrut/nashkel/blob/master/nashkel/meta-tree.scm
<zacts>ok
<zacts>I honestly don't have the skills currently, but if I do start scheming, then in a few months as a minimum timeline?
<zacts>>= 3 months from now I'll realistically have the skills to actually contribute to anything worthwhile like that
<zacts>anyway, perhaps a hilarious personality trait of mine. tonight I'm making a dependency graph with graphviz of all my reading and studying dependencies.
<zacts>I'm tired of textually editing this with C-like comments, although the last couple of days I've used scheme lists for my data
<zacts>I want to visualize my life data in ways that can help me see interdependencies between nodes, clusters, etc...
***michel_mno_afk is now known as michel_mno
<nalaginrut>zacts: IMO, for you need, you just want to return JSON from server-side, and take advantage of JS lib
<nalaginrut>there're various JS lib for visualization
***jjmarin_ is now known as jjmarin
<zacts>oh I see
<zacts>so d3js can go right off of json?
<civodul>Hello Guilers!