IRC channel logs

2015-06-29.log

back to list of logs

<zacts>mark_weaver: davexunit: I found a couple of neat books recently http://ocw.mit.edu/resources/res-6-011-the-art-of-insight-in-science-and-engineering-mastering-complexity-fall-2014/online-textbook/MITRES_6-011F14_art_insfin.pdf
<zacts>and https://mitpress.mit.edu/sites/default/files/titles/free_download/9780262514293_Street_Fighting_Mathematics.pdf
<zacts>just fyi
<zacts>both creative commons I think
<zacts>MIT Press too
<nalaginrut>morning guilers~
<artyom-poptsov>Hello nalaginrut
***michel_mno_afk is now known as michel_mno
<civodul>Hello Guilers!
<ksinkar>civodul: hi
<dsmith-work>Morning Greetings, Guilers
***karswell` is now known as karswell
<nalaginrut>well, ES6 has TCO and quasiquote now, we don't need any scm->js in the future ;-D
<ArneBab>there you see the legend “it was intended as a scheme” (not true) making itself real ☺
<ArneBab>“be careful what legends you tell, people might just make them real” ← old german roleplayer wisdom ☺
<ArneBab>nalaginrut: https://youtu.be/GSYNRlVqjfA?t=5m5s
<nalaginrut>hah ;-D
<paron_remote>hello *
***michel_mno is now known as michel_mno_afk
<mark_weaver>nalaginrut: does ES6 really have *guaranteed* tail call semantics?
<mark_weaver>because even GNU C has had tail call *optimization* for ages, but you can't rely on it, and in practice it can only be done in very restrictive cases.
<mark_weaver>in scheme it is not an optimization. it is a required part of the semantics.
<mark_weaver>if ES6 does have it, that would be fantastic news!
<davexunit>people give tail call recursion a hard time these days, citing clojures 'recur' macro as a better, more explicit solution
<davexunit>though 'recur' exists because the JVM doesn't support the necessary constructs for tail calls.
<ijp>recur is the worst of all possible solutions
<davexunit>haha
<davexunit>don't let clojure fans hear that
<ijp>it handles only the uninteresting case of tail calls, which could be handled better by a loop macro
<ijp>actually, from clojures POV it is just a loop macro
<davexunit>the vocal clojure fans seem convinced that they've "fixed" lisp.
<ft>But vocal fans are always convinced. :)
<davexunit>much as I'm convinced that Scheme is the best of the Lisp family. :)
<ft>Without a doubt. :)
<davexunit>but I like to think that I wouldn't tout a limitation of the host platform as a feature for the language.
<paron_remote>I'm a dual enthusiast of scheme and common lisp, if that's not heresy :)
<ijp>I'm not enthusiastic about any programming language any more
<ijp>saves a lot of time
<paron_remote>ijp, programming nihilist :)
<paron_remote>ijp: how goes the js stuff? when do we get to see the next thrilling paste? :)
<ijp>paron_remote: I've been away from it for a few days to recharge and handle various other stuff that needed handled
<ijp>paron_remote: turns out that the amb example while it included psyntax and boot-9 didn't load them all although it did load enough to run the example
<ijp>since one primitive didn't call its continuation
<ijp>since then I was working through boot-9 trying to get everything working
<ijp>I stopped at ~65% just after the call to (set-current-module the-root-module)
<ijp>there was a really annoying vtable bug that has been annoying to debug
<ijp>(redundant statement is redundant)
<paron_remote>ijp: cool, thx for the update :)