IRC channel logs

2015-06-27.log

back to list of logs

<paron_remote>hm
<paron_remote>hello!
<paron_remote>so I'm live-hacking a web application and using spawn-server and geiser to connect to it
<paron_remote>it's pretty damn nice
<paron_remote>one thing though, I'd love to set a breakpoint at a function right now
<paron_remote>I figured I'd do this at the repl:
<paron_remote>(use-modules (system vm trap-state))
<paron_remote>(add-trap-at-procedure-call! quiz-view)
<paron_remote>however, maybe it's because it's in a different thread?, but I don't see any breakpoint appearing I can debug at
<paron_remote>oh I see
<paron_remote>yeah it is per-thread, huh
<paron_remote>hm
<paron_remote>is there any method for parsing HTTP form data? or I guess it seems likely I need to do that myself
<civodul>paron_remote: you can use the debugging meta-commands, such as ",break"
<civodul>oh but yes, per-thread
<paron_remote>civodul: gotcha, thanks :)
<davexunit>hard to insert a breakpoint for code that is running in a thread outside the REPL
<paron_remote>yeah
<paron_remote>I guess a cooperative repl would be the only way to go? but would it work even there?
<paron_remote>for now I'm setting globals for objects I want to inspect and playing with them at the repl I do have ;)
<davexunit>cooperative repls have the same problem
<paron_remote>I guess that makes sense since it's still waiting at a user prompt
<paron_remote>and you'd have to interrupt it, or something, even if you could.