IRC channel logs

2015-06-03.log

back to list of logs

<please_help>The ,bt backtrace is too shallow and too low-level, anything I can do about it?
<please_help>for instance, only displaying trace from modules I whitelist, or simply displaying a longer backtrace
<mark_weaver>please_help: ",help bt" will tell you about the backtrace command. note the #:width option
<mark_weaver>I don't think we have anything to whitelist certain modules
<please_help>ok, thanks
<nalaginrut>morning guilers~
***karswell` is now known as karswell
***michel_mno_afk is now known as michel_mno
<wingo>moooo
<ArneBab_>moin :)
<dsmith-work>Wednesday Greetings, Guilers
<wingo>greets
*wingo almost done porting the optimizer over to cps2
<wingo>just the backend to go
<paroneayea>wingo: woo! :)
<paroneayea>wingo: exciting.
<ijp>wingo: is there a specific order for arguments in cps?
<ijp>to primitives
<wingo>ijp: you mean, order of evaluation?
<wingo>because e.g. vector-ref takes two arguments, the first is the vector and the second is the index
<wingo>of course order of operations is fixed already in cps
<wingo>so, i guess not quite sure what you mean
<ijp>$primcall and $call take a list of arguments (already evaluated)
<wingo>right
<ijp>are they ordered the same way as they would be in source
<wingo>yes, usually
<wingo>not sure if there are exceptions
<ijp>I'll have another look, see if I messed up
<wingo>is it a problem with a specific primitive?
<wingo>but if you are wondering about implementation, see compile-bytecode.scm and vm-engine.c
<wingo>there are all the cases there
<ijp>okay, this was my own problem
<wingo>cool
<paroneayea>ijp: I forget what it was... *someone* was telling me how https://github.com/Gozala/wisp
<paroneayea>used a javascript feature in some browsers so that the source locations in tracebacks and etc
<paroneayea>were actually in the original language (in this case, wisp)
<paroneayea>but now I can't find what that feature was
<paroneayea>but apparently it's popular in some of the cross compilers
<wingo>source maps
<wingo>is the feature name
<paroneayea>wingo: ah yes that's the one
<paroneayea>ijp: so, maybe useful to you to be aware of, or maybe you already were!
<duud>Guile's texinfo manual contains multiple references to to the r6rs manual - like this one "For complete documentation, design rationales
<duud>and further examples, we advise you to consult the “Standard Libraries” section of the Report (*note R6RS Standard Libraries: (r6rs)Standard Libraries.)." There is no corresponding texinfo file in Guile's repository but there is one for r5rs '/doc/r5rs/r5rs.texi'. Did r6rs.texi disappear somehow?
***michel_mno is now known as michel_mno_afk
<ijp>duud: no, it was never added afaik
<ijp>and it would probably be four .texi files
<duud>It would be nice if someone could add them. The person who wrote the manual obviously had them.
<duud>had the r6rs.texis
<cmhobbs>i'm not sure that this is a guile question so much as a debian question but most any apt operation i do ends with this: /sbin/ldconfig.real: /usr/local/lib/libguile-2.0.so.22.7.2-gdb.scm is not an ELF file - it has the wrong magic bytes at the start.
<cmhobbs>checking here first just in case
<cmhobbs>anyone know what that might be? guile seems to be working fine for me
<davexunit>it's benign
<cmhobbs>thanks
<cmhobbs>all my guile code still runs, i just didn't want something sinister to be happening under the hood :D
<please_help>So I have only two points in my codebase that can set a tensor record's tensor-sync property to #t. I use print debugging to check whether it's doing the right thing and it is, without a doubt. Yet I somehow still end up with tensor types that can never be synched being synched. I thought it could be (guardian) garbage collection (which modifies device memory, which is what I use to get info about the tensor), but I
<please_help>disabled it so that's not it. I realize not posting any code might makes it harder but is there anything I might want to look at? Also the backtrace isn't helpful, count argument seems to be ignored for some reason and I get an extremely shallow backtrace because of it.
<dsmith-work>cmhobbs: ldconfig only expects .so's in the various lib dirs, and complains when it sees something else.
<cmhobbs>thanks
<dsmith-work>cmhobbs: It annoys me too
<mark_weaver>cmhobbs: the problem is that the expectations of 'ldconfig' (everything in /usr/local/lib is an ELF library) conflicts with the expectations of 'gdb' regarding the locations of the *.scm file supporting gdb for libguile.
<mark_weaver>we are stuck in the middle here
<cmhobbs>ok, cool
***karswell` is now known as karswell
<ijp> http://shift-reset.com/pastes/js_abs.html // fact coming shortly
<davexunit>ijp: :D
<davexunit>you're doing god's work, son.
<duud>ijp: yes thats exiting. I would like to learn from your source code. Is it available online?
<mark_weaver>ijp: it's great to see!
<ijp>duud: I will be pushing a branch Real Soon Now
<ijp>(tm)
<duud>ijp: thx
<ijp>but it won't be generally usable for a good while yet
<davexunit>ijp: but will it be "production ready" and "web scale"?
<ijp>oh sure, it's that already
<davexunit>great.
<paroneayea>wow ijp
<paroneayea>amazing :)
*paroneayea slacked over lunch and did chapter 2 of The Reasoned Schemer
<paroneayea>so good
<davexunit>nice :)
<paroneayea>so busy, haven't been able to make it far
<davexunit>same
<davexunit>been focused on other stuff
<paroneayea>I need to pick up The Seasoned Schemer too.
<davexunit>I haven't even started that one yet
<paroneayea>and now, the little prover. So many books to read!
<davexunit>despite owning it for a year
*paroneayea tries running ijp's generated javascript in guile's js :)
<paroneayea> http://pamrel.lu/b2e4c/ well the environment loads
<paroneayea>but not the actual code :)
<ijp>yeah, but at least it runs in node
<paroneayea>and firefox :)
<paroneayea>or "iceweasel" :)
<davexunit>ahem, icecat. :P
<paroneayea>:)
<paroneayea>yes that's that I *should* be using probably :)
<paroneayea>esp given https://identi.ca/joeyh/note/OJTFg8eKTP2wrDcueLuhlQ
<davexunit>yeah
<davexunit>:(
<davexunit>what happened mozilla...
<paroneayea>sadtimes mcsads
<paroneayea>funny to read that right around the same time sourceforge is wrapping software in adware
<unknown_lamer>tragic
<unknown_lamer>but also heh, joeyh and I have wunderground in the same tile spot
<ijp>tbf, you won't notice those ads after a week or two
<davexunit>but they shouldn't be there in the first place.
<davexunit>and certainly not in debian's iceweasel
<unknown_lamer>becoming beholden to the ad industry is a path to hell
*unknown_lamer has first hand experience
<unknown_lamer>they start demanding things
<davexunit>unknown_lamer: Check Out the New Dollar Menu! http://mcdonalds.com - Sponsored
<unknown_lamer>davexunit: I see you have the new Ultimate Edition XChat(tm)
<davexunit>unknown_lamer: hmm? no I just grabbed the version from sourceforge
<davexunit>...
<davexunit>:P
<unknown_lamer>hahaha
<unknown_lamer>the guy that came up with that plan
<unknown_lamer>I hate him
<unknown_lamer>he was promoted for it too, even though it may hae led to vlc leaving >:O
<unknown_lamer>and also multiple incidents of ill will
<unknown_lamer>it sucks really, because sf.net is free software and github is evil SaaS...
<unknown_lamer>but sf.net's parent company is basically evil
<dsmith-work>Bah. Just reading the monthly update from SF. In the section about sharing GitHub files on SF, does "take advantage of SourceForge's distribution know-how" mean that ad-ware wrapper stuff?
<civodul>probably, that's definitely part of their expertise :-)