IRC channel logs

2015-05-23.log

back to list of logs

<artyom-poptsov>Hello Guilers
<artyom-poptsov>Just got Guile-SSH tunnels working.
<artyom-poptsov>This is work-in-progress though, but one could already do something like this: https://gist.github.com/artyom-poptsov/8e131ed3997df712c9e3
<ArneBab>artyom-poptsov: nice! is that a reimplementation or using ssh as library?
<please_help>is there a way to express a c for-loop in scheme without having to write a small c wrapper and calling it via the ffi?
<davexunit>please_help: I don't understand why you'd need that
<davexunit>if you're calling a foreign function, you can just loop as you would normally do in scheme and call that function
<please_help>because a library I'm wrapping exposes a macro that expands to a for loop, but obviously I can't actually use the macro myself. I need to reproduce the for loop as expanded by the macro on the scheme side.
<davexunit>you'd write a scheme loop
<davexunit>and call the relevant c functions
<please_help>also I think it's more complicated than just looping, I'll check again but as I understand, it's possibly hardware-accelerated and thus offloads to the gpu and does some fancy waiting or not if possible.
<davexunit>either way, you'll have to write a scheme version that calls the relevant foreign functions.
<davexunit>dealing with c macros can be a real pain.
<please_help>scheme function -> c function pointer possible?
<mark_weaver>yes
<mark_weaver>please_help: see procedure->pointer
<please_help>thanks
<artyom-poptsov>ArneBab: Hi. Guile-SSH is using libssh (https://www.libssh.org/) library under the hood.
<ArneBab>artyom-poptsov: ok - thanks!
<linas>so does stis have a version of prolog that works with guile?
<stis>linas: yes it is at a quite advanced stage. I have about 26000 lines of prolog which essentially most of it runs quite ok
<stis>I'm trying to improve on system so that it can accept a large base of swi prolog prolog programs
<stis>and at the same time invent new algorithms and constructs that is unique to guile-log
<stis>atm i'm developing the clustering algorithm further to get clusters of clusters working and be able to scale up to huge graphs
<stis>that is the thing I posted on the list a few days ago.
<stis>linas: see http://c-lambda.se/guile-log/ for docs, look for the prolog chapter
<stis>linas: if you want to test the code, use the latesed taged release, head is unstable
***karswell` is now known as karswell
<artyom-poptsov>According to the Guile 2.0.9 manual, 'select' procedure can be used on ports as well as file descriptors, but according to the Guile sources only file ports (backed by file descriptors) are accepted. Is there a way to perform some kind of 'select' procedure on file descriptors and custom ports simultaneously?
<artyom-poptsov>I suppose one could implement an ad hoc procedure that handles both FDs and custom ports, but probably there are other ways to do that.
***karswell` is now known as karswell
<paroneayea>oh, looks like a new "little book" is coming out
<paroneayea> https://mitpress.mit.edu/books/little-prover