IRC channel logs

2015-05-03.log

back to list of logs

***michel_mno is now known as michel_mno_afk
<paroneayea>o/
<davexunit>yo paroneayea
*davexunit hacking on AF_NETLINK support for sockets
<paroneayea>ohhhhhhhhhhhhhhhhhhh nice!
<paroneayea>davexunit: glad you're doing it :)
<paroneayea>after you said you weren't sure if you should/could touch that code, I was thinking "I hope he does anyway!"
<davexunit>paroneayea: civodul gave me the patch he was working on
<davexunit>which was a great foundation
<paroneayea>woo
<paroneayea>davexunit: btw, you know how I said I had thought that someday, maybe I'd do something like dylan/julia but more aimed at a close mapping to guile, and call it julian
<paroneayea>I thought a better name might be Alyssa
<paroneayea>after Alyssa P. Hacker from SICP
<paroneayea>silly maybe! But someday, maybe, amirite? :)
<davexunit>that would be a good name :)
<paroneayea>naming's one of the hard problems of computer science right? I have a good name, the rest should be easy then ;)
<paroneayea>(that's how it works, right?)
<davexunit>just hope you don't have to make any caches
<paroneayea>damn! hopefully not.
<davexunit>netlink sockets are working it seems
<davexunit>I still need to actually learn how to use them...
<davexunit>but, I can create the socket, connect, and write to it sucessfully.
<paroneayea>davexunit: \\o/
<davexunit>I'll have to create a client and server to test thoroughly
<paroneayea>I need to find something I'm motivated enough to hack on at the moment
<paroneayea>I'm feeling restless and like I wanna hack, but I'm also feeling too exhausted to do anything in particular
<paroneayea>frustrating!
<davexunit>I was at that point
<davexunit>and this socket project gave me some motivation
<davexunit>I'm burnt out on the postgresql service
<davexunit>for guix
<davexunit>need to ask mailing list for advice
<paroneayea>maybe I should go back to The Reasoned Schemer
<davexunit>yeah that could be enjoyable
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
***michel_mno_afk is now known as michel_mno
<jmd`>What's the best way to maintain a fifo in scheme? A list is not efficient, since one cannot push/pop the tail
<remi`bd>well, you can push/pop the tail: (append '(1 2 3) '(4)) pushes 4 on (1 2 3)
<remi`bd>see http://irreal.org/blog/?p=40 for an example of FIFO using two lists
***michel_mno is now known as michel_mno_afk
<jmd`>remi`bd: But isn't that an O(n) operation ?
<remi`bd>well, I’m not an expert, but if you maintain a pointer to the last element of your list, you might end up with a O(1) operation
<remi`bd>anyway, I believe it doesn’t matter if your list is not supposed to hold more than a few hundred elements
<remi`bd>(asymptotic complexity being only valid for large sets)
***michel_mno_afk is now known as michel_mno
<jmd`>I have (cond ((assoc-ref xxx "this") (do-something (assoc-ref xxx "this"))))
<jmd`>How can I avoid having to call assoc-ref twice?
<remi`bd>(let ((this (assoc-ref xxx "this"))) (cond …))
<remi`bd>but in this situation, if the value of (assoc-ref xxx "this") is simply #t, why not calling (do-something #t) ?
<saul>I am struggling with using namespaces in sxml. I have tried the *NAMESPACES* directive as described on http://metapaper.net/xml/ns/ but neither @@ or *NAMESPACES* seem to be known keywords. Do I need to use a module in addition to (sxml simple) ?
<saul>I see from the revisions at the bottom of http://okmij.org/ftp/Scheme/SXML.html the the @@ representation is obsolete. Even still, when I use the nested (@ (@ form, I receive an "Invalid name starting character: @" .
<saul>Would that have something to do with defining my sxml form in quasiquotes?
***michel_mno is now known as michel_mno_afk
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
<mark_weaver>jmd: (cond ((assoc-ref xxx "this") => do-something))
<jmd>mark_weaver: Thanks
<mark_weaver>np!
<mark_weaver>jmd: there's a (ice-9 q) module for simple FIFOs
<mark_weaver>see section 7.12 (Queues) of the manual
***michel_mno_afk is now known as michel_mno
<jmd>Is there an equivalent of C's __LINE__ ?
<mark_weaver>there are various tools along those lines. see 'current-source-location', 'syntax-source', and section 6.25.2 of the manual.
<mark_weaver>I could make a more specific suggestion if you give me some more context
<paroneayea>so, highly hyperbolic, but pretty fun read: http://journal.stuffwithstuff.com/2013/07/18/javascript-isnt-scheme/
<paroneayea>davexunit: oh hey, the guy who wrote the link I posted to above is the one that wrote that game programming patterns book you linked me before
<paroneayea>about the scene graph stuff, etc
<taylanub>"Usually, touching Scheme or Smalltalk inflicts an incurable disease whose primary symptom is involuntary sneering and derisive snorting in the presence of any other language." hahaha
<davexunit>paroneayea: yup, I recognized the author. just finished reading that. pretty entertaining.
<davexunit>paroneayea: I don't really like a lot of those patterns because they are completely OOP focused.
<davexunit>but the scene graph one is useful.
***michel_mno is now known as michel_mno_afk
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk