IRC channel logs

2015-04-15.log

back to list of logs

<cmhobbs>can someone point me to examples of a guile program running as a daemon and a guile program taking arguments from the command line?
<mark_weaver>cmhobbs: for command-line access, see section 4.3.3 of the manual (Command Line Handling)
<mark_weaver>regarding running as a daemon, I don't have an example handy, but we have 'primitive-fork' and 'setsid'. see section 7.2.7 of the manual (Processes)
<ijp>one of the nicer thinks about systemd is that you just have to write a config to get a daemon
<ijp>the traditional way is kind of silly
<mark_weaver>too bad systemd doesn't support any other kernel
<mark_weaver>cmhobbs: well, of course guile comes with a few built-in daemons, e.g. the web server in module/web/server.scm and module/web/server/http.scm
<mark_weaver>and the repl server in module/system/repl/server.scm
<nalaginrut>morning guilers~
<cmhobbs>mark_weaver, thanks!
<ArneBab>ijp: is it very different from what you can do with start-stop-daemon or runit?
<ArneBab>ijp: your comment just prompted me to write this: http://draketo.de/english/free-software/start-stop-daemon-runit
<ArneBab>(because asking “how is that different from <simple but scarcely documented feature>?” isn’t a useful question ☺)
<civodul>Hello Guilers!
<ArneBab>ijp: now it’s actually easy to read: http://draketo.de/files/2015-04-15-Mi-simple-daemon-openrc_2.pdf
<ArneBab>civodul: moin
<artyom-poptsov>Hi civodul
<civodul>hey
*artyom-poptsov is preparing a new Guile-DSV release
<lloda> where do I need to look to have quasiquote support in #2(...) ?
<civodul>lloda: scm_read_array in read.c, i think
<lloda>thanks
<first-healer>\\nick healer
***first-healer is now known as healer
<civodul>paroneayea: just saw your post about pipes
<civodul>not really answering, but you may be interested in http://git.savannah.gnu.org/cgit/guix.git/tree/guix/hash.scm
<civodul>gcrypt bindings for that
<civodul>more reliable than opening pipes, if that's an option for you
<davexunit>ArneBab: I improved the haunt README https://gitorious.org/haunt/haunt/source/README.md
<paroneayea>civodul: I looked into it! The main thing about it is it seemed like it would require that I resolve a few other imports of other guix libraries
<paroneayea>civodul: also, I got interested in the idea of, why is this so much harder in guile than it is in python? maybe that's worth fixing! :)
<ArneBab>sneek: later tell davexunit: nice!
<sneek>Okay.
<dsmith-work>Wednesday Greetings, Guilers
<civodul>paroneayea: it's really just two files, guix/{gcrypt.scm,hash.scm}
<civodul>i wouldn't be surprised if there were other bindings out there though :-)
<paroneayea>I do think I want to write a (open-pipe-stdports) which does a multi value return of stdin, stdout, stderr
<paroneayea>I probably will snarf the guix stuff in the meanwhile, yes :)
<paroneayea>but I do think I want that to exist in guile. I wonder how hard it would be to do?
<civodul>i agree it's useful and definitely feasible
<paroneayea>davexunit: I looked at the Haunt commit log
<paroneayea>"Eva Luator", sounds like an SICP character :)
<davexunit>paroneayea: that's because it is!
<sneek>Welcome back davexunit, you have 1 message.
<sneek>davexunit, ArneBab says: nice!
<paroneayea>ohhhh
<davexunit>:)
<paroneayea>davexunit: I didn't see it on a search
<paroneayea> http://en.wikipedia.org/wiki/Structure_and_Interpretation_of_Computer_Programs#Characters
<paroneayea>Eva Luator vs Eva Lu Ator
<davexunit>ahhh
<paroneayea>:)
<davexunit>I messed up lol
<paroneayea>oh well, still good!
<davexunit>Cy D. Fect: A "reformed C programmer."
<davexunit>hahahaha
<paroneayea>:)
<paroneayea>I need to spend some more time on SICP....
<paroneayea>I made it through section 1
<paroneayea>but that's it
<davexunit>chapter 3 was a gold mine for me
<davexunit>propagation of constraints, the circuit simulator
<paroneayea>SICM also seems fun
<davexunit>both ideas I incorporated into Sly
<paroneayea>davexunit: the circuit simulator in sly??
<paroneayea>I don't know what it is, but :)
<paroneayea> http://mitpress.mit.edu/sites/default/files/titles/content/sicm/book.html haha fun image
<davexunit>paroneayea: I took the "agenda" from the circuit simulator
<paroneayea>ahh
<paroneayea>haha http://www.amazon.com/review/R3A76ZXM413QEZ/ref=cm_cr_dp_title?ie=UTF8&ASIN=0262194554&channel=detail-glance&nodeID=283155&store=books
<paroneayea>I don't own linux
<paroneayea>(sic)
<davexunit>hahaha
<paroneayea>if only I could afford to buy a billion manuals
<paroneayea>might be a fun one to read
<davexunit>if you buy, buy from MIT press instead :)
***first-healer is now known as healer
<paroneayea>davexunit: noted :)
<paroneayea>davexunit: looking at the sicm book brings back to my mind
<paroneayea>I wish there was a "math notation for computer programmers" book
<paroneayea>written in scheme or python or something.
<davexunit>that would be nice
<davexunit>I understand math better when I can incorporate the concepts with computer programs
<paroneayea>I started re-reading my old calculus textbook and thinking, "hey, I go through some of these things every day, but I've forgotten what all these symbols map to"
<davexunit>for example: derivatives and integrals. very handy for game programming.
<paroneayea>I also struggle with papers
<paroneayea>reading them I mean
<paroneayea>because I can't think in terms of the symbols because there's been such a disconnect of time
<ijp>too much overloading to do it effectively
<paroneayea>ijp: hm?
<davexunit>I don't know if many people actually like reading those long papers
<ijp>paroneayea: what does * mean?
<paroneayea>ijp: ah I see
*davexunit saw this today http://blog.ploeh.dk/2015/04/13/less-is-more-language-features/
<davexunit>one of the things mentioned is cyclic dependencies
<davexunit>guile allows them
<davexunit>it has bitten us in guix
<davexunit>what to do?
<ijp>a sum type instead of exceptions? definitely a haskeller
<davexunit>yeah
<davexunit>take this with a grain of salt
<paroneayea>davexunit: and that article is why R5RS is all you need ;)
<paroneayea>amirite
<paroneayea>???
*ijp loads his gfdl and makes all paroneayea worst features invariant.
<davexunit>hahaha
<civodul>davexunit: interesting post
<civodul>though i find the argument against exceptions a bit weak
***michel_mno is now known as michel_mno_afk
<davexunit>civodul: me too
<daviid>meep
<sneek>daviid, you have 3 messages.
<sneek>daviid, mark_weaver says: 'remove-dot-segments' will do the wrong thing for something like .././../foo/../bar
<sneek>daviid, mark_weaver says: you need to remove all the . and .. components from the front, but keep track of how many of those were .., and then add that many .. components back to the front when the loop is finished.
<sneek>daviid, mark_weaver says: I haven't looked closely at your 'merge-paths' yet
<daviid>snekk, i knew it!
<daviid>mark_weaver: changed your name already
<daviid>tx for the review, appriaciated
<daviid>mark_weaver: i did think about that and it works, what makes you think it does not ?
<daviid>(remove-dot-segments ".././../foo/../bar")
<daviid>$17 = "../../bar"
<daviid>sneek: tx
<daviid>paroneayea: all i do is (C) fsf, till now it is what i want indeed
<daviid>mark_weaver: this corrects your name, a tipo in the commentary, and some indentation - I prefer this way for named let and (_ code) on the same line when using match: http://paste.lisp.org/+35I5 but nothing changd in the algo itself
<paroneayea>daviid: you've assigned all your stuff to the FSF?
<paroneayea>(great!)
<daviid>of topic, wrt gitorious, any one can tell me how to get/save a copy of what is there so i can reinstall somewhere else later, i've not decided yet what will do ...
<daviid>paroneayea: yes
<daviid>all my stuff
<paroneayea>daviid: did you sign something with them to do a blanket assignment?
<paroneayea>they do per-project signing right, I thought?
<daviid>paroneayea: i did sign the contribution documents, like you maybe? this was necesary to have write access to guile-gnome, clutter and g-wrap... but (C) is something else, i think, anyone can write GPL based code and assign the (C) to the fsf [i've been told...]
<paroneayea>daviid: hm, nope, I don't think that's how it works
<paroneayea>to assign copyright the FSF has to also be party to it
<paroneayea>I think
<paroneayea>so for the projects you've assigned to I believe that's true
<paroneayea>but not for all projects
<paroneayea>someone can correct me in case I'm wrong :)
<paroneayea>but I believe this is true.
<davexunit>yeah, the FSF needs to be part of that
<davexunit>but it sounds like daviid has signed the documents for guile-gnome, so it's okay?
<daviid>the (C) is who will enforce if someone or a company enfringe, from what i did read and chat here [2y ago] i can assign (C) to the fsf
<daviid>Kisê is (C) fsf, and everything actually, but if that is a problem let me know
<daviid>davexunit: could you ask maybe? i just fell happier to grant the (C) to the fsf for all i do
<davexunit>daviid: please email licensing@fsf.org
<daviid>fell/feel
<paroneayea>is grip part of guile-gnome?
<daviid>paroneayea: no
<paroneayea>I asked because I didn't think grip was a GNU project
<paroneayea>that's why I brought it up earlier on IRC
<daviid>paroneayea: it's not, not yet
<paroneayea>also sorry, I don't mean to be annoying or persnickety daviid, but I think that people have been confused about this before
<daviid>paroneayea: yes i actually did read i could, but ...
<paroneayea>eg Aaron Swartz said on his website "on death all my copyright is assigned to the FSF" but I talked to someone who said "yeah it's not that simple"
<paroneayea>anyway davexunit is probably right that you should email licensing@fsf.org if you want clarity
<paroneayea>I'm not an fsf licensing person :)
<daviid>neither do i
<paroneayea>I'm glad you're enthusiastic about assigning to the fsf :)
<paroneayea>I think that's great
<paroneayea>and don't mean to be a burden here on such things
<daviid>yeah, code is not mine, it is from and for humanity
<paroneayea>free humanity foundation :)
<daviid>:)
<daviid>we are just messengers, in that field, others in other fields, everything is ideas and art, all this pertence to hunabity
<paroneayea>whoo just 1.75 hours of contracting left then I'm done for the week
<davexunit>woo!