IRC channel logs

2015-04-10.log

back to list of logs

***cluck` is now known as cluck
<nalaginrut>morning guilers~
<cmhobbs>hello nalaginrut
<nalaginrut>hi
<daviid>dsmith-work: had to run, but tx for your help. fyi, gobject-2.0 is part of libglib2.0-dev and the user as the "glib wrapper will be built" so something is wrong but it should not be related to the lack og libgnome-dev, imo
<daviid>glib can not build without gobject. i think there were an error compiling guile-gnome or even at config time that he did not see, maybe. we'll see... but nothing will work without gobjetc being correctly build ...
<daviid>also, i'm suspicious he has a 'wrong' setup for guile tseld
<daviid>itself
<daviid>because he said that guile is in /opt, we should not have to export GUILE_LOAD_PATH, since guile knows where its 'site' dir is
<daviid>and he reported tht ,use (gnome-2) fails unless we export: maybe he has 2 guiles
<daviid>gnome-2.scm is installed in guile's site directory, as g-wrap ...
<civodul>Hello Guilers!
***michel_mno_afk is now known as michel_mno
<wingo>morning ludo :)
***jalle is now known as jockej
<dsmith-work>Happy Friday, Guilers!!
<civodul>Happy Friday, dsmith-work & all!
<daviid>yea! hf all!
<davexunit>hello guilers.
<davexunit>I had mentioned last week that I was going to write a blog post about how I do web development with guile. something that others could follow.
<davexunit>when I sat down to do it, I realized that I used a few of my own special modules to actually get stuff done.
<davexunit>in particular, I wrote a module for transforming sxml to html
<davexunit>that knows about which tags can "self close" (like <input type="text" />), and which cannot
<davexunit>among a few other things.
<davexunit>I think it would be useful for upstream guile. how does that sound?
<ArneBab_>davexunit: that sounds great!
<ArneBab_>either upstream to guile, or upstream to guildhall
<ArneBab_>publish in guildhall
<ArneBab_>(not upstream)
<davexunit>here is the module I use for guix-web http://paste.lisp.org/display/146944
<davexunit>the other important thing it handles is HTML escape codes
<davexunit>ah, yes, and the <!DOCTYPE ...> weirdness
<serhart>how is guildhall going to fit into a world with guix?
<davexunit>serhart: guildhall still has a use-case, guix is a general purpose package manager. some users don't want that, they just want an easy way to grab scheme modules.
<serhart>will guix a guildhall build system?
<davexunit>we could certainly write an import tool, like we have for some other things.
<hellekin>davexunit: FWIW in HTML5 self-closing tags look like <br> no <br/> :)
<davexunit>hellekin: really? ugh.
<davexunit>I haven't seen that anywhere.
<davexunit>thanks.
<davexunit>guess that makes this whole thing even harder to do right.
<hellekin>davexunit: well actually it's optional for void elements (br ,hr) but marks the self-closing tag for MathML, SVg, etc. (so called foreign elements)
<hellekin>void elements: area, base, br, col, embed, hr, img, input, keygen, link, menuitem, meta, param, source, track, wbr
<davexunit>I guess I should distinguish them in my sxml->html procedure
<davexunit>but only for html5. bleh.
<davexunit>I could test for the correct doctype in the tree, I suppose.
<davexunit>I want HTML to "just work" with Guile's SXML :(
<davexunit>hellekin: so the /> is optional, but valid?
<hellekin>yes sir
<davexunit>cool
<davexunit>then I suppose I am okay
<nalaginrut>davexunit: do you know the black magic of <script> in SXML? ;-P
<davexunit>nalaginrut: I use a hack with standard SXML, but since writing my own sxml->html transformer I don't need it anymore.
<davexunit>with standard sxml I do something like: (script (@ (src "...")) "")
<nalaginrut>davexunit: yeah, "" is the black magic...
<nalaginrut>I failed several times to find it
<davexunit>nalaginrut: other elements have similar issues
<davexunit>and then there's the issue of escaping HTML
<davexunit>with sxml->xml doesn't how to do, and rightfully so, because it isn't writing HTML.
<davexunit>doesn't know*
<nalaginrut>yes, so I made some hack in Artanis for escaping issues
<nalaginrut>well, SXML has its own standard, it's just similar to html
<davexunit>sxml->html is quite short, almost of the source lines are from the escape sequence table.
<davexunit>so there's not much to it if you subtract them.
<nalaginrut>davexunit: I still don't know if it's a bug in sxml module or it's SXML standard
<davexunit>nalaginrut: the <script> thing? it isn't a bug.
<davexunit>because in SXML, a tag can self-close if there are no elements within it.
<nalaginrut>someone once blame to me that sxml module has problem to use for html, but finally, we realized the problem is because SXML just similar to html
<davexunit>s/SXML/XML/
<davexunit>SXML naturally follows the XML specification, not the HTML specification.
<nalaginrut>so a veteran knows how to use it for html
<davexunit>but with a few tweaks it can be used for HTML as well!
<nalaginrut>well, I didn't realize it before
<nalaginrut>davexunit: maybe you should make a post to explain it ;-)
<nalaginrut>many newbies just don't know and treat SXML as html
<nalaginrut>of course, there's only little difference
<nalaginrut>but it could waste some time on it...
<davexunit>okay, I'll blog about it
<nalaginrut>thanks ;-)
***michel_mno is now known as michel_mno_afk
<ArneBab_>davexunit: that script is pretty cool!
<ArneBab_>s/script/module/
<ArneBab_>davexunit: why did you prefix escape-chars with %?
<davexunit>ArneBab_: because it's a global. I picked up that style from guix.
<ArneBab_>good to know - thanks!
<davexunit>glad you like the module. I imagine that someone that knows sxml better can suggest some improvements to me.
<davexunit>I'm going to make a blog post about it anyway, though.
<davexunit>for nalaginrut :)
<ArneBab_>yay!
<ijp>well, you could have done it using all the other sxml procedures that only I use, but meh
<davexunit>ijp: perhaps I should rewrite it that way, then.
<ijp>meh
<davexunit>I didn't know any better!
<davexunit>ArneBab_: this is pretty slapped together, but a half-assed blog post is better than no blog post! http://dthompson.us/rendering-html-with-sxml-and-gnu-guile.html
<davexunit>sneek: later tell nalaginrut http://dthompson.us/rendering-html-with-sxml-and-gnu-guile.html
<sneek>Will do.
<ArneBab_>I think it’s nice!
<ArneBab_>I’d put '(html on its own line to make it look less deeply indented.
<ArneBab_>it then looks more like html code
<ArneBab_>and one more example with (sxml->html instead of sxml->xml, just the same example, but how it’s right
<ArneBab_>I think it should go to the same place where sxml is
<ArneBab_>sxml->xml I mean
<ArneBab_>davexunit: ping ☺
<davexunit>ArneBab_: thanks I'll fix that
<davexunit>ArneBab_: done