IRC channel logs

2015-03-30.log

back to list of logs

<davexunit>cool, produced the same program
<davexunit>er, floorplan
<davexunit>I still can't run this on my fpga, but that was a fun experiment.
<mark_weaver>nice!
<davexunit>the results of this hack: http://paste.lisp.org/display/146617
<davexunit>compare to: https://raw.githubusercontent.com/Wolfgang-Spraul/fpgatools/master/hello_world.c
<davexunit>s/login/logic/ in my paste
<mark_weaver>davexunit: looks nice!
<davexunit>I emailed the fpgatools maintainer to see what work is required to get it to work on the FPGA in the Novena
<davexunit>I hope he writes back
<davexunit>I don't know of any other free software that can produce a bitstream capable of running on a Xilinx FPGA.
<turtleman_>hi
<turtleman_>is there a way to disable #! ... !# for block comments?
<ijp>I think so, but why?
<turtleman_>well, most other implementations i use only read the first line's #!
<turtleman_>so those scripts are incompatible with guile
<turtleman_>thats all
<ijp>well, anything I tell you is going to be incompatible with those other scripts anyway...
<turtleman_>ok, i was just wondering then
<ijp>turtleman_: you could try #!#
<turtleman_>hey thats actually pretty interesting
<turtleman_>im going to try that
<ijp>hmm, the manual only specifically says the #| syntax can be overridden
<turtleman_>i found a workaround based on your idea
<turtleman_>#!/usr/bin/env scheme
<turtleman_>; !#
<turtleman_>it works :)
<ijp>that's what I should have typed, but ah well, I pictured python/ruby/sh/etc
<nalaginrut>morning guilers~
<daviid>the autotools chain is not git aware :( i'm dreaning i guess, but i was hoping that something like $(wildcard meta/*) would select all files but the ones that are listed in .gitignore
<nalaginrut>daviid: just write some scheme script put in build-aux then call it in Makefile
<daviid>nalaginrut: do you have an example, by any chance :)
<nalaginrut>daviid: In your case, I don't have one. But when I need more powerful thing make can't provide, I would write it as Scheme scripts then call it
<nalaginrut>just like this v
<nalaginrut> https://github.com/NalaGinrut/artanis/blob/master/build-aux/gen-directive.scm
<daviid>nalaginrut: tx
<daviid>nalaginrut: you don't have a Makefile.am ? [i don't see it in the tree or am'i blind
<nalaginrut>daviid: I don't use automake, configure is enough for me
<daviid>i was looking for how th call to gen-directive
<nalaginrut>And I like to write my Makefile.in, could be more elegant
<daviid>ok
<nalaginrut>daviid: oh, gen-directive isn't used since there's better script
<nalaginrut>you can see check_texinfo.scm
<nalaginrut>and if you want to save all the results in a list, maybe you need arr=$(shell script-name)
<daviid>ok thanks a lot!
<nalaginrut>np ;-)
<daviid>nalaginrut: how would you solve this prob :)? i have this: pofdir = $(pkgdatadir)/pof then dist_pof_DATA = $(wildcard kise/pof/*) but it does not work because pof has subdirs I tried to list manually, but it ends up putting all files under $(pkgdatadir)/pof [it does not recreate the tree]
<daviid>i was hoping not to have to have subdirs Makefile.am ... but i can not find a solution because make install does not recreate even when passing [for exzample] dist_pof_DATA = kise/pof/kise.pot kise/pof/fr_BE/kise.po kise/pof/fr_BE/LC_MESSAGES/kise.mo
<nalaginrut>daviid: for subdirs, you may just `ls -l` for simplest solution
<nalaginrut>with $(shell
***Guest11351 is now known as Cork
<daviid>nalaginrut: ok, trying...
<nalaginrut>daviid: or $(shell find $(YOUR_PATH) -name *.po) I get all *.scm files in this way
<nalaginrut>please checkout my Makefile.in
<nalaginrut>sorry, `ls -l` is wrong here
<nalaginrut>please use 'find'
<nalaginrut>daviid: ^
<daviid>ok tx
<zacts>how may I start guile without a repl?
<zacts>I want to do something like: guile --no-repl -l hello.scm
<zacts>hello.scm will contain: (display "hello, world!\\n")
<zacts>I just want 'hello, world!' to be printed on the screen, and not the REPL
<nalaginrut>zacts: just "guile hello.scm"
<zacts>oh really?
<zacts>how did I miss that? lol :-D
<daviid>nalaginrut: even if i list 'manually' it does not work, install does recreate the tree, for example
<daviid> /usr/bin/install -c -m 644 kise/pof/kise.pot ./kise/pof/fr_BE/kise.po '/opt/share/kise/pof'
<daviid>will put all files in '/opt/share/kise/pof'
<daviid>so, ./kise/pof/fr_BE/kise.po ends up being in /opt/share/kise/pof and it should be in /opt/share/kise/pof/fr_BE what am'i doing wrong here ?
<nalaginrut>daviid: well, I think you have to use 'for' in bash for that
<nalaginrut>in a short, iterator
<nalaginrut>daviid: see my Makefile.in, the 'test' object
<nalaginrut>s/object/target
<daviid>looking, it is a tree as well?
<nalaginrut>I think it's flat now, since there's path as prefix before all filenames
<nalaginrut>so iterate them could be fine
<nalaginrut>daviid: anyway, you may use 'scandir' for dir trees though, in (ice-9 ftw)
<daviid>nalaginrut: sure, i know perfectly how to scan a dir in scheme, but i don't know hoa to call things from Makefile.am so it works
<daviid>the manual case i pasted is my prob, no the grabbing of the files ..
<daviid>make calls install, it passes the file list, and install fails to create the tree ...
<daviid>i understand it's a bit of topic, many thnaks for your help, but i still can not figure how to install a dir [with all subdirs...]
<daviid>just using the autotools chain i mean
<nalaginrut>daviid: I guess the problem is 'install' can't accept muti filenames? if so, you have to use 'for' to do them one by one
<nalaginrut>daviid: I'm sorry, I don't know how to do it in Makefile.am, I never use automake
<daviid>nalaginrut: it's ok, thnks
<nalaginrut>I think you can do the same in Makefile, but I confess I never use automake...
<nalaginrut>;-)
<daviid>have to go afk, tx!
<wingo>moin
<civodul>morning!
<DEREK-SON> http://tinyurl.com/nlochba
<DEREK-SON>weed does kill
<wingo>these people leave before i remember how to get ops
<ArneBab>zacts: guile -s hello.scm
<ArneBab>oh, sorry, thought I was at the end of the buffer
*davexunit thinks about a define-c-struct form that creates accessors for data in foreign pointers
<civodul>davexunit: would be nice
<davexunit>I've been really desiring it in my most recent adventures with the FFI