IRC channel logs

2015-01-15.log

back to list of logs

<cmhobbs>is it possible to fire up a guile repl in emacs without opening multi-term first?
<cmhobbs>or some other terminal
<davexunit>cmhobbs: check out geiser.el
<davexunit>once installed, you can use M-x run-guile
<cmhobbs>also is there a concept of null or nil in guile? if so, what's the keyword?
<cmhobbs>i have geiser! thanks for the tip!
<davexunit>cmhobbs: typically we use false, #f
<davexunit>various data types have their own null value
<davexunit>like "" for strings and '() for lists
<davexunit>predicates string-null? and null? test for them, respectively
<wingo>meep meep
<civodul>hey Guilers!
<nalaginrut>heya
<nalaginrut>wingo: It's 3.12s now, while Python2 costs 2.4s. I don't think I can go any further without patching guile-core ;-)
<nalaginrut>wingo: here's the code https://gist.github.com/NalaGinrut/4418448e73b65af58ffa
<wingo>cool, will look
<wingo>civodul: slot-ref was a lot slower with the goops refactor; will work on that before any merge
<civodul>oh, ok
<civodul>even once it's inlined?
<dsmith-work>Thursday Greetings, Guilers
<davexunit>another day, another one-off guile script helping me do my job.
<davexunit>thanks guile!
<dsmith-work>davexunit: yey!
<civodul>guile: ../../libguile/ports.c:2527: scm_i_port_iconv_descriptors: Assertion `pti->encoding_mode == SCM_PORT_ENCODING_MODE_ICONV' failed.
<civodul>mark_weaver: does that ring a bell? ↑
<civodul>that's for a port whose encoding is #f
<mark_weaver>civodul: yes. the last time, it was because the pti structure was getting corrupted. memory corruption caused elsewhere.
<mark_weaver>I've forgotten what the source of the corruption turned out to be.
<civodul>do you remember if something was fixed in that area?
<civodul>oh ok
<civodul>it's 2.0.9.219-e1bb7
<mark_weaver>I vaguely recall a bytevector realloc bug that might have been the cause, but I don't remember if the link was clear.
<mark_weaver>commit 1baa2159307c34683e8ede54f38f65010fc594b0
<mark_weaver>I think we worked around the problem in guix by avoiding the affected procedures higher up in the stack.
<mark_weaver>it was in guix/serialization.scm, iirc
<civodul>i remember that one, not sure if it's related
<civodul>could be
<civodul>i'm trying with a newer Guile now
<mark_weaver>note that the bytevector fix is post-2.0.11
<mark_weaver>(although the debian package cherry-picked the fix)
<civodul>yeah i know
<civodul>for weeks i've been thinking: when do we release 2.0.12?
<civodul>i think it's in a state that we could release
<civodul>there are so many bug fixes in there
*sneek chants "Release! Release! Release!"
<mark_weaver>there are some remaining problems.
<mark_weaver>there was a change made in stable-2.0 that broke guile-gnome
<mark_weaver> http://bugs.gnu.org/18570
<civodul>it's g-wrap, so it must be a GOOPS-related change
<mark_weaver>also, I think that the new "foreign objects facility" API to replace SMOBs needs more discussion and review before releasing it.
<mark_weaver>it was committed into stable-2.0 less than 25 hours after the first proposal was posted
<mark_weaver>and I guess it's on me to continue that discussion now
<civodul>right, i had forgotten about that one
<dsmith-work>mark_weaver: What's wrong with SMOBs?
<dsmith-work>Other than C, of course.
<mark_weaver>dsmith-work: ask wingo, he's the one who decided to replace them.
<dsmith-work>Ah
<mark_weaver>dsmith-work: here's where he proposed them: https://lists.gnu.org/archive/html/guile-devel/2014-04/msg00069.html