IRC channel logs

2015-01-03.log

back to list of logs

*davexunit wonders how to use literal html within an sxml tree
<davexunit>also, does anyone have existing sxml->html code?
<davexunit>I feel that it's a missing piece in guile's sxml modules
<ijp> http://shift-reset.com/blog/2012/9/13/Mixing%20Raw%20HTML%20and%20SXML/
<davexunit>thanks ijp
<davexunit>one thing I don't see here is doing the proper converstion of characters that should be converted to html entities
<davexunit>like © -> &copy;
<ijp>I don't know of a comprehensive list of those, but you can use the function make-char-quotator for that
<ijp>oh wait, no you can't
<davexunit>there's ~360 of them :)
<ijp>if they are all single characters, you could make-char-quotator
<davexunit>yeah, they are.
<nalaginrut>morning guilers
<davexunit>hey nalaginrut
<nalaginrut>heya
<davexunit>how's it going?
<nalaginrut>davexunit: GNU remotecontrol seems want to try Artanis, I'm writing some suggestions to help them to build a prototype, maybe
<davexunit>oh neat!
<davexunit>that's really cool news
<nalaginrut>thanks! ;-)
<nalaginrut>well, I should finish the new server-core for it, since the built-in server is not so robust in real need
<nalaginrut>anyway, users may use Nginx to reverse proxy it, then there's no server problem IMO
<zacts>lo world
<davexunit>hello zacts
<zacts>hey davexunit
<nalaginrut>zacts: heya
<zacts>yo
<davexunit>hey guilers.
<davexunit>I'm running into something that I don't understand.
<davexunit>(string-ref "™" 0) and (string-ref "€" 0) both return the same character value for me.
<davexunit>since I cannot refer to certain characters using character literals like #\\™, I was hoping to find some way of getting the correct character value from a single character string.
<davexunit>I'm writing an sxml->html procedure, and characters like ™ must be escaped in the generated HTML source.
<nalaginrut>davexunit: oh, you're playing strange chars, why not consider to write a char-GUI game? ;-
<nalaginrut>;-D
<daviid>civodul: i finally found the solution, thanks to ebassy on #clutter, to this libtool problem, the 'system' trying to find *.la non existing files... i suspected a 'global' problem [as opposed to guile, guile-gnome, guile-clutter specific] on my box because i needed to compile clutter itrself and it failed the same way. so here is the thing [still a bit 'misterious' for me but]: if at anytime a dependency is built with s [still] existing
<daviid>.la file, the all libtool chain will make snything 'en aval' depending on it, even if the *.la file was deleted.
<daviid>with that in mind, i rebuilt cogl, clutter, guile-cairo, then guile-gnome and guile-clutter started to compile again
<civodul>good!
<daviid>yes, let's keep that in mind for other guilers, maybe .. now, i'm almost ready to release guile-gnome now, but where make check works, make distcheck fails with the following message [in _build]: FAIL: guile-gobject-test; ../../../glib/test-suite/guile-gobject-test: 2: exec: ./guile-test-env: not found
<daviid>however, from _build/glib/test-suite, guile-test-env _is_ in the same directory then the test it trys to execute: ../../../glib/test-suite -> <top dir>/guile-gnome-platform-2.16.3/glib/test-suite, where guile-test-env exists
<daviid>the guile-gobject-test starts with this:
<daviid>exec ${builddir:-.}/guile-test-env guile --debug -e main -s "$0" "$@"
<daviid>i should change that ${builddir:-.} but i don't know for what
<daviid>not even sure i should change that actually :lo:
<daviid>any idea?
<daviid>bbl
<mark_weaver>daviid: if it says "exec: ./guile-test-env: not found" when you think 'guile-test-env' is actually there, the other thing to check is the shebang at the top of that 'guile-test-env' script.
<mark_weaver>if the "interpreter" in the shebang cannot be found, you will get that same error.