IRC channel logs

2014-12-19.log

back to list of logs

<tadni_>Does guile have an irc library? I want to port my simple bit in Elisp to it.
<tadni_> https://github.com/fbs/guile-irc
<tadni_>Nothing upstream, it appears though.
<cky>mark_weaver: Yep, those.
***fangism is now known as fangism-hawngry
<nalaginrut>morning guilers~
<nalaginrut>how can I set guile as default implementation? when I'm using org-mode to output html, it always ask me to input the implementation name
<nalaginrut>and geiser-impl-installed-implementations seems doesn't work
<nalaginrut>alright, I disabled geiser
<ArneBab>nalaginrut: I had the same problem - couldn’t find a solution.
<nalaginrut>it's ok, since I rarely use geiser, so I disable it
<dsmith-work>Happy Friday, Guilers!!
<civodul>Hello Guilers!
<daviid>hello civodul!
***siel_ is now known as siel
<daviid>a pack of beers for who can debug this: http://paste.lisp.org/display/144838
<daviid>updated th above paste so it contains the code that raises the bug: http://paste.lisp.org/display/144838#2
<daviid>i sent a message to guile-devel, help really apreciated, i won't be able to solve it by myself, unfortunately
<ecanaza>Hi there, is there a way to call to #define min(X, Y) ((X) < (Y) ? (X) : (Y)) via FFI. I can't use dynamic-func (dynamic-pointer: Symbol not found: min)
<dsmith-work>ecanaza: No, you can't call C preprocessor macros
<dsmith-work>ecanaza: Those just do text replacement to the source code before it's compiled.
<ecanaza>ok, Thanks.
<ecanaza>I will check guile-opengl code for any solution.
<davexunit>ecanaza: I imagine that the example you used is just to demonstrate the issue, but guile has a min procedure.
<davexunit>when I write wrappers, I just write the equivalents of the macros by hand.
<davexunit>constants and such.
<ecanaza>yep, but min is only a example
<davexunit>there's no way to call a preprocessor macro, because it's a *pre-processor* macro.
<davexunit>the compiler just does a substituion when it encounters the macro.
<ecanaza>got it
<davexunit>most of the time you don't need those macros, the only ones I ever seem to need are #DEFINE constants
<davexunit>a guile program that parsed a header file into an AST and spat out the relevant #DEFINEs would be cool
<ecanaza>ok, but I don't know how do it I want call to #define GTS_IS_POINT (obj)
***fangism-hawngry is now known as fangism
<davexunit>ecanaza: you'll need to write a scheme expression that is the equivalent of that macro.
<davexunit>what C code does GTS_IS_POINT expand to?
<ecanaza> http://gts.sourceforge.net/reference/gts-points.html#GTS-IS-POINT:CAPS
<davexunit>ecanaza: you'll need to read the source code for this macro
<davexunit>I might be able to help you convert it if you show me the source.
<ecanaza>ok, I think is a gobject, I will check it.
<ecanaza>davexunit: Thanks a lot, got it. now I know how do it because GTS_IS_POINT is calling to others function that I can call via dynamic-func
<davexunit>ecanaza: awesome!