IRC channel logs

2014-11-27.log

back to list of logs

<amirouche>the bindings is raising an error (SIGSEV) http://dpaste.com/3D9EB2F#
<amirouche>here is wiredtiger.scm http://dpaste.com/3SH0AZJ
<amirouche>and the c file http://dpaste.com/3R2XANM
<amirouche>The thing is that if I uncomment the code below line 145, there is no error
<amirouche>error happens after the c function is called, inside guile vm
<amirouche>I'm compiling guile with debug (Ubuntu doesn't ship debug deb for it)
<amirouche>ark! guile 2.0.11 from git fails to compile
<nalaginrut>morning guilers~
<civodul>Hello Guilers!
<nalaginrut>heya
<ArneBab>moin civodul
<ArneBab>moin nalaginrut
<nalaginrut>ArneBab: heya!
<nalaginrut>ArneBab: I think wisp page is fine now, but I'd like to read the updated one
<ArneBab>nalaginrut: I’ll try to upate it today: I want to trim the testsuite a bit so it only lists essential tests (and less duplicates).
<ArneBab>From my perspective that’s all which still needs to be done before I can submit the SRFI.
<ArneBab>… that and converting the page to HTML 3.2
<ArneBab>(which will require quite a bit of manual work)
<ArneBab>nalaginrut: do you know whether they are strict about HTML 3.2?
<nalaginrut>I don't know about it
<nalaginrut>but I think they prefer old-school html ;-P
<ArneBab>then I’ll have to revive my schooltime skills ☺
<nalaginrut>maybe you should take care of the syntax highlight
<ArneBab>nalaginrut: yes - since HTML 3.2 doesn’t seem to have nice styles, I thought about using italic letters for the blue highlight.
<nalaginrut>well, it's terrible ;-D
<ArneBab>at least it will work on monochrome displays :) (and printouts)
<wingo>morning :)
*wingo back from us
<wingo> http://www.slideshare.net/lagergren/jugru-2014j-rockit-architecture-copy is interesting for implementation nerds
<nalaginrut>wingo: hmm...server side usage only + greenthread? I like this enemy
<wingo>i think they do only pthreads
<wingo>dunno, we are missing something because we don't hear the voice :)
<nalaginrut>and AOT later, wow, seems this is the only way in tech nowadays ;-P
<nalaginrut>wingo: I guess it's their long term aim
<nalaginrut>although they may use pthread at present
<civodul>howdy, wingo!
<wingo>heya civodul :)
*wingo went to the scheme workshop last week
<civodul>your Scheme Workshop talk looked very nice
<wingo>it was much better than expected! some fresh people and fresh papers
<djcb>that was an interesting read, thanks
<wingo>civodul: thanks!
*wingo likes to rant :)
<civodul>:-)
<civodul>i'd love to attend someday, the program indeed looked refreshing
<wingo>i think next year they are going to try to colocate with icfp
<civodul>ok
<wingo>the tentative plan being to bounce between clojure things and academic things
<wingo>so this year was at the same time as the clojure conj -- which did draw some people
<civodul>it was a good idea, i think
*wingo hasn't been to an icfp in many years, would like to go again
<civodul>arg, ICFP 2015 is in North America
<wingo>boo :(
<wingo>that trip is hell
<civodul>heh
<nalaginrut>I guess bdw-gc is not concurrent GC, right?
<wingo>nalaginrut: i don't know if the disabled-by-default "incremental" gc could be called concurrent
<wingo>not by default tho
<nalaginrut>wingo: oh, I think it is!
<nalaginrut>" A close approximation of concurrent collection is incremental collection, which is more tractable because it does not have to deal with mutation during the garbage collection algorithm."
<wingo>bah, that sounds like a bad definition :)
<wingo>anyway :)
<nalaginrut>;-D
<nalaginrut>wingo: it's interesting that it said they'll use green-thread in the former of slide, but I found they use native-thread in the bottom of slide ;-)
<ArneBab>wingo: is there a recording of your talk?
<wingo>ArneBab: sadly no! i recorded the audio but then when i went to save the app on the cyanogenmod phone said "internal error" :(
<wingo>i need to look in the phone if there is some file left over
<wingo>civodul: maybe we need to organize a euroscheme conf
<wingo>or get the chickeners to organize one :)
<wingo>mixing industry and academia is tricky tho
<wingo>would be nice to have both
<wingo>like for academia i guess you need to be affiliated with someone and publish the papers somewhere
<wingo>or maybe we could do something affiliated with icfp 2016
<mario-goulart>wingo: I think some european chickeneers will meet at FOSDEM.
<wingo>mario-goulart: nice :)
<mario-goulart>DerGuteMoritz: do you know something about that (^)?
<wingo>i will try to be there
<wingo>a smaller, scheme-focused event is also necessary tho
<wingo>seems to me anyway :)
<mario-goulart>definitely
<mario-goulart>It would be great.
<DerGuteMoritz>I think I'll be there, yep
<DerGuteMoritz>don't know of anyone else, yet, though
<ArneBab>wingo: :( - would be cool if you could find the file!
<mario-goulart>DerGuteMoritz: I thought Peter would go too. Won't Felix go?
<DerGuteMoritz>mario-goulart: nothing confirmed, yet IIRC!
<mario-goulart>Alright. Thanks for the info!
<wingo>ArneBab: there's a file!
<ArneBab>YAY!
<taylanub>I'd love to hear it too if the audio quality is OK. the other day I tried to watch a Guix talk by civodul (the most recent I think) but couldn't understand any of the speech :(
<wingo> https://wingolog.org/pub/scheme-workshop-2014-audio.oga / https://wingolog.org/pub/scheme-workshop-2014-audio.mp3
<ArneBab>wingo: thanks a lot!
<ArneBab>wingo: “The programs that we write are a function of their expected behavior” ← that’s a pretty nice quote - and applicable to a very broad range of topics.
<civodul>taylanub: yeah the audio of this year's GHM sucks, i don't know what happened
<amirouche>for some reason my bindings are segfaulting inside guile
<amirouche>I compiled guile with debug symbols
<amirouche>both wiredtiger and lmdb segfault
<amirouche>I experimented more with wiredtiger and the funny thing is that if the c function just before the crash does more thing; it won't segfault
<amirouche>maybe it's related to thread
<amirouche>the segfault happens at vm-i-system.c:890
<amirouche>also for some reason I need to LD_PRELOAD wiredtiger
<jmd>Is there a way to build a simple guile, on a barebones box?
<jmd>How long does it typically take to build guile ?
<taylanub>jmd: master branch takes very long. stable maybe 20 minutes on average hardware...
<jmd>Mine must be slower than average...
<taylanub>jmd: what CPU do you have?
<jmd>model name : AMD E-350 Processor
<jmd>Wow! its finished!
<taylanub>jmd: how long did it take?
<jmd>Well I asked the question:
<jmd><jmd> How long does it typically take to build guile ? [19:24]
<jmd>
<jmd>I think it had been going about 20 mins
<jmd>and <jmd> Wow! its finished! [20:20]
<jmd>
<jmd>So about 80 mins.
<wingo>moo