IRC channel logs

2014-11-10.log

back to list of logs

<nalaginrut>morning guilers~
<civodul>Hello Guilers!
<jmd>civodul: Hi
<Chaos`Eternal>can i control the buffer size of a port?
<civodul>Chaos`Eternal: with 'setvbuf'
<Chaos`Eternal>what's default size?
<civodul>it depends on the port type, i think
<civodul>for file ports, it may also depend on the file system
<Chaos`Eternal>well, is there anything like getvbuf
<wingo>apparently not. that's strange
<wingo>i think actually we control the buffering size, it's not a filesystem thing
<wingo>terminals are line buffered, file ports are block buffered, i think something like 1024 or 4096 bytes by default
<civodul>wingo: fports.c uses st_blksize as a default buffer size
<wingo>ah right, just found that too
<wingo>cool :)
<civodul>:-)
<dsmith-w`>Morning Greetings, Guilers
<wingo>greetings dsmith-w`
***dsmith-w` is now known as dsmith
***dsmith is now known as dsmith-work
<Chaos`Eternal>thx , civodul and wingo
<dsmith-work>Wow. That erlang list link that davexunit posted is very interesting.
<dsmith-work>I've always hear good things about erlang, but I just can't get past "syntax" after learning scheme.
<Chaos`Eternal>i made a system-call via ffi
<Chaos`Eternal>but i want to check errno
<Chaos`Eternal>how?
<Chaos`Eternal>(dynamic-pointer "errno" (dynamic-link))
<Chaos`Eternal>does not work i think, because the value does not change even if the perior system-call failed
***paroneay` is now known as paroneayea
<mark_weaver>Chaos`Eternal: errno is typically a C preprocessor macro that accesses some thread-local variable, so we'll need to wrap it specially. there's a ticket for this: http://bugs.gnu.org/18592
<mark_weaver>Chaos`Eternal: actually, it occurs to me that we probably can't wrap 'errno' normally, because it'll likely get changed between the syscall that you made and when you check it from scheme.
***Soft- is now known as Soft
<jmd>Any guile modules to deal with fuzzy logic?
<ijp>maybe
<dsmith-work>jmd: Is that used anywhere? (fuzzy logic in general)
<jmd>dsmith-work: Indeed it is.
<ijp>not really hard to support though, just add a maybe object, and define a threeway if
<jmd>ijp: Fuzzy logic doesn't have discete results so a threeway would not be appropriate.
<ijp>getting existing code to handle it would be problematic, but no sure what you'd want there
<ijp>jmd: you and I must mean different things by "fuzzy logic"
<jmd>I mean that which was first introduced in the literature by Lotfi
<dsmith-work>It's like boolean logic, but you gave a continuous range of values between 0 and 1.
<jmd>dsmith-work: Right.
<dsmith-work>and is max, or is min, not is 1-
<ijp>I usually only see the ternary version
<jmd>ijp: If it is ternary, then it is not fuzzy logic.
<jmd>... at least not in the generally accepted use of the term.
<ijp>noted
<ijp>answer is still "probably no"
<jmd>I suppose the fuzzy equivalent of "if" would be a sigmoid function.
<dsmith-work>jmd: Ya, that sounds familar
<jmd>But we could define a fuzzy-if which processes only a percentage of the symbols passed as the second arg :P
<dsmith-work>jmd: In some fonts, a lower case t can look a lot like an inverted lower case f.
<dsmith-work>Need a way smoothly progress between #t and #f, with midway lookign like #-
<dsmith-work>;^)
<stis>hej guilers!
***wingo_ is now known as wingo