IRC channel logs

2014-11-01.log

back to list of logs

***dje is now known as xdje
<ArneBab>mark_weaver: status report (because I’m happy how well this worked out): the new (read)-based wisp implementation now supports quoted lists. And match is officially awesome ☺ → https://bitbucket.org/ArneBab/wisp/src/f154d2b61241d32782b999f8e0876dc34d0acc92/wisp-scheme.w#cl-503
<ArneBab>I just need to add the code for quasiquote, unquote, syntax, etc. (all prepared, just a few lines to add to match) then it should be finished. I’ll do that another day, though (“solved!”)
<naboo>Is there a native way to send files to an ftp server in Guile, or is it better to use an external program like ftp / scp?
<Riastradh>Guile 2.0.11 fails to build on NetBSD:
<Riastradh>...
<Riastradh> CCLD guile
<Riastradh> GEN guile-procedures.texi
<Riastradh>GC_is_visible test failed
<Riastradh>Abort (core dumped)
<Riastradh>Suggestions on how to debug this?
*wingo searches logs
<Riastradh>Oops! I just realized that Thomas Klausner beat me to debugging this two days ago, while I wasn't looking. It was an issue in boehm-gc.
<Riastradh>I thought guile used a precise GC these days, though -- does it not?
<wingo>ah it's a bdw-gc issue, good to know
<wingo>Riastradh: it's complicated :)
<wingo>we use bdw-gc
<Riastradh>(This is the fix/workaround: <http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/devel/boehm-gc/patches/patch-dyn__load.c?rev=1.1&content-type=text/x-cvsweb-markup&only_with_tag=MAIN>.)
<wingo>the C stack and static roots (e.g. static variables, TLS sections, etc) are scanned conservatively
<wingo>by bdw-gc
<wingo>the scheme stack is scanned precisely
<wingo>and the scheme heap is scanned mostly conservatively (but there there is less of a possibility of false aliasing, because of pointer tagging)
<Riastradh>I see.
<Riastradh>If pointers are tagged, why scan the heap conservatively?
<wingo>because that's just what bdw-gc does, and we use bdw-gc for other reasons
<wingo>a couple of things tho
<wingo>you can create objects that are declared to not contain pointers
<wingo>so that goes for bytevectors, etc
<wingo>and you can create objects with specialized mark functions
<wingo>but that's not recommended
<wingo>anyway, just how it is. would be nice to be able to move objects though!
<wingo>eventually something like azul's c4 collector would be excellent
<ijp>wingo: I think our ffi implicitly assumes objects don't move
<wingo>ijp: there are solutions to that (pinning etc)
<rekado>I have an atmega32 board here that I want to give to my nephew to introduce him to hacking; I wonder what options there are to allow him to write micro controller code in scheme instead of C or assembly.
<rekado>it seems, though, that C with pre-processor macros to make it all a little more accessible is probably the way to go.
<cluck>rekado: get a raspberry pi, plenty of doc, can run a full desktop (if desired) and there are plenty of bare metal lisps for it (chibi and racket come to mind, sadly no guile on arm yet that i know of ;( )