IRC channel logs

2014-09-09.log

back to list of logs

<dsmith-work> http://www.dreamsongs.com/CLOS.html
<dsmith-work>Interesting..
<daviid>dsmith-work: yes indeed tx for this link, it also reminds me the old times ... :)
*davexunit learned about match-lambda
<davexunit>yaaaaaaay!
<daviid>i see that goops also limits methods specialization on class, where clos goes down to instances, which would allow things like: (define-method (combine ((x (eq? 'powder)) (y (eq? 'spark))) 'boom)) [just for the record, this 'limitation' is clearly stated in goops manual, but it could be improved in the future]
<nalaginrut>morning guilers~
<civodul>Hello Guilers!
<artyom-poptsov1>Hi civodul
<civodul>hey, artyom-poptsov1
<Max_Gentlemen>mark_weaver, what is your opinion of encoding paramaters like functions instead of specialized objects like mutable records or fluids?
<Max_Gentlemen>I think a better quaestion would be "Why are params typically encoded as functions rather than actual specialized objects for it"
<taylanub>Max_Gentlemen: having them be procedures saves a couple keystrokes. it might have been desirable to make them a disjoint type but "that ship has sailed".
<taylanub>Max_Gentlemen: "procedure" is the preferred term for the function objects in Scheme by the way
<nalaginrut>hmm...I really hope the compiling could be faster...
***Max_Gentlemen is now known as imaaminpojat
***imaaminpojat is now known as imaaminpoikienko
***imaaminpoikienko is now known as anencephelia
***anencephelia is now known as JJSacreBleu
<gjanssens>Hi, I'm trying to build guile 2 on Windows which turns out to be more complicated than I had hoped
<gjanssens>I found that Eli Zaretskii succeeded in doing so after applying several fixes
<gjanssens>He note on the mingw32 mailing list that not all of these patches have been committed in the guile repository
<gjanssens>My question now is mainly: will there be a guile 2.0.x that will build successfully on Windows ?
<gjanssens>That is with Eli's patches or modifications there of ?
<dsmith-work>gjanssens: The very busy guile devs are reviewing them. Takes a while.
<dsmith-work>gjanssens: I would suggest trying the patches yourself and reporting any failures or successes to the lists.
<dsmith-work>sneek: seen rlb?
<sneek>I last saw rlb on Apr 17 at 11:48 am UTC, saying: may also try to produce an edn module for guile... time permitting.
***rlb` is now known as rlb
<gjanssens>dsmith-work: thanks. I'll see if I get to it
<gjanssens>dsmith-work: I already spent two days on it without much success :(
<stis>evening guilers!
<stis>\\me is celebrating today :)
<stis>Fixed one of the hardest bugs ever in my life in guile-log
<stis>finally got guile-log's engine to garbage collect in a robust manner!
<davexunit>stis: yay!
<stis>that stalled me for 4 months :-D
<dsmith-work>stis: Yow.
<janneke>nice!
***JJSacreBleu is now known as LLCordonBleu
***LLCordonBleu is now known as Bortaqqq
<janneke>is there a way to find out at runtime if a matching goops generic method exists?
<daviid>janneke: you mean if an applicable method exists [given an arg list]
<daviid>janneke: you can ask for the list of methods of a generic function: generic-function-methods
<janneke>daviid: yes...
<janneke>ah nice, and then specializers gives the formal parameter types
<janneke>thanks!
<daviid>np. you can also take advantage of no-method, no-applicable-method and no-next-method ... [by adding your methods to these system predefined genric functions]
<daviid>janneke: about next-method, note that if you want to call on to a method with the same name but with a different set of arguments, you do _not_ use next-method, you call the method explicitly [see manual 8.6.4 Next-method]
<janneke>daviid: many thanks!
<janneke>i want[ed] to implement a sort of map-like function, but for a goops tree