IRC channel logs

2014-06-20.log

back to list of logs

<davexunit>hello guilers
<civodul>Hello Guilers!
<ijp>greetings earthling
***ijp` is now known as ijp
<dsmith-work>Happy Friday, Guilers!!
<davexunit>happy friday
<civodul>Happy Friday!
<janneke>i'm writing a module with a lot of functions that could have very generic names
<janneke>functions like (name x), (component x) (interface x) (type x)
<janneke>what approaches do i have wrt namespaces?
<janneke>currently, i just import that module and prefix all names: ast-name, ast-component, ast-type
<janneke>i could introduce goops, use generics and drop the ast- prefix, or do ((@ language asd ast) name)
<guest`>why "(equal? (car '(/)) /)" is "#f"?
<lloda>because (car '(/)) is a symbol '/, but / is a function (divide)
<dsmith-work>Actually, '(/) is a list... But yeah, it's certainly not /
<dsmith-work>scheme@(guile-user)> /
<dsmith-work>$1 = #<procedure / (#:optional _ _ . _)>
<dsmith-work>scheme@(guile-user)> '(/)
<dsmith-work>$2 = (/)
<dsmith-work>scheme@(guile-user)> (list? $2)
<dsmith-work>$3 = #t
<guest`>dsmith-work: note the car, and I already got it...
<dsmith-work>Ahh, true. Sorry...
<dsmith-work>Amazing how you can not see things sometimes..
<daviid>hello guilers!
<davexunit>daviid: hello!
<daviid>hi davexunit, how are things today?
<davexunit>things are good. getting ready for the big FSF newsletter mailing.
<daviid>great!
<daviid>looking to receive ir of course
<davexunit>daviid: :)
<davexunit>and in guile land, I've been working on a scene graph implementation
<davexunit>my prototype: http://paste.lisp.org/display/142951
<daviid>nice!
<daviid>it sounds very much like clutter
<davexunit>oh cool.
<davexunit>yeah, scene graphs are used a lot.
<davexunit>it's not yet reactive, but it will be.
<davexunit>gotta figure it all out.
<davexunit>one thing that I don't like is that I have to duplicate some things for each scene node constructor function.
<davexunit>like the #:transform arg.
<daviid>by the way could you not do what you do in clutter? I mean you'd develop special actor but the 'engine' of the all interface would bwe clutter ?
<davexunit>daviid: I don't know how clutter works.
<davexunit>I guess I should read about it!
<davexunit>daviid: it won't be -2d for long. ;)
<davexunit>as you can see from the code snippet, I have a perspective-projection procedure that allows you to render in 3D space.
<daviid>davexunit: tha's exactly what clutter does :)
<daviid>i think youre reinventing the wheel [if i may say so]
<davexunit>daviid: do you have some recommended reading for clutter?
<davexunit>daviid: well, scene graphs are all over the place.
<daviid>let me look [i am far from being a specialist, but i'd like to become more pro...]
<davexunit>it's not reinventing the wheel because every scene graph is different.
<daviid>i know, but customizing clutter sounds a better track imh, at first glance at least
<daviid>_and_ i need friends :) :)
<davexunit>mine will become quite specialized towards game development and reactive programming.
<davexunit>but i'll certainly steal an idea or two from clutter.
<daviid>i understand that, let me finish what i'm doing and bb
<davexunit>sure thing. no rush. I can just go read clutter docs, but if you have a specific piece of documentation that you think would be relevant to me feel free to send it to me. :)
<daviid>i would read an intro, install it [if not already the case] and run examples. then i would think :) and talk to ebassy on #clutter [irc.gnome.org], he's really a nice guy, to know if what you want to do in the future is feasible in his opinion
<daviid>then i would try guile-clutter of course [i am working on 1.12, we are very late but i'll catch [later stable is now 1.20, development is fast, it was 1.18 not even a month ago
<daviid>s/later/latest
<daviid>i'm still lacking g-wrap and C knowledge [never programmed in C, I can read it of course but I obviously lack practice when it comes to deep things] otherwize it would be done already
<daviid>dave do you have a working guile-gnome?
<daviid>davexunit: i'm back :) here is good start: http://en.wikipedia.org/wiki/Clutter_(software)
<daviid>where you'll read: "Clutter is a scene graph based canvas working in retained mode. Every object on the scene is usually a 2D surface inside a 3D space."