IRC channel logs

2014-06-04.log

back to list of logs

<xdje>That happens with 2.0.5, but not 2.0.11.
<xdje>Ugh. Why can't libguile export scm_{major,minor,micro}_version functions that return an int.
<dsmith-work>Can. But should have _c_ in the name.
<dsmith-work>Like scm_c_version()
<xdje>I get that part. I'm just lamenting that they don't exist already.
<xdje>To get something useable, I have to call scm_major_version, then convert the SCM to a C string, and then atoi it. Yikes.
<dsmith-work>Yeach, icky
<dsmith-work>So only do it once..
<xdje>Indeed... That's what I'm coding up right now. :-)
***cluck` is now known as cluck
***ft_ is now known as ft
***sneek_ is now known as sneek
***fangism is now known as fangism-ctrl-Z
<TerPri>I want to work on an at least partial guile to opencl compiler, where do I start?
<TerPri>The point would be to end up with a theano equivalent, but 1- for guile; 2- that doesn't require nvidia hardware. I already have lisp in small pieces as a usable starting point (opencl being c-like enough), though I can't seem to find in-depth enough information about the parts of the guile compiler-tower (only summary explanations).
<TerPri>If I were to start from a lisp in small pieces code, I assume I'd have to implement the compiler phase as being at the top level, though that would mean I'd have to handle the optimizations that guile already handles all the way until the bytecode level.
<TerPri>On the other hand, the bytecode level maps to stack-based operations as far as I could tell, and I'm not sure how well that could be translated to opencl.
<nalaginrut>morning guilers~
***dje is now known as dje42
<civodul>Hello Guilers!
<wleslie>hey luuuuuuuuuudo
<civodul>:-)
<davexunit>morning guilers
***george2|chakra is now known as george2
<dsmith-work>Morning Greetings.
<mark_weaver>Hello Guilers!
<sneek>Welcome back mark_weaver, you have 1 message.
<sneek>mark_weaver, ArneBab_ says: I created a first rough draft of an SRFI for wisp: http://draketo.de/proj/wisp/srfi.html
<mark_weaver>TerPri: regarding compiling Guile to opencl, I would compile look at the new register VM on the master branch of guile git, which will become Guile 2.2, though beware that there might be some changes to the bytecode before release.
<ArneBab>Hi mark_weaver, nice to see you here again!
<dsmith-work>TerPri: The guile manual *does* have quite a bit of documentation, though it's not a tutorial.
<ArneBab>mark_weaver: and congrats again for officially becoming co-maintainer ☺
<mark_weaver>sneek: later tell bhattigurjot: set the ACLOCAL_PATH environment variable to $PREFIX/share/aclocal, where $PREFIX is the one used to install guile, and then rerun: autoreconf -vfi
<sneek>Got it.
<mark_weaver>ArneBab: thanks! :)
<mark_weaver>I should mention: the reason I've been mostly absent for the last month or so is because my best friends, with whom I cohabitate, are currently in the process of selling their old house and moving into a new one, and there's been an large amount of work to do on that.
<davexunit>well that's good news, I was hoping that something bad didn't happen.
<davexunit>welcome back, mark!
<mark_weaver>thanks dave! :)
<davexunit>while we're mentioning things: I am the FSF's new web developer.
<mark_weaver>davexunit: oooh, congrats!!
<davexunit>thanks!
<mark_weaver>as a volunteer, or staff?
<davexunit>mark_weaver: staff.
<mark_weaver>that's great news :)
<davexunit>yeah, I'm hoping things work out well.
<davexunit>I had to sacrifice some things to get a job where I didn't write proprietary software.
<mark_weaver>it always makes me glad to see people willing to make such sacrifices. the world needs more of that.
<davexunit>I hope to make up the difference with happiness and pride in my work.
<mark_weaver>opinions differ of course, but speaking for myself, I certainly find that to be the case. I could never go back.
<mark_weaver>anyway, I'll be mostly afk for most of today... still lots to do!
<davexunit>mark_weaver: ttyl, nice to have you back on IRC.
<civodul>hi, mark_weaver!
<civodul>oh, congrats davexunit, indeed
<ArneBab>davexunit: oh, wow! Congratulation! (and besides: The GNU websites are technically really nice!)
<ArneBab>mark_weaver: I had also feared something might have happened. Good to know that it was just (hopefully positive) real life interference ☺
<davexunit>ArneBab: thank you!
<daviid>mark_weaver: welcome back indeed! I also was hoping nothing bad happened and now cross fingers so that everything goes well for both you and your friends.
<daviid>davexunit: great! congrats. I also strickly work if and only if what I write is GPL or GPL compatible, not easy money wise, but quite a lot more satisfactory for me.
<davexunit>daviid: yeah, I gave up a lot of money to do this.
<davexunit>for the best, I think. I want to see where this road takes me.
<daviid>to freedom, the best road
<daviid>davexunit: out of curiosity, are you working remotely or in Boston?
<davexunit>in Boston.
***fangism-ctrl-Z is now known as fangism
<naboo>does anybody use guile-ncurses?
<naboo>i have problem with coloring menu
<naboo>only black background and white letters display and can't change this
<TerPri>mark_weaver: I'll check this out, thanks. dsmith-work: all I could find about the standard compilation passes was a list of ops at the glil and tree-il levels with a terse 'description'. For example, there is no listing whatsoever of what insts are available at the assembly or bytecode level; when symbols can take one of N values, the exact meaning of the value is not specified; and so on.
<TerPri>I think I found the assembly instructions just now, though. Not sure how I missed them before. They're the ones listed at the end of the A Virtual Machine for Guile section, right?
<dsmith-work>TerPri: There's "A Virtual Machine for Guile" and "Compiling to the Virtual Machine"
<mark_weaver>TerPri: make sure to look at guile from git master though. there's no point in building a compiler from the stack VM, as that will soon be obsolete.
<mark_weaver>TerPri: see http://www.gnu.org/software/guile/docs/master/guile.html/A-Virtual-Machine-for-Guile.html