IRC channel logs

2014-06-03.log

back to list of logs

<nalaginrut>morning guilers~
<taylanub>morning! if anyone's interested, here's a badly written rant on Apple's way of marketing their new language: http://taylanub.github.io/doc/apple-swift.html
<madsy>taylanub: B..b.but it got closures and tuples and lambdas and everything!11
<taylanub>welcome to 1960! :)
<madsy>Yep
<madsy>I was being sarcastic if that wasn't obvious
<taylanub>oh sure, it was
<nalaginrut>well, one of my friends have published a JD this morning: need programers who is familiar with Swift for at least 3 years, and he has gotten several CVs now...
<ArneBab>taylanub: but the Apple GUI looks more shiny! …
<nalaginrut>hah, first time I know this http://www.gnu.org/software/sather/
***mario-go` is now known as mario-goulart
<civodul>dje42: did you have a chance to look at the marker thread issue with GDB?
<dje42>civodul: not yet
<civodul>ok
<davexunit>hey guilers.
<dsmith-work>Hey hey
***karswell` is now known as karswell
<hyg>can you run standalone elisp programs? i can't find the script equivalent of repl's ,L elisp
<dsmith-work> --language=LANG change language; default: scheme
<dsmith-work>
<dsmith-work>hyg: from guile --help
<hyg>dsmith-work: must be in a newer version (got 2.0.9). will get 2.0.11, thanks!
<taylanub>and you can pass many args by starting your file with "#!/usr/bin/guile \\ <newline> space separated args go here <newline> !#" but unfortunately that won't work with "#!/usr/bin/env guile"
<hyg>taylanub: yup, i read about the "meta switch" trick
<wirrbel>hi
<wirrbel>I would like to write a C-extension for guile
<wirrbel> I have a rough skeleton working (hand crafted Makefile, .c file, .scm file)
<wirrbel>but I wonder whether there is a very simple project/repo with an exemplary Autotools configuration
<wirrbel>that I could adapt
<dsmith-work>wirrbel: guile-cairo perhaps?
<dsmith-work>wirrbel: Or (I hesitate to mention) guile-sqlite? (Not entirely things are done the right way there.)
<dsmith-work>sneek: later tell hyg Yeah, that was from guile (GNU Guile) 2.1.0.1504-3be43
<sneek>Okay.
<xdje>civodul: more guile 2.0.5 porting work is needed, e.g. I'm using file-name-separator-string which was added later. Oops.
<civodul>xdje: ooh, didn't see that one
<civodul>or maybe that was added recently?
<xdje>Is there a canonical way to work around such portability issues on the Scheme side
<xdje>e.g., symbol-bound? is deprecated
<civodul>(define file-name-separator-string (if (defined? 'file-name-separator-string) file-name-separator-string "/"))
<xdje>ah, defined? "works for me"
<xdje>In guile 2.0.5 I can't get (use-modules (gdb init)) to work, even though the file is in %load-path. If I first (load-from-path "gdb/init.scm"), then (use-modules (gdb init)) works. Another 2.0.5-ism?
<civodul>hmm, no, i don't think anything has changed here
<xdje>Hmm, I reproduced it in a toy example, went back to reproduce it again and no longer can.
<civodul>note that 'use-modules' creates the required module as a side effect
<civodul>so even when it fails, subsequent uses of that module will "succeed"
<civodul>as in: produce no error message
<civodul>that can be confusing
<xdje>I exited guile and restarted it though.
<xdje>I also rm -rf ~/.cache/guile
<civodul>ah, ok
<xdje>(use-modules (foo)) -> ERROR, (add-to-load-path "/home/dje/src/play"), (use-modules (foo)) -> ERROR
<xdje>However, restart guile and do (add-to-load-path "/home/dje/src/play"), (use-modules (foo)) -> SUCCESS [i.e. the first use-modules causes the subsequent load attempt after fixing %load-path to also fail]
<xdje>Bleah.