IRC channel logs

2014-05-11.log

back to list of logs

***_zxq9_ is now known as zxq9
<civodul>Hello Guilers!
<daviid>hello guilers, fixing guile-gnome 'make check' (./tests.mk. ./glib/test-suite/Makefile.am) which now processes the checks, I run into another problem which I believe is not related to my changes, for which i'd like some help if possible, and so I can also send 1 'fix make check' patch. here is the quizz
<daviid>in here http://git.savannah.gnu.org/cgit/guile-gnome.git/tree/glib/test-suite you'll see that Makefile.am has the following def:
<daviid>TESTS = guile-gobject-test \\
<daviid>
<daviid>in the same directory you'll find guile-gobject-test, a guile script, and it's first line is this one:
<daviid>exec ${srcdir:-.}/guile-test-env guile --debug -e main -s "$0" "$@"
<daviid>running make check gives me this error:
<daviid>./guile-gobject-test: 2: exec: /usr/local/src/guile-gnome/git-clone/guile-test-env: not found
<daviid>what does this "exec ${srcdir:-.}/guile-test-env ..." expands to?
<daviid>what would be the proper expression (intead of "${srcdir:-.}" so that it includes the local directory?
<daviid>well, I can change that to this I suppose: exec ./guile-test-env guile --debug -e main -s "$0" "$@"
<daviid>this works: exec ${srcdir:+.}/guile-test-env guile --debug -e main -s "$0" "$@"
<daviid>maybe it was just a tipo, but if any guile developper read this, later maybe, confirming the above correction is right[or not] would be nice...
<civodul>daviid: my guess is that it should have been builddir instead of srcdir, no?
<civodul>aren't you doing an out-of-source build?
<daviid>civodul: from git yes
<daviid>what is "-." ? i changed it to "+." [like instinctively, but...
<civodul>":-" gives a value if the variable turns out to be empty/undefined
<civodul>so i think it's correct
<civodul>what may not be correct is srcdir, which should be builddir
<civodul>(i'm saying that without having seen the code, though ;-))
<daviid>then srcdir is not empty and does not include "." which should
<daviid>both files, guile-gobject-test and guile-test-env are in the same source dir: http://git.savannah.gnu.org/cgit/guile-gnome.git/tree/glib/test-suite
<daviid>I can try builddir of course
<daviid>it passes with builddir so I'll make that change. then i have another weird test bug, here is it [from the test suite, not as a result of a check I mean]:
<daviid>the file is here: http://git.savannah.gnu.org/cgit/guile-gnome.git/tree/glib/test-suite/lib.scm
<daviid>the error is: ;;; WARNING: compilation of /usr/local/src/guile-gnome/git-clone/glib/test-suite/gobject.test failed:
<daviid>;;; ERROR: build-constant-store: unrecognized object #<procedure run-test-exception (name exception expect-pass thunk)>
<daviid>sorry, the fils is this one: http://git.savannah.gnu.org/cgit/guile-gnome.git/tree/glib/test-suite/gobject.test
<daviid>
<civodul>daviid: that's because of the horrible defmacros in test-suite/lib.scm (the way we did in the old days)
<civodul>i think you should simply copy test-suite/lib.scm from current Guile
<civodul>that'll just work
<daviid>ah wonderfull, let me do that, i'll let you know
<daviid>ok, that solved it, now I have another bug
<daviid>here is the report: http://paste.lisp.org/display/142497
<daviid>or is it just normal? I mean it runs the test, produces a guile-gobject-test.log and a test-suite.log, but does it complains with: "Makefile:846: recipe for target 'test-suite.log' failed" ?
<daviid>s/but/but why does it complain/
<daviid>hum, very complicated Makefile for a little schemer :)
<daviid>here is the Makefile:846 expression: http://paste.lisp.org/display/142497#1
<civodul>daviid: that just means that one test out of 3 failed
<civodul>you need to look for api.log for details
<civodul>or test-suite.log
<daviid>ok, i thought in this case it would only print the === ... ... === and not a Makefile error
<daviid>the api.log says: "... Public API has been removed (unless) ..." which probbly related to my patch, defining unless only for guile < guile-2. I have to finf out where to change the api tests
<civodul>yeah that test just makes sure the API hasn't changed inadvertently
<daviid>gobject.api line 192 - 194 are: (re-export-modules macro)
<daviid> (unless macro)
<daviid> (with-accessors macro)))
<daviid>but unless is defined, so ?
<civodul>hmm, dunno
<civodul>that's really harmless, so worth reporting upstream, but no worries
<daviid>civodul: I know, but I am learning and this is part of it :)
<civodul>ahh, good :-)
<daviid>I'd like to solve the unless problem, if possible, here is the api.log: http://paste.lisp.org/display/142497#2
<civodul>but i have no idea here, and feeling a bit lazy ;-)
<civodul>would need to check whether/where 'unless' is defined, and whether that interferes with Guile's 'unless'
<daviid>it's ok, tx for your help! get a rest then :)
<civodul>(which 1.8 didn't have)
<civodul>np
<daviid>I know, I did the change: it's here:
<daviid> http://git.savannah.gnu.org/cgit/guile-gnome.git/tree/glib/gnome/gobject/utils.scm, which once you apply my patch gets to this: http://paste.lisp.org/display/142497#4
<daviid>[ only if you wish of course, i understanbd if you rest :) ]
<civodul>daviid: i think on Guile 2 it should just #:re-export (unless)
<daviid>oh, really? I thought iif in guile core no need for ..., but let me try
<civodul>i mean, if you re-exported it, it would silence the test
<daviid>but how would that be in guile-1.8?
<daviid>ah ok
<daviid>trying...
<daviid>ok, no more unless API change report, but I still don't understand, in the test suite, why it did complain about that: as if unless should be defined in gnome utils and not just be defined
<daviid>actually it did report test-suite.log:ERROR: re-exporting local variable: unless
<daviid>i think module-api itself should be cond-expand dependent
<daviid>right now the only way for the test suite to run all tests and no Makefile related bug anymore, just the check reports of course, is to delete the (unless macro) line in gobject.api
<daviid>civodul: many thanks, have to go of kb for now, bbl