IRC channel logs

2014-04-27.log

back to list of logs

<daviid>though there is a bug, imo, because using his definition, guile could return 'foo or 'bar (i have not deeply studied the hyperspec for such a situation he is using) but not 42 anyway
<unknown_lamer>mark_weaver: re: the slots, there should only be one slot named a, and the arguments for the same named slot in a subclass should be merged with the ones specified in its superclasses according to the rules in clos
<unknown_lamer>since goops's standard metaclass attempt to emulate clos pretty closely
<unknown_lamer>I could have sworn it did that like ... 5+ years ago
<mark_weaver>unknown_lamer: I tried the example on guile 1.8.8, and it behaved differently: standard input:8:1: In procedure foo-a in expression (foo-a (make <bar>)): standard input:8:1: No applicable method for #<<generic> foo-a (1)> in call (foo-a #<<bar> f79ff190>)
<mark_weaver>it seems as though it didn't merge the slots, but rather made a fresh new slot or something.
<unknown_lamer>hrm, I wonder if it worked in 1.6
<unknown_lamer>(been using guile since 1.3 ...)
<mark_weaver>I'm almost totally ignorant of the GOOPS code. not looking forward to debugging this.
<unknown_lamer>I'd offer to fix goops, but I'm knee deep in a compiler of my own at the ... year
<unknown_lamer>trying to improve the dynamic environment support, which was very clearly bolted on as an afterthought and ... yech
<mark_weaver>oh, what compiler?
<unknown_lamer>domtool (http://wiki.hcoop.net/DomTool)
<unknown_lamer>I just discovered a fun bug too, it turns out you can do things like `val foo = "foo"; val bar = foo; val foo = bar";` and bar = "bar" which is ... wrong
<unknown_lamer>val foo = "bar"; at the end there
<taylanub>unknown_lamer: Might as well see that as reactive-programming.
<unknown_lamer>bar@YESYESYYSS@test.org: last-one@wins.com
<unknown_lamer>that is a problem
<unknown_lamer>you can use a different type for the second val, and ... the entire security of the system is actually nil
<meguli>Hello everyone
<meguli>I am trying to build latest guile under MSYS2. I installed libunistring from MSYS' package manager.
<meguli>But when configuring guile I get an error saying; error: GNU libunistring is required, please install it.
<meguli>What I need to do to make compiler locate libunistring? I don't know much about MSYS2's conventions about storing libraries. It is not in lib, it is in bin with a funny name.
<meguli>namely, msys-unistring-0.dll
<meguli>Btw, guile requires gmp too as you know. It is also a dll with a name starting msys-, in bin. But compiler can link that one.
<meguli>Thanks guys, compiled libunistring from source as well.
<stis>heya wingo:
<stis>Saw that you asked about any ueses of a gc mark functions for smobs,
<stis>I think I have one application where I'm trying to have some kind of gc for logical variables.
<stis>there I need to know if a smob has been marked by normal gc or not.
<stis>And implementedf it by tagging the smob if it is marked.
<stis>also the control stack itself has both items that shuld be marked and items that should not be marked.
<stis>All this because I don't know how to ask the gc if an object have been markde or not.
<wingo>hi
<stis>:)
<wingo>when would you want to know if an object has been marked?
<wingo>at what gc phase would you want to know that?
<stis>the control stack contains references to the variables, but if no other objects in scheme as a reference to the object, I can remove it from the control stack
<stis>I think that I need to know it after the gc havebeen done, I pprotect the variables and at the end of the gc, they have not been marked I will remove them from the control stack and unprotect the variable
<ijp>so you want weak references from the control stack
<ijp>although those alone wouldn't let you remove entries
<stis>yep, a weak reference. Ans also because I have normal guile objects as well on the control stack
<stis>I can'tt treat it as a uniform datastructure, huh
<stis>anyway I got this all as a feature request, and I havent got it working yet.
<zxq9>I've never really cared before, but how far from the scheme spec does guile2 stray?
<zxq9>Or, is there a reference detailing this?
<ijp>which spec?
<ijp>but in any case, I doubt there is a listing of any omissions
<ijp>specifying additions would be a waste of time
<zxq9>OK. Just curious. Never really cared until running into a swarm of racket/drscheme folks.
<zxq9>Actually, still don't care. Just curious.
***ngz` is now known as ngz
<wingo> http://article.gmane.org/gmane.lisp.guile.devel/17104
<taylanub>zxq9: I believe R5RS support is basically complete, and R7RS-small support is almost done AFAIK (see "wip-r7rs" branch).
<taylanub>Some parts of R6RS are implemented. Trying to fully conform to R6RS might be impractical, I don't know. (AFAIK it has some controversial parts, many other implementations don't care about full conformance either, and R7RS-small/-large likely differ too much from it to make conforming to both possible or practical.)
<ijp>just stop after "I don't know"
*taylanub realizes that "I don't know" and "AFAIK" are technically a contradiction. :P
<taylanub>I need to read through R6RS some time ..