IRC channel logs

2014-04-14.log

back to list of logs

<nalaginrut>morning guilers~
<nalaginrut>oops, the 'apply' in Tree-IL has been changed to 'call'
<nalaginrut>I have to update my code
<ijp>the begin/sequence/whatever also changed
<nalaginrut>since master?
<nalaginrut>or it's changed in stable-2.0?
<waxysubs>it's certainly not changed in stable-2.0
<nalaginrut>ok, thanks for reply
<nalaginrut>I've been playing master for several weeks
<nalaginrut>ArneBab_: well, I wrote a 50 lines elementary arithmetic for the complete and basic multi-lang tutorial
<nalaginrut>even easier than imp
<nalaginrut>elementary arithmetic language
<nalaginrut>ArneBab_: I'll give you link when I done the article
<ArneBab>nalaginrut: cool - thanks!
<b4283>i tried to use sxml-match yesterday. I pasted the example code from the manual to guile REPL and got exceptions
<b4283>does this mean the manual is wrong or ...?
<nalaginrut>hmm? I played sxml-match years ago, I think it works fine
<nalaginrut>but I can't say it work fine after so many updates these years ;-)
<ArneBab>Basic notes on FFI as provider to Batteries and Bindings in Guile: http://draketo.de/proj/py2guile/#sec-5-4
<lloda>ArneBab: comments on netcdf4 vs hdf5?
<ArneBab>lloda: netcdf4 is just a wrapper around hdf5 to make it harder create files which others cannot read ☺
<lloda>would you explain? I've only used hdf5.
<ArneBab>lloda: netcdf4 uses hdf5 as backend
<ArneBab>lloda: it defines a filesystem structure (group/group/variable) with attributes on everything.
<ArneBab>lloda: I stumbled over some files in which a fortran-module used advanced hdf5 features to hack in some information. It took me quite some time to find out that a given attribute was actually necessary to make the code parse files I created.
<lloda>hmm. are they compatible in some way? it looks wasteful having to support both :-/
<wingo>moin
*wingo should write about the closure optimization that landed over the weekend
<ArneBab>lloda: netcdf4 files are hdf5-files, but not always the other way around
<lloda>then it's better to wrap hdf5? that would cover both
<ArneBab>then you would not get the netcdf4 API
<ArneBab>(netcdf3 used a different file-format. Netcdf4 switched to hdf5-format, but with the netcdf API)
<lloda>I see...
<lloda>wingo: master make check fails here at test-out-of-memory with 'error creating finalization thread: Cannot allocate memory' and then 'Bad GET_MEM arg'. That's different than last time.
<wingo>lloda: so the Bad GET_MEM thing should be fixed if you pull from git
<wingo>libgc i mean
<wingo>but errors when spawning the finalization thread is a new one to me
<wingo>thanks for the report :)
<lloda>np. I think I'm already at libgc-master, but will rebuild to make sure.
<wingo>i think ivan just merged the fix for the GET_MEM thing a week ago
<lloda>the last commit I see there is on 2014-04-01...
<lloda>is git://github.com/ivmai/bdwgc.git the official one?
<wingo>lloda: i think so, yes
*wingo checks
<lloda>wingo: recompile just finished
<lloda>PASS: check-guile
<lloda>=============
<lloda>1 test passed
<lloda>=============
<lloda>
<lloda>all good!
<wingo>nice!
<wingo>i suspect you will still see a bug from time to time though
<wingo>exceptions during thread creation probably need some help
<wingo>especially for the finalization thread :P
<lloda>noted
<wingo>please do let me know if/when you see similar failures; if you can reproduce one and supply backtraces that would be extra-useful
<wingo>i think similar problems bork the hydra build
<wingo>reasoning about out-of-memory with overcommit enabled is squirrely
<wingo>found an n^2 thing in scm_make_stack, la la la
*taylanub switched to Debian on the weekend, no more OpenBSD portability reports, but less pain when trying to contribute ..
<ArneBab>wingo: and fixed?
<wingo>working on it :P
<ArneBab>\\o/
<tupi>wingo: just to confirm, updating guile-clutter binding, I can ignore warnings like ... (opaque type for proc g-utf8-to-utf16 gunichar2*) ... right?
<wingo>sure
<wingo>though i thought i made sure to ignore those procedures
<tupi>maybe, don't know, but even though the warning messages would still appear while doing 'make' no?
<tupi>of the warnings we have to deal with, "Opaque type for function clutter-foo: Foo*", I only have to deal with the warning if the proc name "clutter-*" is in the list of new symbols _and_ the opaque type is new too, right?
<ArneBab>is there a way to tell readline to keep newlines?
<ArneBab>if you put in (define (foo)\\n; foo \\n(display 'foo), and the history does not work
<wingo>ArneBab: good question...
<ArneBab>I searched for that a few times but did not find it
<ArneBab>Python seems to have a way to make it work, but I don’t know how…
<wingo>ArneBab: what if you replace guile-readline/ice-9/readline.scm:108 with "\\n" ?
<ArneBab>nice!
<ArneBab>wingo: that works!
<wingo>probably we should do that in guile
<wingo>scheme has problems with that too; if you have
<wingo>(lambda () ;foo
<wingo> 42)
<wingo>then the lines get concatenated and then the ; ends up commenting out the rest of the line
<ArneBab>that’s the example I meant ☺
<ArneBab>(naturally that hurts much more in wisp)
<wingo>yep
<ArneBab>wingo: can you do it right away?
<wingo>sure
<ArneBab>thanks!
*wingo updates his stable branch
<wingo>ArneBab: fixed
<ArneBab>cool - thanks a lot!
<wingo>thanks for the report :)
<ArneBab>wingo: one other question: is it possible to tell guile to use C-o as “send the current line” (like CTRL-D, but without the danger of leaving guile)
<ArneBab>the binding is from http://www.gnu.org/software/bash/manual/html_node/Miscellaneous-Commands.html#Miscellaneous-Commands
<wingo>that probably doesn't have as simple an answer
<wingo>surely the answer is 'yes' but i don't know how to wire that up
<ArneBab>ok - still thanks
<wingo>i've never used that before
<ArneBab>I am searching for a way to avoid typing tw
<ArneBab>3 returns for one-linerrs
<ArneBab>and i think in bash that would work
<ArneBab>… it’s not really clear whether that is correct
<ArneBab>well, one step at a time
<ArneBab>readline completion is already a great step forward!
<dsmith-work>That "Bad GET_MEM arg" sure is annoying.
***fangism-ctrl-Z is now known as fangism
<civodul>Hello Guilers!
<wingo>heya civodul :)
<ijp>hello
<cky>o/
<impaktor>o}-<
<cky>How...horizontal. :-P
<stis>hej civodul and folks!
*stis posted a small intor to guile-prolog at advogato
<stis> http://www.advogato.org/person/tampe/
<ijp>impaktor: itym }o]-<
<ijp>uless you have some suggestions for adding tail to get a proper gnuman
<cky>}o]-E
<stis>:)
<impaktor>I have a C++ code, it computes ODE equations parsed from a text file. I do wonder, if using guile instead of my own parser would lead to faster code?
<cky>Depends on the format.
<impaktor>Format of how I do it with guile?
<cky>No, the format of the text file to parse.
<impaktor>Hm, it's just a plain text file with stuff like (d x1 = x1 + p1*x2), where d x1 means dx1/dt, and then I parse that on the C++ side into an expression with a bunch of virtual inheritance.
<impaktor>which then gets called using GSL (Gnu Scientific Library), to integrate, using some Runge Kutta method.
<cky>Hmmm. Scheme may not be the best to parse that, but you can try.
<ArneBab>civodul: is this OK? http://draketo.de/proj/py2guile/#sec-6-1
<civodul>ArneBab: looks good, yes!
<ArneBab>civodul: great!
<civodul>"GNU Guix uses the facilities of version control systems instead of a signed manifest to verify packages." is a bit ambiguous
<civodul>binaries must be signed etc.: http://www.gnu.org/software/guix/manual/guix.html#Substitutes
<civodul>but git commits aren't signed, indeed
<civodul>also, re EDSLs, it might be more appropriate to link to http://arxiv.org/abs/1305.4584 which has all the details
<ArneBab>civodul: but git commits *could* be signed.
<cky>ArneBab: Not really. git tags can be, though.
<civodul>cky: commits can also be signed
<civodul>i learned it recently
<civodul>but it's not very convenient
<cky>civodul: Huh, interesting.
<ArneBab>civodul: linking to the paper sounds good
<civodul>git commit --gpg-sign
<ArneBab>cky: in Mercurial I’m used to signing all my releases
<civodul>Guile and Guix tags are signed too
<cky>ArneBab: Well, ditto with Guile releases, as civodul just mentioned.
<cky>ArneBab: But releases are tags.
<ArneBab>the important part is that since commits are immutable children of all their ancestors, one signature can sign many commits
<cky>Yes.
<ArneBab>(that’s the same in hg and git: same concept, just a different implementation)
<cky>*nods*
<ArneBab>civodul: linked to the paper ☺
<ArneBab> http://draketo.de/proj/py2guile/#sec-6-1
<tupi>civodul: do you know the englih expression of "swimming in the fog" :) ?
<civodul>tupi: not yet, tell me
<tupi>i don't either, although i did live a while in the us, maybe i knew but i forgot,
<civodul>ok :-)
<civodul>ArneBab: regarding car and cdr, current orthodoxy recommends pattern matching: http://www.gnu.org/software/guile/manual/html_node/Pairs.html
<civodul>much saner :-)
<ArneBab>civodul: I’ll try to look at it later. Thanks!