IRC channel logs

2014-02-26.log

back to list of logs

<nalaginrut>morning guilers~
<mark_weaver>tupi`: you around?
<Madsy>Hey mark_weaver
<mark_weaver>Hi Madsy
<Madsy>I'll see if I can test the latest guile sources tomorrow
<Madsy>If I can remember the build process that is :)
<mark_weaver>heh :)
<mark_weaver>it you could keep notes of how to build it, that would be helpful.
<mark_weaver>tupi`: the reason that number is not being printed as 0.3 is because it's not the float that's closest to 0.3.
<mark_weaver>ultimately, the bug is in whatever code parsed that "0.3" and turned it into a float. if you used guile to do that conversion, it would work properly and print as 0.3.
<mark_weaver>also, the sqlite3 terminal has imprecise numeric output. it would presumably print two different values the same way. at least I hope it would print the value closest to 0.3 as "0.3". it is printing a number that's different from the closest value as "0.3" also, so the output is lossy.
<mark_weaver>here is the closest IEEE 754 double to 3/10: 0.010011001100110011001100110011001100110011001100110011
<mark_weaver>that's written in binary, and that last '1' is the least significant bit in the IEEE double representation.
<mark_weaver>the number that's in your sqlite3 database is this: 0.010011001100110011001100110011001100110011001100110100
<mark_weaver>so it was incorrectly rounded by the numeric input routine.
<mark_weaver>on the other hand, maybe 0.3 wasn't converted from a string. maybe it was computed in some way. in that case, it can't be helped if the computations and/or intermediate values are represented in binary. 1/10 can't be represented precisely in binary, so it's like computing 1/3 in decimal and then multiplying by 3 and getting 0.999999999999. it can't be helped.
<mark_weaver>you could either use exact rationals, or round off the last few digits and hope that the error is confined to those last few digits.
<mark_weaver>or you could represent durations as milliseconds (or maybe hundredths or tenths).
<nalaginrut>is there tree shaker in current master?
<sdl>1
<wingo> http://sockpuppet.org/blog/2014/02/25/safely-generate-random-numbers/
<atheia>g'morning guilers
<wingo>moin
<atheia>neat b-day hack — the demo was very… peaceful :-)
<nalaginrut>nice, I should update the session id generator of Artanis ;-)
<nalaginrut>mozilla try to invent a new browser with Rust
<nalaginrut>reinvent
<wingo>tx :)
<ArneBab>I added the comments from mark_weaver about foof-loop and SRFI-42 into my path from python to guile: http://draketo.de/proj/py2guile/#sec-5-1-2-5
<add^_>Uh, if a struct I want to parse contains a char array, how do I go about that?
<add^_>The (system foreign) list of types doesn't show char..
<add^_>Maybe I can make it an 8bit int that I convert to char later?
<add^_>:-/
<add^_>The struct I want to parse contains a char tag[];....
<add^_>err.. char tag[32];
<add^_>w/e
<lloda>does Guile have a path library? something like os.path in Python...
<add^_>path library?
<lloda>like os.path.join(path, dir, dir, basename)
<lloda>takes care of / vs \\, dunno
<add^_>I think it's even part of guile per default, but that is if I'm thinking of the same thing..
<lloda>which function?
<add^_> https://www.gnu.org/software/guile/manual/html_node/Load-Paths.html
<add^_>Like that?
<wingo>there is something, let me find the link
<wingo>lloda: http://www.gnu.org/software/guile/manual/html_node/File-System.html at the end for the underlying bits, and in-vicinity (strange inherited name) for joining dir and path
<wingo>not much more sugar though
<wingo>see boot-9, search for "separator"
<wingo>where are you based in .ch btw, lloda`?
<lloda`>my desktop just crashed :-/
<lloda`>I'm in Lausanne
<wingo>neat, i am near annemasse, near geneva
<wingo>i'm giving a talk in lausanne tomorrow if you're interested; it's on javascripty things tho ;)
<lloda`>would be nice, don't know if work will allow me :-(
<wingo>heh, always an issue
<wingo>anyway http://www.meetup.com/jsromandie/events/164820382/ fwiw
<lloda`>wingo & add^: I can use file-name-separator for what I need, thanks for the help
<add^_>:-)
<add^_>Although I didn't do anything helpful apparently, I guess I missunderstood your question..
<add^_>sorry
<lloda`>wingo: the hour is good and it's like 50 m from here...
<wingo>heh, neat
<lloda`>I don't know a lick of JS though :-p we'll see!
<lloda`>add^: my question wasn't very clear either!
<cluck>:)
<lloda>would anybody find this useful?
<lloda> http://paste.lisp.org/display/141388
<didi`>lloda: I don't think it works.
<didi`>lloda: (join-path-components (list "foo" "bar")) => ""
<lloda>takes a rest list, so: (join-path-components "foo" "bar")
<didi`>lloda: Ah, right.
<didi`>lloda: But it still doesn't work.
<didi`>(join-path-components "foo" "bar") => ""
<lloda>right, hm...
<lloda> http://paste.lisp.org/display/141388#1
<didi`>Cool.
<lloda>I've emailed guile-user and I've received a weird email from guile-user-owner saying 'The results of your email commands...' What did I do?
***cluck` is now known as cluck
<didi>lloda: Are you subscribed to the list?
<lloda>yes, the digest
<tupi`>wingo: just pushed the sqlite-bind fix
<stis_>gah, I just cant get texinfo to work, any masters in here?
<stis_>I just cant get the 'up' 'prev' etc to work
<atheia> /quit
<atheia>damn.
<atheia>:-)
<wingo>stis_: you mean for a @node? usually you don't set them at all and just rely on texinfo to do it for you
<wingo>tupi`: excellent :)
<stis_>wingo: yeah, I thought so, but it's not working, and I cant find out why!
<wingo>stis_: check your sectioning then?
<stis_>you mean of the nodes flow correctly after each other?
<stis_>Ahh, got it, I used chapter and not section after node, thank you sir :-)
***Fuuzetsu is now known as Guest99573
***stis__ is now known as stis
***ota_ is now known as ota
***Guest99573 is now known as Fuuzetsu
***forgottenwizard is now known as ZombieChicken