IRC channel logs

2014-02-21.log

back to list of logs

<didi>Does guile read my ~/.guile when I run programs from the command line like `$ guile foo.scm'?
<ijp>I think so, unless you use -s
*ijp RTFMs
<ijp>no, only during interactive use
<didi>ijp: Hum. It doesn't look like it does. I add a directory to the load path inside my ~/.guile and I can `,use' it from the REPL, but `guile foo.scm' reports there is no code for the module.
<didi>Ah.
<didi>Hum, I must use another strategy for adding directories to the load path.
***turbofai` is now known as turbofail`
<ijp>GUILE_LOAD_PATH or -L
<didi>I guess I'll go to the env variable so then geiser can take advantage of it too.
***heroux_ is now known as heroux
***sneek_ is now known as sneek
<didi>If I have a library that uses GOOPS and I want users to instantiate objects from a class <foo>, what do I #:export?
<ijp><foo> and any new generics you've written
<didi>ijp: Nice. Will users have to use-module (oop goops)?
<ijp>yes
<didi>OK. Thanks.
<ijp>unless you also export define-method etc.
<ijp>which you shouldn't
<didi>I won't.
<nalaginrut>morning guilers~
<didi>Does guile move structures created with `make-c-struct' around?
<didi>Meaning, do I have to worry about (pointer-address (make-c-struct ...)) changing?
<mark_weaver>it certainly won't change.
<mark_weaver>even if we moved to a moving GC, I'm sure that we'd arrange to make sure that anything created by make-c-struct would never move.
<didi>mark_weaver: Oh, nice. Thank you.
<mark_weaver>np!
***turbofail` is now known as turbofail
<stis>cha guilers!
<wingo>moin
<stis>morning wingo:
<wingo>morning!
<ArneBab>moint wingo
<stis>how do I get the module a procedure is defined in?
<taylanub>sneek: Later tell didi if you're using `make-c-struct', also see https://gitorious.org/taylan-guile/bytestructures/, just be wary that offset calculation will happen at run-time so you don't want to use it in the innerest of inner loops
<sneek>Got it.
<taylanub>sneek: Later tell didi on my 2.0 GHz Core2Duo I can make a million references in 6 seconds for the fourth field of a struct within a vector within a struct, or 8 seconds if I reference the 7th field of said struct (the depth of the type (layers of vectors/structs) and, in case of structs, the position of the field, affect the referencing speed)
<sneek>Will do.
<taylanub>Hrm, I should just put those results into the docs.
<stis>nay there isn't such a binding, soI need to use procedure-proerties and roll my own binding
<unknown_lamer>wingo: compost!
<unknown_lamer>wingo: I created a vectorizing abstraction based on cut, once I am done slogging through hcoop crap (I guess I have to rekey an afs cell, ugh) I am totally going to port it to work atop compost
<unknown_lamer>this appears also to solve the whole fp performance thing
<unknown_lamer>onward, toward cool 3d graphics hacks in guile
<wingo>stis: it's quite tricky in master
<wingo>well, stable-2.0 as well for that matter
<wingo>if a function doesn't reference any toplevel bindings, is it defined in a module at all?
<stis>yep, I just decided to roll my own system useing procedure-properties.
***mario-go` is now known as mario-goulart
***ota_ is now known as vojjta
***vojjta is now known as ota_
***ota_ is now known as ota
<wingo>oooh, i might have found the segfault
<wingo>yays
<wingo>that's a pretty weird one :)
<stis>crunch!! (the sound of a squached bug is sooo pleasing)
<wingo>:)
<wingo>mark_weaver: did you see i removed the hard stack size limit in master? :)
<wingo>we still need some nice way of controlling the soft limit
<wingo>but probably we can default to not having a soft limit
<wingo>as we don't have a limit for the heap
<wingo>and install a limit in the repl
<dsmith-work>Happy Friday, Guilers!!
<wingo>heya dsmith-work :)
<mark_weaver>wingo: yes, I saw that, and was most glad :)
<stis>Happy friday dsmith-work!
***wingo_ is now known as wingo
<wingo>are there any examples of libs that guile has incorporated into its distro for which that has been a bad idea?
<wingo>statprof, sxml, etc -- all good in practice, it seems to me
<civodul>wingo: i can't think of any bad example
<civodul>we've only made smart choices, obviously
<civodul>:-)
<wingo>haha ;-)
<civodul>is it a bug that (string-locale<? "a" "B") => #t in en_US locale?
<civodul>and fr_FR
<wingo>it's not a specified procedure, is it?
<civodul>no, it's (ice-9 i18n)
<wingo>yeah dunno then
<cluck>:)