IRC channel logs

2014-01-16.log

back to list of logs

<civodul>so many game frameworks in Guile! :-)
<davexunit>mark_weaver: is what you posted on the ML awhile ago the most recent version of the mvars module?
<mark_weaver>iirc, I posted two versions. make sure it's the later one.
<davexunit>yes, I'm using the later one.
<davexunit>would this be part of ice-9?
<davexunit>(ice-9 mvars) ?
<mark_weaver>I think that's what I named it, yes.
<mark_weaver>if you like, I can send you my current version.
<davexunit>yeah, it is. missed that somehow.
<davexunit>sure.
<davexunit>that would be useful.
<davexunit>dthompson2@worcester.edu
<mark_weaver>sent
<mark_weaver>it's not a commit; just the file. I'm not sure I ever made it into a commit.
<davexunit>okay.
<mark_weaver>I need to revive the thread about it.
<davexunit>my patch will just assume that (ice-9 mvars) is there and if/when it gets a new name we can change it.
<mark_weaver>sounds good.
<mark_weaver>Thanks! I'm overwhelmed with things to do for Guile, so if you could help get this REPL thing done, it would be much appreciated :)
<davexunit>I will try my best. :)
<davexunit>TIL that *unspecified* is a thing. neat.
<markwitmer>#quit
<davexunit>whoa markwiter showed up! stay awhile next time...
<davexunit>mark_weaver: so with this new repl patch, we want to avoid that read-wrapper stuff that we did before, right?
<davexunit>this should be done without adding a new REPL option.
<mark_weaver>that's right.
<mark_weaver>I'm concerned that the read-wrapper exposes an API that we might regret later.
<davexunit>that's valid.
<mark_weaver>however, it might be reasonable to use something like that internally, dunno.
<davexunit>okay. I'll need to generalize a thing or two. finding the best places to do so is the tricky part.
<davexunit>perhaps run-repl can take a reader proc which is prompting-meta-read by default, that way I can insert my own wrapper around it.
<mark_weaver>that makes me a little nervous since run-repl is exported.
<davexunit>ah, true.
<mark_weaver>maybe rename the existing 'run-repl' to something else that's not exported, and then make 'run-repl' just call the new internal procedure with 'prompting-meta-read' as an argument?
<davexunit>then I'd need to write another procedure that calls the internal procedure with a new reader.
<davexunit>and export that.
<mark_weaver>well, I think it would be okay to call it using the (@@ <module> <id>) syntax.
<davexunit>oh okay.
<mark_weaver>or to make the code a little nicer, do something like (define run-repl* (@@ (system repl repl) run-repl*))
<mark_weaver>effectively importing the non-exported binding.
<davexunit>okay. that seems a little strange to me, but I guess it's okay since we really don't want to expose the procedure publicly.
<mark_weaver>I agree that it's a little strange and ugly.
<mark_weaver>but unfortunately in this case we need two modules to cooperate behind the scenes without exporting the private interfaces between them.
<davexunit>yeah
<davexunit>getting this to work with the (system repl server) module will be even more fun, heh.
<nalaginrut>morning guilers~
<b4283>salut
<dje42>Am I correct in saying strings in Guile don't have an encoding. Reading/writing strings requires an encoding of course.
<dje42>e.g. If I have a Scheme function that returns a string, do I need to specify what the encoding of the result is?
<mark_weaver>that's correct.
<mark_weaver>in Guile 2, strings are sequences of unicode code points.
<dje42>That's what I thought. Cool, thanks!
<mark_weaver>(in guile 1, they were just byte strings)
<dje42>Ah, right.
<civodul>Hello Guilers!
<nalaginrut>heya
<ArneBab>moin
<jemarch>hi
<civodul>hey jemarch
<wingo>o/
<tromey>congratulations on your /. article wingo
<wingo>haven't seen that one!
*wingo goes to look
<tromey>it was yesterday
<davexunit>awful slashdot comments. why am I not surprised?
<tromey>never read the comments!
<davexunit>I get sucked in by the trolls. :(
<tromey>me too, so for my sanity I rarely read comments
<tromey>life's too short for all that crap
<davexunit>if only I had your decision making skills :P
<tromey>haha
<davexunit>wingo's article was above my level of understanding, but I did learn a bit about what CPS is.
<davexunit>I couldn't use the API, but I have a better idea of what it does and why.
<wingo>hehe
<wingo>i don't expect anything from comments, so it's all amusing
<taylanub>where's the article ?
<davexunit>taylanub: http://wingolog.org/archives/2014/01/12/a-continuation-passing-style-intermediate-language-for-guile
<taylanub>oh, I was searching slashdot :P
<taylanub>thanks
<wingo>i just finished updating docs for the new compiler btw, so in master it's all part of the "Guile Implementation" section
<davexunit>searching slashdot for "wingo" gets you there.
<wingo>i don't plan on touching that much more at this point, need to focus on a release
<wingo>main missing thing is NEWS now
*wingo looking at lloda's thing today also :)
<dsmith-work> http://developers.slashdot.org/story/14/01/15/190230/gnu-guile-scheme-gets-a-register-vm-and-cps-based-il
<ArneBab>from ./ on the discussion about embedding guile: “Guile's real strength is that you can shove it into pretty much any other language. I use it in a project primarily written in C, and it easily lets users add real customization without having to recompile anything.” http://developers.slashdot.org/comments.pl?sid=4672097&cid=45969143
<ArneBab>wingo: I’m currently writing an article on my path from python to guile. Would you be able to do a review on its readability when I’m finished? I ask you, because your article are mostly a joy to read, so I hope that you can find the places where I need blow dust from my text ☺
<ArneBab>is there a way to use FFI with fortran?
***jao is now known as Guest80122
<ArneBab>can (dynamic-link ...) link to C++ libraries? I tried linking libstdc++ and it fails with file-not-found: (define libstd (dynamic-link "/usr/lib/libstdc++.so.5"))
<ArneBab>bbl
<wingo>moo
<ArneBab_>re
<dsmith-work>Whee. The guile manual is now at 900 pages. With the TOC spanning 20 pages.
<davexunit>damn. that's a big book.
<developernotes>So how are things coming along with the next release of guile?
<ggrant>davexunit: Yah, mwitmer committed your fix! :^)
<davexunit>ggrant: :)
*ggrant was thinking of seeing if he had some free-time this weekend to start a *.texi ... looking like it might be a better goal for next-week, by the look of it thusfar.