IRC channel logs

2013-09-25.log

back to list of logs

<civodul>hey
*civodul just filled out the GSoC forms
<civodul>sneek: seen bipt
<sneek>I last saw bipt on Sep 19 at 09:44 pm UTC, saying: so for CL, for example, i wouldn't find it too inconvenient to require a modules.scm packages or similar, vs. having a module definition written in portable CL. i also think ML-style module features are more natural with separate configuration, at least based on my limited experience with scheme48.
<add^_>sneek: seen add^_
<sneek>add^_ was here Sep 25 at 12:53 pm UTC, saying: sneek: seen add^_ .
<add^_>:-)
<add^_>That's actually a kinda convinient way of checking what time it is in UTC.
<wingo>heh
<add^_>Hm, maybe sneek have a time command?
<add^_>sneek: time?
<add^_>sneek: time
<add^_>nope
<DeusExMachina>Hi
<DeusExMachina>can someone help me with a problem?
<wingo>ask away
<wingo>meaning, go ahead :)
<DeusExMachina>is guile aviable on windows?
<wingo>we don't provide pre-built binaries
<wingo>guile does build on windows, in various ways (cygwin and mingw)
<DeusExMachina>how can I build it on windows?
<wingo>you choose whether you want to do it using cygwin or mingw
<wingo>you choose whether you want to build it on windows or cross-compile from linux
<wingo>then you set up your build environment with the right tools, and from there it's just a normal autotools project
<wingo>it can be a bit frustrating, admittedly...
<DeusExMachina>ook
<DeusExMachina>how do I cross compile it from Linux?
<wingo>that warrants a mail to guile-user so you can get the right people to respond :)
<DeusExMachina>ok
<dsmith-work>Nope. No time
<add^_>ok
<dsmith-work>!uptime
<sneek> 09:49:44 up 29 days, 1:58, 0 users, load average: 0.01, 0.05, 0.05
<dsmith-work>That's the system uptime
<add^_>ah
<add^_>nice
<add^_>Maybe that's something for ijp and aidalgol to add ;-)
<add^_>Unless ofcource they already done that
<ijp>adding it would be trivial, but better still would be adding a time command like lambdabot has, that can give localtime for a particular user
<ijp>so then you can do "time add^_" and get whatever time it is where add^_ is
<add^_>that would be nice yes
<dsmith-work>ijp: Based on ip address?
<ijp>that would be one way to do it
<ijp>I forget what lambdabot does
<civodul>dmd is back to life! http://www.gnu.org/software/dmd/
<civodul>just in case someone is look for a place to hack :-)
<ijp> http://shift-reset.com/blog/2013/9/25/Fun%20with%20Self-Reproducing%20Programs/
<ijp>d'oh, I see untranslated markup
<davexunit>civodul: so it's an init system written in guile?
<davexunit>everyone seems to be using systemd these days
<foeniks>hi, I have been using port->string while writing my clojure parser since I were annoyed by the statefulnes of read-char.
<dsmith-work>civodul: That's the init manager for hurd that Wolfgang somename wrote in guile?
<sneek>foeniks, you have 1 message.
<sneek>foeniks, dsmith-work says: org-mode comes with emacs, though you can install a fresher version from http://orgmode.org/
<foeniks>I do wonder what your opinion is on that approach
<foeniks>for now its seems that it is more problematic to get line number and character number that way
<ijp>okay, post should be fixed nwo
<ijp>now*
<ijp>many of you have seen the code already, but I promised shanecelis I'd write it up
<ijp>it also means I am desperately in need of something utterly ridiculous to write
<dsmith-work>civodul: Yey! btw
<foeniks>is there a way to get all available identifiers in the current namespace?
<bananagram>can you sleep for a fraction of a second somehow?
<bananagram>sleep only accepts integers
<ijp>all the ones bound in a module is easy, all the imports is a little trickier
<ijp>the former is (hash-map->list (lambda (k v) k) (module-obarray (current-module)))
<ijp>to get imports, you'll also need to scan the uses list
<ijp>I think
<ijp>foeniks: out of curiousity, what are you doing?
<ijp>bananagram: usleep
<ijp>usleep isleep weallsleep
<bananagram>usleep only accepts integers too
<mark_weaver>bananagram: usleep accepts only integers, but those integers are in units of microseconds.
<bananagram>oh, okay
<bananagram>thanks
<mark_weaver>np!
<add^_>Uh, I just accidentally forked cunning-bot when I wanted to copy the copying text.. lol
<add^_>Oh well
<add^_>Hm, renamed the project, but now I've named it back again, might as well keep the original name if I want to help out :-P
*add^_ is feeling silly, as if he had too much whisky
<foeniks>ijp, filling up a vim guile mode's function list
<dsmith-work>μsleep
<civodul>davexunit, dsmith-work: yes, it the init system writte 10 years ago (!) by Wolfgang Jährling
<civodul>it's very GOOPSy, but pretty cool (nonetheless ;-))
<davexunit>civodul: do you plan on getting it up to snuff to be a real contender?
<davexunit>new init systems are quite controversial.
<civodul>it's not new, it's 10 years old! :-)
<civodul>the short answer is "we'll see"
<civodul>it's definitely better than most init systems out there
<civodul>but not as fancy as systemd in some ways
<davexunit>I'm open to the idea. :)
<davexunit>I just frequently see flame wars about systemd
<mark_weaver>systemd has some great features, but its decision to exclude support for all kernels other than Linux is a deal breaker for me.
<mark_weaver>I also dislike that so many changes require recompiling from C.
<mark_weaver>IMO, a better long-term strategy is to incorporate the good aspects of systemd into dmd.
<civodul>agreed on all points
<mark_weaver>:)
*civodul is consensual ;-)
<foeniks>can one be init system agnostic?
<civodul>not but seriously, that's the thing: there are good ideas, but it relies on Linux-only hacks, and it's C, which makes it not-so-much hackable
<civodul>foeniks: to some extent
<civodul>but systemd wants to eat your whole system ;-)
<mark_weaver>and leave all other kernels out to dry.
<dsmith-work>Yeah, I was looking into init systems.
<dsmith-work>I settled on runit
<dsmith-work> http://smarden.org/runit/ Is in busybox
<civodul>didn't know this one
<dsmith-work>It's kind of liek daemontools
<add^_>If I do this: guile --listen -L blah -L blah2
<add^_>will it include both of those directories? Or should I do it some other way?
<add^_>like -L "blah:blah2" or something?
<dsmith-work>add^_: try guile -L /foo/bar -L /baz/zap -c '(display %load-path)(newline)'
<dsmith-work>add^_: And with only one -L
<dsmith-work>And none
<add^_>hm
<mark_weaver>add^_: yes, it will include both. -L blah:blah2 won't work.
<mark_weaver>unlike GUILE_LOAD_PATH, which gets parsed into colon-separated components, -L does _not_ get parsed.
<mark_weaver>-L simply gets prepended to the %load-path as-is, regardless of what characters are in it.
<add^_>ah
<mark_weaver>(assuming of course that you've properly quoted it in your shell)
<add^_>ok
*add^_ is trying to load everything in the spells project but isn't really succeding..
<add^_>Because something needs something else and that something else needs yet another something..
<add^_>Actually, thinking about it, it *should* work..
<add^_>But it gives me a warning about network.sls can't compile because there is no code in the "network compat" module..
<add^_>oh
<add^_>-.-
<add^_>Nevermind
<add^_>sorry for the noice
<add^_>Actually, I didn't solve the problem, ARGH.... Still, sorry for the noice...
<add^_>Oh.. For some reason it doesn't find the file because it's called something else than the module is? But why does it work for ijp and not me?
<add^_>ijp: are you using your fork of spells?
<add^_>No, can't be, since it's no commits after or before the master one..
<mark_weaver>add^_: might it be because the files end with .sls?
<mark_weaver>ijp renamed the files to .scm
<add^_>hm
<add^_>Maybe
<add^_>No he didn't
<add^_>Not in the repo on github at least
<add^_>And I think it should load .sls files on this setup, because I should have explicitly told guile to read those..
<add^_>Yes
<add^_>I did
<mark_weaver>add^_: try passing -x .sls to guile
<mark_weaver>add^_: to clarify, ijp renamed the files to .scm in guildhall
<add^_>oh
<add^_>For some reason guildhall doesn't work for me anymore..
<add^_>didn't work with the -x .sls
<add^_>I guess I can try to install it again, but if it messes up my guile again I'm not going to be happy ;-)
<davexunit>I have never successfully used guildhall
<add^_>There is an error saying "R6RS exception: &assertion"
<add^_>When I run make on it
<add^_>Oh well
<add^_>:-(
<add^_>I dunno what happened, if guile was updated in some way that made it break
<mark_weaver>add^_: are the guildhall dirs in your %load-path?
<add^_>I'm just following the wiki :-/
<add^_>Well, I added it now, still the same error.
<add^_>reran autogen, configure and make (with a clean)
<add^_>No dice
<tupi>add^_: are you trying to install guildhall or developping something that you'd like to guild host ?
<mark_weaver>add^_: maybe you have something from spells in your path, that's overriding something important from guildhall? or maybe if you installed spells, you overwrote some important part of guildhall?
<add^_>hm
<add^_>I don't have spells installed
<add^_>But
<add^_>I have both spells and guildhall in the directory (I didn't use to though)
<mark_weaver>sounds dicey
<add^_>I moved it
<mark_weaver>isn't guildhall derived from spells?
<add^_>Now
<add^_>Still doesn't work
<add^_>Argh
<add^_>Ah, wait, the local thingy
<civodul>mark_weaver: guildhall derives from Dorodango, which uses Spells
<add^_>Hm
<add^_>No dice
<foeniks>is guildhall something like ruby gem for guile?
<mark_weaver>closer to apt-get
<foeniks>is there a central or default repository
<foeniks>while googling I found http://shift-reset.com/doro/
<add^_> https://github.com/ijp/guildhall
<foeniks>ah, I mean for the package list, not the source ;)
<add^_>oh
<add^_>right
<add^_>It's in filesys it goes wrong at least
<civodul>ijp: ooh, trusting-trust at http://shift-reset.com/ :-)
*civodul discovers the blog
*tupi think that guild rocks and hoped guildhall be further developed, so it could be used to install guile S/W that depends on C libraries, not just scheme, like guile-gnome, guile-clutter, kisê ... but ijp got the Tree-IL, compiler ... fever, no one knows if there is a cure :) let's just hope...
<add^_>:-P
<add^_>Oh well
<add^_>I'll try again with the "normal" way to do it..
*civodul points Gnus at gwene.com.shift-reset
<add^_>ARGH
<add^_>I just need spells, not anything else. Why is it so hard to get it to work?
<add^_>I'll try the thing you said mark_weaver
<add^_>Renaming the files
<add^_>Uh
<add^_>Is there a faster way of doing that?
<add^_>Than doing it manually :-P
<add^_>Tried with some files (the needed ones) but didn't work
<add^_>Uh
<add^_>Nevermind, I'll continue tomorrow
<add^_>Now, bed..
<add^_>Good night all!