IRC channel logs

2013-08-10.log

back to list of logs

<ltsampros>didi: I concur. public logging without topic warning is kinda spooky
<dsmith-work>It's been suggested that about half the nicks in here are just logging bots
***ijp` is now known as ijp
<rlb>didn't realize this channel was officially, publically logged... But do channels normally mention that? I know of at least one that I just checked that doesn't.
<rlb>...and I'm wondering if the disclaimer's really helpful since anyone could publish logs anytime they like.
<rlb>(for any public irc channel)
<rlb>no?
<didi`>rlb: They should.
<didi`>Also, <http://freenode.net/channel_guidelines.shtml>
<rlb>ok, thanks -- didn't know about that
<rlb>(and my personal preference would be to not log, fwiw)
<didi`>Both.
<rlb>So is the logging here official?
<rlb>oh, missed the rest of that conversation in the backlog -- reading it now
<mark_weaver>rlb: I asked Christian Grothoff to log this channel. I didn't think it was controversial since #guile had been logged by rotty for a long time, and that was common knowledge on channel. See https://gnunet.org/bot/log/guile/2013-03-27 for Grothoff's announcement here.
<mark_weaver>If people would prefer to not log, I'm okay with that too.
<mark_weaver>Thoughts?
<rlb>mark_weaver: ok, right -- I'll hold off for further discussion, and then we can either change the topic or the approach. Thanks.
<shanecelis>hello guilers
<mark_weaver>hi shanecelis!
<ltsampros>Hi guilers
<ltsampros>is there any way to get pi (the greek π) in guile?
<weinholt>i always use (angle -1) for that
<weinholt>if you meant the mathematical constant? for the character use #\\π or #\\x3c0
<ltsampros>a thanks
<ltsampros>I just needed a value. I'm greek so i'm utf-8 ready
<weinholt>:)
<ltsampros>(define π (angle -1)) worked just fine .
<ltsampros>btw, I'd have never thought to use (angle -1)
<weinholt>just one of those tricks you pick up along the way
<amk9>hi :)
<amk9>one guy got around generating the docs for the generated gnome introspection bindings http://lazka.github.io/pgi-docs/
<amk9>exactly what I was looking for
<amk9>they are guile binding of gir http://gitorious.org/guile-gir a bit old though
***Guest2306 is now known as jao
<shanecelis>hello guilers
<shanecelis>What's a good way to make a trampoline out of a symbol?
<shanecelis>Given 'foo-func, I want to make (lambda () (foo-func))
<didi>shanecelis: They me more about this "trampoline out of a symbol". Maybe you are talking about continuations?
<didi>s/They/Tell
<mark_weaver>shanecelis: (define (make-trampoline s) (compile `(lambda () (,s)) #:env <desired-module>))
<mark_weaver>where <desired-module> is the module object of the top-level environment you want the lambda within.
<shanecelis>mark_weaver: that'll do it.
<shanecelis>thanks, mark_weaver!
<mark_weaver>you're welcome! happy hacking :)
<shanecelis>didi: I want to provide a trampoline to some function foo instead of foo, so that when foo is redefined, it'll call the current foo and not what it was previously defined as.
<shanecelis>It still trips me up that I can compile things at runtime. So cool.
<didi>shanecelis: Hum. I don't think I fully understand you. But that doesn't matter. mark_weaver saved the day. :^)
<mark_weaver>it is certainly quite empowering to be able to so easily compile new code bits at runtime.
<mark_weaver>and hopefully in the not-too-distant future, it'll be native code that is so easily generated :)
<shanecelis>That'll be awesome.
<stis>evening guilers!
*stis is spamming the mailing list again :-)
<stis>mark_weaver: It would be soo cool if we could get native code and fast call's for C functions.
<stis>But actually low overhead C functions calls should be possible to get before native arrives no?
<mark_weaver>maybe, I don't know.
<stis>Anyhow, I plan to do an example optimizing the thrusts of a toy moon rocket using guile, guile-log and some 2d game tools
<mark_weaver>sounds neat!
<stis>The speedy stuff of the algorithm could be done in C and guile-log to tree serach the optimum.
<stis>What 2d tools are there to use?
<mark_weaver>well, personally I'd go with guile-figl, but guile-sdl might be more your style, dunno.
<stis>Ok, thanks!
<mark_weaver>there's also guile-cairo
<stis>which are easiest to install?
<mark_weaver>definitely a good option as well
<stis>For you who is math wiz, tree search an optimum is not doable, I will combine it with some heuristics!
<mark_weaver>you'll probably have to compile from source. I don't think they differ in build difficulty much.
<stis>Ok, cool, I will look into it, thanks again!
<mark_weaver>you're welcome, happy hacking!