IRC channel logs

2013-07-02.log

back to list of logs

<dsmith>sneek, later tell civodul I didn't mean to depend on libev, but rather to take abstraction ideas from it.
<sneek>Got it.
<nalaginrut>morning guilers~
<wleslie>afternoon nalaginrut!
<nalaginrut>wleslie: heya
<civodul>Hello Guilers!
<sneek>Welcome back civodul, you have 1 message.
<sneek>civodul, dsmith says: I didn't mean to depend on libev, but rather to take abstraction ideas from it.
<ISF>what happened to the (ice-9 debug) in guile 2.0?
<civodul>ISF: it vanished, because it no longer makes sense there
<civodul>it issues this warning: "(ice-9 debug) is deprecated. Use (system vm trace) for tracing."
<ISF>civodul: there's no warning for me (or I'm not importing the ice-9 correctly)
<civodul>ISF: you get that message if you set GUILE_WARN_DEPRECATED=detailed
<civodul>(the environment variable)
<ISF>civodul: ah, thanks for the tip
<ISF>civodul: so, how do I get a trace like the one from ice-9? I tried ,option trace #t ,trace function (function args) but it doesn't show anything
<ISF>civodul: sorry, got it working, it just doesn't work in geiser (with guile)
<civodul>ISF: good (sorry, was on the phone)
<taylanub>Where can I read more about the kind of vtables that Guile uses ? When I Google, I only get results related to the method-dispatch mechanism as used in C++ and such; is that even related ?
<civodul>taylanub: in the fine manual, of course ;-)
<civodul>info "(guile) Structures"
<civodul>it has nothing to do with C++ vtables
<civodul>it's a misnomer, really
<taylanub>Oh I meant more than what the manual has. It explaints their usage, what they are etc., but I wonder where they came from, why one would use such a weird thing for structs, etc.
<civodul>i think it originates in Guile
<civodul>it's slightly overengineered, because there are 'o' fields for instance
<civodul>and 's'
<civodul>and tail arrays
<civodul>all these things we pay for without ever using them ;-)
<taylanub>Manual says tail arrays are depracated; are s and o fields also considered harmful ?
<civodul>they are considered useless, mostly :-)
<civodul>i think 's' is used somewhere internally, but 'o' isn't used anywhere AFAIK
<civodul>it was meant as a kind of interface with C, like SMOBs
<taylanub>I wonder what pieces of code other than records use vtables and structs, and whether those pieces of code could switch to just using records, after which the record code could be simplified ?
<civodul>GOOPS uses it
<jave>hello
<jave>what's the status of guile-gstreamer?
<civodul>dunno
<civodul>i think it needs love
<civodul>did you try building it?
<jave>no
<daimrod>Killed buffer
<ijp>very loudly too
<shanecelis>hey guilers
<taylanub>Hidy ho
<shanecelis>I have an app with guile integrated that will sometimes segfault because I connect to the REPL server. Am I doing something obviously wrong?
<shanecelis>sometimes it works fine. Other times, it kills the app.
<davexunit>hmmm I've never seen that happen, shanecelis.
<shanecelis>cool. Maybe I'm just doing something wrong. I'll run the app in GDB from now on, and see if I can spot what's going wrong.
<davexunit>I had a game prototype that I could use a REPL from. the only thing that crashed it was when I tried to replace certain fundamental procedures in my game loop.
<atheia>Hello everyone!
<atheia>A question about Guile and Unix Domain sockets.
<atheia>I'm trying to use (read) and (write) to pass data from a 'server' process to a 'client' process
<atheia>The doc seems to imply that read will read the next s-expression from the port,
<atheia>but I'm finding it keeps reading until the port is closed by the other side.
<atheia>Is this what is supposed to happen?
<LAMMJohnson>atheia: I believe it's the same behaviour as the read system call
<LAMMJohnson>Read until the other side closes the connection or until n bytes
<LAMMJohnson>Except in guile you don't specify a byte limit because you're not reading into a fixed-size buffer