IRC channel logs

2013-06-23.log

back to list of logs

<davexunit>best data structure for vector math operations (add, mul, scale, normalize, magnitude)? vectors #(1 2 3) ? bytevectors? plain lists?
<fbs>davexunit: youre doing the opengl thing right?
<davexunit>yes
<davexunit>but this is more of the not-necessarily opengl related stuff.
<davexunit>lists are probably the easiest thing to work with
<fbs>might be interesting to just test a few in a big benchmark and see what works best
<davexunit>yeah
<davexunit>that's true
<fbs>writing a few generic math operations shouldnt be that hard
<fbs>if you want fast fast you probably want to make use of of simd stuff like sse https://en.wikipedia.org/wiki/SIMD
<davexunit>thanks
<davexunit>I probably don't need *that* fast, but vector math is such a common thing for games that I'd like to provide procedures that aren't totally wasteful.
<fbs>do you have gpu accel?
<davexunit>yes, but I don't know if I want to be using the gpu for this stuff.
<davexunit>I might stick to plain lists, since most operations can be implemented with simple maps and reduces.
<davexunit>I have an after-gc hook that relies on a procedure that uses the guile FFI. unfortunately, when this hook is called when guile is exiting, the program crashes because the shared library file has aleady been unloaded.
<davexunit>what would be the best course of action? just catch the exception and ignore it?
<tupi>sunday is a good day for stupid quizz :) is the fork/pull request 'concept' available on savannah ? i'd like to [learn how to] contribute to the clutter branch of guile-gnome, i have a savannah account and [already had
<tupi>a guile-gnome git clone
<tupi>but i can't find how to fork [reading the savannah git doc] a project
<davexunit>clone the repo on your machine
<tupi>davexunit: i already had a clone
<davexunit>do you have a remote to push to?
<davexunit>gitorious, github, etc?
<tupi>i have a gitorious account, which holds my kisĂȘ/common projects, but i did not put guile-gnome there
<tupi>how would i do that actually ?
<davexunit>the basic workflow is: clone repo, make feature branch, do your work, send a patch to the mailing list
<tupi>ok, but wingo did mention send a pull request and so i am trying to learn to do that
<davexunit>is guile-gnome on gitorious?
<davexunit>he might mean on there
<tupi>not that i am aware of, it's on savannah
<tupi>url = git://git.sv.gnu.org/guile-gnome.git
<tupi>
<tupi>so the fork / pull request is not working 'with' savannah hosted project then ?
<davexunit>fork/pull request is github terminology. I've never heard it used with respect to savannah.
<fbs>youre gonna need access right
<tupi>ok
<tupi>and tx both of you. too bad there is no such contribution schema on savannah
<tupi>but i can ask to be a member [for clutter examples contribution] and always ask review on the mailing list before to push ...
<fbs>I think thats still 'the' way to do it
<tupi>yes. i just sent a membership request
<fbs>I like the 'github model', makes it easy
<civodul>how come fport_fill_input can raise system-error with EINTR
<wingo>civodul: for Ctrl-C i imagine
<wingo>or is that something else
*wingo trying to do away with scm_tc16_memoizer
<civodul>wingo: but SCM_SYSCALL is supposed to catch EINTR and loop
<wingo>civodul: perhaps something else schedules an async to throw that error?
<civodul>hmm
<civodul>arrrgh
<civodul>no
<civodul>wingo: it's a while(0) loop
<civodul>so the "continue;" there just leaves the loop
<civodul>IOW, it never worked
<wingo>..............................................................
<wingo>that's amazing
<civodul>indeed :-)
<civodul>so many years...
<wingo>if the while(0) is at the end though, does the continue work?
<civodul>it is: do { ... } while (0)
<wingo>doesn't that work?
<civodul>well no
<wingo>i would think that continue would restart the loop correctly
<wingo>maybe i'm showing my ignorance
<civodul>i double-checked just in case ;-), and no, it doesn't work
<wingo>:)
<wingo>so did i introduce that bug?
<wingo>i think so
<civodul>it seems, yes :-)
<civodul>not sure what to do now
<civodul>well, email :-)
<wingo>that's incredible
<wingo>that must be one of the worst bugs i have made
<civodul>apparently people have been able to deal with that :-)
<wingo>indeed, c99 is pretty clear here; i must have just imagined a different language
<wingo>zow
<civodul>i didn't notice until i had actually macro-expanded it and stepped through it