IRC channel logs

2013-06-19.log

back to list of logs

<nalaginrut>morning guilers~
<b4283>hiya
<nalaginrut>b4283: heya~
<b4283>John Carmack tweeted that "the challenge of Scheme program is to make it run."
<taylanub>The challenge of any programming language is to make programs you write in it run, when you don't know the language. :P And when you do, it's to make them "work" I guess.
<nalaginrut>b4283: hmm? I didn't see it
<nalaginrut>OK, see it, but I don't understand...
<voltagex>anyone awake?
<wingo>moin :)
<garjola>Hello
<garjola>I have a question about parallel execution using (parallel proc proc ...)
<garjola>It does not run in parallel ...
<garjola>it behaves just like (begin ...)
<garjola>At least, only one single core is used.
<garjola>Tested on debian stable on 2 different machines (2 cores and 8 cores)
<garjola>Any hint?
<davexunit>add^_: I remember you being interested in game development with guile. check out this new language: http://strlen.com/lobster
<civodul>garjola: `parallel' is implemented in terms of futures
<civodul>and there's at most 1 future per core
<davexunit>add^_: it has a great feature list. let's aim to match it with Guile. :)
<civodul>garjola: and there were a couple of bugs in Guile < 2.0.7 (?)
<garjola>civodul: GNU Guile 2.0.5-deb+1-3
<garjola>Should I upgrade?
<civodul>yes
<garjola>The behaviour I see is that one single core is used
<garjola>Simple example code
<garjola>(use-modules (ice-9 threads))
<garjola>(define (afunc)
<garjola> (begin
<garjola> (+ 1 2 3)
<garjola> (afunc)))
<garjola>(parallel (afunc)
<garjola> (afunc)
<garjola> (afunc))
<garjola>Any simple way to install a more recent guile on debian? Or do I have to build from source?
<davexunit>build from source. it takes some time but is relatively painless.
<davexunit>you'll have to install a few *-dev packages
<garjola>OK. Thanks
<add^_>davexunit: sorry, I was away. I'll look at it.
<add^_>davexunit: what did you want to do with it? Add stuff to Guile or stuff to Lobster?
<davexunit>add^_: make guile-2d have the features of lobster.
<davexunit>Guile can already do everything that his custom language does.
<add^_>aha
<davexunit>it's just a matter of providing the game specific stuff.
<add^_>Sounds fun :-)
<davexunit>apparently lobster comes with a library for A* pathfinding. that is pretty nice.
<add^_>Right
<add^_>So I should look at the "engine" part?
<add^_>of the list that is.
<davexunit>yeah
<davexunit>Guile covers the first 2 parts.
<add^_>This sounds more interesting than making the RL-lib I was planning on making but have given up on (libtcod has some bindings for guile already apparently)
<davexunit>mostly. minus the speed stuff.
<davexunit>RL-lib ?
<add^_>RogueLike
<davexunit>oh cool.
<davexunit>work on what you'd like. I'm just looking for potential contributors since guile-2d will never get done with just me. :P
<add^_>But finishing the bindings already made should be higher priority..
<add^_>I'll help you if I can :-)
<add^_>I need a clear goal though.
<davexunit>yes indeed.
<davexunit>clear goals are lacking.
<add^_>Well, the list on that page is pretty good for a start
<davexunit>yeah
<davexunit>something like "add 2D primitive shape drawing procedures"
<add^_>Awesome now I have an even more concrete project to help out with. ;-)
<davexunit>a major goal for me is "add sprite batching"
<davexunit>and dealing with tilesets (a texture split into many smaller textures)
<add^_>Ah
<add^_>I remember doing that with guile-sdl
<add^_>The second goal
<davexunit>it's more complex with opengl
<add^_>Aaah
<add^_>I haven't tried doing that in OpenGL
<add^_>Geez, I killed my emacs buffers without saving the changes -.-
<add^_>davexunit: is it ok if I add some stuff to the TODO file?
<add^_>Hm
<davexunit>of course.
<add^_>I really dislike github's new look.
<add^_>:-(
<add^_>I'm uncertain wether I should fork or not.
<fbs>just fork
<davexunit>make a fork, add^_
<add^_>oki
<civodul>hello there!
<civodul>has anyone been using the Guile bindings for GnuTLS on Debian, with Debian's Guile 2.0.5?
<civodul>i'm looking for volunteers to test :-)
<civodul>(Nikos privately reported a weird failure that i can't reproduce)
<davexunit>what would be the most efficient way to represent 2d/3d vectors (in the mathematical sense)?
<davexunit>regular lists? bytevectors?
<davexunit>doing lots of vector math is common in games, and I want to use a data structure that will give me the best performance.
<add^_>I would guess bytevectors, but I don't really know.
<add^_>One should test before deciding on one..
<davexunit>agreed, but I figured I would ask those that might know better than me. :)
<add^_>Yeah..
<davexunit>I would like to have n-dimensional vectors, preferably. not just 2d/3d.
<add^_>Agreed
<add^_>Wouldn't that be arrays then though?
<add^_>a vector is a 1d array right?
<davexunit>is array != vector?
<add^_>Well, if the array is 1 dimension it's the same.
<davexunit>does guile have a notion of arrays?
<davexunit>I can't reference the docs atm.
<add^_>I think yes
<add^_>What do you mean with reference the docs?
<davexunit>to see if arrays are a thing
<add^_>They are
<add^_>Hm
<add^_>I guess you aren't at home
<davexunit>nope
<davexunit>I'm too busy to do more than a little irc banter.
<add^_>Okey
<fbs>civodul: does debian ship tls bindings for 2.0 now?
<add^_>I wish I remember what structure it was that was strongly recomended against using. (e.g Do not use X)
<add^_>remembered*
<davexunit>maybe array.
<add^_>Maybe.. Or Structures/Records.
<davexunit>yeah, use records instead of structs
<add^_>Hm, I think the records of choice are the ones in srfi-9 if I remember that correctly
<davexunit>yes
<davexunit>I use srfi-9 constantly.
<add^_>I noticed in your code :-)
<davexunit>I can't do without srfi-1 and srfi-9
<davexunit>those are pretty essential
<add^_>Ah, yeah
<add^_>I see no warning about the usage of arrays, should be fine I suppose..
<civodul>fbs: not sure
<civodul>fbs: but my request is about building GnuTLS on Debian anyway :-)
<fbs>ah
<fbs>my irc thing uses gnutls
<civodul>and you use Debian's Guile 2.0.5?
<fbs>i could
<add^_>Ah, that. I remember having trouble even installing gnutls on my debian-box
<civodul>oh
<civodul>i'm all ears :-)
<add^_>Well, that was when I made that hack for the irc thingy
<add^_>Haven't tried in quite some time.
<add^_>I could try again, perhaps even tomorrow if the weather is good enough (e.g rain)
<spaceCamel>
<spaceCamel>:q
<davexunit>unfortunately for spaceCamel, this IRC channel isn't vi.
<tupi`>haha
<add^_>LOL