IRC channel logs

2013-06-17.log

back to list of logs

***ozzloy_ is now known as ozzloy
<recursor94>Hey, I tried the guile in C example program in the guile info pages, and the compiler yielded this error. /tmp/ccEomLPX.o: In function `inner_main':
<recursor94>simple-gui.c:(.text+0x20): undefined reference to `scm_shell'
<recursor94>/tmp/ccEomLPX.o: In function `main':
<recursor94>simple-gui.c:(.text+0x49): undefined reference to `scm_boot_guile'
<recursor94>collect2: error: ld returned 1 exit status
<recursor94>Is there a simple explanation for this error? I'm new to C.
<nalaginrut>afternoon guilers~
<civodul>Hello Guilers!
<nalaginrut_>wingo: is there anyway to break a procedure from external? and add '(abort)' into the break point
<wingo>what? :)
<wingo>you can set up a prompt and abort to the prompt
<nalaginrut_>wingo: add arbitrary breakpoint to a procedure, but the procedure doesn't has 'abort'
<fbs>wingo: is there an easy way to dump the content of a .go file as 'assembly' from the cli?
<wingo>(define (call-with-break f) (let ((tag (make-prompt-tag))) (define (break . vals) (apply abort-to-prompt tag vals)) (call-with-prompt tag (lambda () (f break)) (lambda (k . vals) (apply values vals)))))
<wingo>fbs: disassemble might do it
<wingo>the format of .go files is changing in 2.2, fwiw
<wingo>nalaginrut: you can add a call trap
<wingo>but that's pretty low-level, and only works in the debugging vm
<nalaginrut_>wingo: where can I find it?
<nalaginrut_>call trap
<fbs>ah, guild disassemblde does it
<wingo>search the manual for traps
<nalaginrut_>OK
<nalaginrut_>seems vm-abort-continuation-hook is a nice thing to try
<nalaginrut_>for a green thread scheduler, it could be used for adding delimited-continuations into a work-queue
<add^_>Oh, is there a date when 2.2 will be released?
<wingo>yes there is a date
<wingo>we don't know the date yet though :)
<add^_>Hah
<add^_>I'll be waiting! ;-)
<fbs>stop waiting and help :p
<add^_>With what would I be able to help? :-P
<nalaginrut_>well~but that sentence is true
<nalaginrut_>anyway, I do think Boss should share a TODO list, and we may see what we can do ;-P
<nalaginrut_>or we have to wait...
<add^_>indeed
<nalaginrut_>if someone need a ruby-1.4 front-end, I'm planning to try it
<nalaginrut_>but I'd like to do something for 2.2
<davexunit>on the subject of how people can help: how can newcomers get involved? interpreters/compilers are pretty daunting.
<wingo>it's tough, and right now we're in a delicate state where there's no compiler for the new vm yet
<wingo>i would recommend starting with something that's not the compiler, at least for now...
<nalaginrut_>I don't know what's the proper thing for newcomers, bindings?
<nalaginrut_>wingo: BTW, I implemented a front-end for a simple language IMP, which I planed to write a tutorial with it, on the topic "how to add a new language in Guile platform"
<nalaginrut_>wingo: brainfuck is too simple, but ecmascript is too complicated for newcomers
<wingo>neat :-))
<nalaginrut_>wingo: https://github.com/NalaGinrut/imp
<nalaginrut_>the hard work is how to write a good tutorial
<fbs> start with chosing your target audience
<nalaginrut_>hmm...the audience should be, the students just learned compile principle, and the language designing fans, and who want to use other languages for writing the future Emacs plugins
<nalaginrut_>besides, with wingo 's example, we can call the module/lib functions from a foreign language
<nalaginrut_>I do think Guile is a Evangeline for language-design-fans, it's easy to try various cool languages as they wish, but without considering the compiling optimization which is very complicated
<nalaginrut_>s/Evangeline/Evangel
<nalaginrut_>even compiler back-end is very complicated too...
<cky>nalaginrut_: I still want to write a GolfScript language frontend. :-)
<cky>nalaginrut_: GolfScript's reference implementation (in Ruby) is too slow, and I'm hoping that a Guile version would be faster. :-P
<nalaginrut_>cky: nice~
<nalaginrut_>cky: how about adding ruby? but I found the LALR is very complicated for ruby-1.9, seems 1.4 is easier
<nalaginrut_>sorry, s/LALR/BNF
<cky>Ruby is a much tougher gem to crack. :-P
<nalaginrut_>yes, I bet so
<nalaginrut_>well, I have a very cool idea, let's implement a nicer TCL front-end, and end TCL war forever ;-P
<nalaginrut_>wingo: I think it's better to rewrite the example with % rather than bare call-with-prompt, the replies complains it's to tricky to understand, but we do have more elegant way. http://wingolog.org/archives/2011/08/30/the-gnu-extension-language
<add^_>Maybe I should start using master instead of using stable-2.0
<add^_>Yeah, gonna do that.
<add^_>Oh, right. Crap.
<add^_>Whatever
<add^_>Awesome
<civodul>awesome!
<add^_>civodul: I was just being stupid, forgot to run ldconfig, thought I had broken my guile build.
<civodul>ah