IRC channel logs

2013-06-09.log

back to list of logs

***jao is now known as Guest48611
***Guest48611 is now known as jao
***Gues_____ is now known as Guest23554
<nalaginrut>morning guilers~
<UNIXgod>Hello. I am new to scheme. I would like to write a function which would do a system call to open my $EDITOR, in this case vi, from inside my scheme repl which creates a temp file for editing and when the editor is closed returns back to the repl and parses and eval it. Mainly to grok and hack around which scheme and work through sicp and little schemer at my own pace. Any suggestions on how to go about constructing the function?
<mark_weaver>UNIXgod: (define (edit-and-eval) (let ((fname (tmpnam))) (system* (getenv "EDITOR") fname) (load fname)))
<mark_weaver>you might want to (delete-file fname) at the end as well.
<UNIXgod>mark_weaver: thank you
<mark_weaver>you're welcome :)
<davexunit>good morning guilers
<davexunit>wingo: where should I send figl patches? guile-user?
<wingo>davexunit: yep
<davexunit>okay. thanks.
<wingo>thank you :)
<davexunit>wingo: what version of the opengl spec does figl use?
<wingo>davexunit: depends :)
<wingo>generally version 2.x
<wingo>though it's often possible to support later interfaces, as things are dynamically bound
<wingo>and later versions actually remove functionality which it seems we should keep, so you can't just update and get a better gl
<wingo>and to an extent it is possible to do gles with figl
<wingo>which is cool
<wingo>because of the late-bound nature of things
<davexunit>I'm reading the opengl 4.3 specs, but for some things I don't see wrappers in figl/gl/low-level.scm
<add^_>davexunit: why so high-end?
<davexunit>I just grabbed the latest spec
<add^_>Which is only supported by a few graphics-cards. :-/
<add^_>Maybe it's gotten better..
<davexunit>wingo: so do the section numbers in gl.scm correspond with the 2.1 spec?
<wingo>yep
<davexunit>okay. thanks. clears things up a lot.
***Gues_____ is now known as Guest46316
***bdmst is now known as boredomist
***Gues_____ is now known as Guest89033
<wingo>evening, mark_weaver