IRC channel logs

2013-05-31.log

back to list of logs

<taylanub>Why do distros not just install Guile 2.0 under the name guile2 ?
<ijp>some do
<taylanub>Any reason Fedora resisted ?
<ijp> https://bugzilla.redhat.com/show_bug.cgi?id=678238
<ijp>it doesn't actually give a reason, it just doesn't seem to have got much discussion
<taylanub>Yeah, what I see is 1 year of ignornace and 1 year of inactivity. :P
<ijp>such is life
<davexunit>what is a .tsar file?
<davexunit>I'm looking at the guile-sdl source
<ijp>never heard of it
<davexunit>and this file seems very significant but I can't tell exactly what uses it
<ijp>I think a .star is some kind of shell archive
<davexunit> http://paste.lisp.org/display/137385
<ijp>I'm 99% inclined to think ttn created his own file format
<davexunit>the file looks like this
<davexunit>I don't know what the integers mean
<ijp>okay, os he did
<ijp>hmm, it doesn't exactly give you much of a clue
<davexunit>it seems to be used for generating texi stuff
<davexunit>so it's not what I'm looking for
<davexunit>ttn hasn't responded to an email I sent him yesterday about guile-sdl so I'm trying to hack something myself.
<ijp>I think it took him a year to respond to one of mine
<davexunit>his sdl surface wrapper doesn't expose all of the surface attributes
<davexunit>I need access to the pixels
<ijp>I had completely forgotten what the email was about when I got the reply
<davexunit>haha
<ijp>let's see. Sent Oct 5 2011 answered March 20 2013
<davexunit>wow
<ijp>amazing how time flies
<davexunit>I'm having a hard time figuring out how the surface getters/setters are implemented.
<davexunit>they seem to be autogenerated but I can't determine how.
***fangism is now known as fangism-shadow
<nalaginrut>morning guilers~
<b4283>hiya
<nalaginrut>b4283: heya~
<adu>hi
<nalaginrut>anyway to do char->symbol?
<nalaginrut>oops, symbol does that
***Soft_ is now known as Soft
<civodul>Hello Guilers!
<fbs>o/ civodul
<nalaginrut>civodul: is memoize.c any related to memorization?
<davexunit>is that r supposed to be there?
<civodul>nalaginrut: to memoization, for the bootstrap evaluator
<nalaginrut>just bootstrap? I saw @prompt there, I'm researching delimited-continuation in Guile
<nalaginrut>I mean, just for bootstrap?
<civodul>nalaginrut: actually no, also for (ice-9 eval)
<civodul>sorry for the confusion
<nalaginrut>so what's the real implementation for delimited-continuation in C?
<nalaginrut>which file?
<civodul>control.c
<nalaginrut>hah~thanks~
<taylanub>nalaginrut: Out of curiosity .. the usage of ~ in chatting has something to do with Chinese, or Japanese, or so, right ? What exactly is it ? :P
<nalaginrut>well, some Chinese use ~ to imply they're happy now
<taylanub>Interesting, thanks. I've definitely seen it in Japanese-speaking circles too; must've spread from one to the other or so.
<nalaginrut>hmm...maybe they use it for other meaning? dunno
<nalaginrut>And for Chinese/Japanese, such a symbol maybe used to compose a complicated chatting face
<nalaginrut>like: ~_~
<nalaginrut>or *^_^*
<taylanub>Never occurred to me to ask someone, I'll ask what the Japanese use it for the next time I encounter it.
*taylanub goes home .. friday evening!
<nalaginrut>hah~happy Friday
<civodul>yeah, Happy Friday Guilers!
<civodul>dsmith: Happy Friday! :-)
<davexunit>happy friday!
<davexunit>nalaginrut: are you researching a green thread implementation? I don't know what green threads entail exactly, but I've used prompts to make coroutines and also made a simpler scheduler for them.
<nalaginrut>davexunit: yes, that's what so-called green thread
<davexunit>my scheduler is based on the "agenda" described in SICP
<davexunit>it's a special scheduler for games that I "tick" every frame.
<nalaginrut>I think it's easy to implement a prototype with coroutines
<davexunit>the coroutine code is a slight modification of some code that wingo posted in the mailing list somewhere.
<nalaginrut>hmm...IIRC, is it a work-queue?
<davexunit>that sounds about right.
<davexunit>it uses queues.
<davexunit>basically, I say (agenda-schedule some-procedure some-number-of-ticks-from-now)
<davexunit> https://github.com/davexunit/gnumaku/blob/rebirth/gnumaku/coroutine.scm
<davexunit>coroutine stuff
<davexunit> https://github.com/davexunit/gnumaku/blob/rebirth/gnumaku/agenda.scm
<davexunit>work-queue "agenda"
<nalaginrut>my idea is a mailbox + event + coroutine, actually, it's actors-model
<davexunit>I don't know much about actors
<davexunit>I'm interested to see what you come up with.
<shanecelis>davexunit: Very cool. I like the coroutines.
<nalaginrut>davexunit: oh~Gnumaku seems cool~
<davexunit>it's a stalled project.
<davexunit>unfortunately. :(
<davexunit>but figured I'd share my code in case it helps turn on some lightbulbs for you.
<add^_>davexunit: aw
<add^_>Happy Friday!
<davexunit>I *want* to continue it, the issue is currently with having an underlying game library.
<davexunit>which I'm trying to address, actually.
<add^_>Ah
<davexunit>I've written 2 bad wrappers for allegro 5, and I'm not going to try a third :P
<add^_>:-P
<add^_>How come you think they are bad?
<davexunit>guile-sdl and guile-figl exist. I want to add a layer over them that provides useful 2D stuff.
<davexunit>well, the first one used the Guile C API
<davexunit>I was manually wrapping everything
<davexunit>I started gnumaku not knowing just how much I would end up needing to wrap.
<davexunit>soon enough I had a really terrible allegro 5 wrapper in my project.
<add^_>aj
<add^_>ah*
<davexunit>so I tried again with a separate project, and used the FFI
<add^_>Well, isn't there swig?
<davexunit>that one is actually decent, but it's incomplete.
<davexunit>I discussed swig here, the impression that I got was that it wasn't going to work well with guile.
<add^_>Actually, maybe you shouldn't use swig, you'll probably waste more time..
<add^_>Yeah
<add^_>It's a lot of manual-tweaking..
<add^_>Same for CL
<davexunit>guile-sdl exists, and I'm trying to get in contact with ttn about it
<davexunit>to get some things added that I would like
<add^_>Yeah..
<add^_>:-)
<davexunit>and wingo's GL wrapper, figl, is great.
<nalaginrut>davexunit: it's great hint for me, thanks for your code ;-)
<add^_>I hope it'll turn out well
<davexunit>add^_: I can't access the raw pixel data of images with guile-sdl currently.
<davexunit>it's blocking me from creating opengl textures
<add^_>Hm
<add^_>I don't remember having that problem, maybe I didn't use that part of guile-sdl though
<davexunit>there are attributes for surface like w, h, format
<davexunit>but not pixels
<davexunit>I looked into the source and it is not being wrapped, and it looks like there isn't the necessary infrastructure to wrap it
<davexunit>I want the pixel data back as a bytevector.
<add^_>surface-get-format ?
<add^_>oh
<davexunit>that's just the pixel format. not the raw data.
<add^_>right
<davexunit>I need to pass that off to opengl
<add^_>sorry
<davexunit>so I can use hardware accelerated rendering.
<davexunit>I couldn't grok all of the macros and stuff used in the source to hack it myself last night.
<add^_>grok?
<davexunit>understand
<add^_>ah
<davexunit> https://en.wikipedia.org/wiki/Grok
<add^_>I remember having trouble with that too :-P
<davexunit>but perhaps I can just write a function that will work well enough for me, submit it, and let ttn tell me how to fix it up to be compatible.
<add^_>:-)
<davexunit>there's a lot of stuff that maintains compatibility with old guile versions.
<davexunit>I don't know how incompatible bytevectors are with old versions.
***fangism-shadow is now known as fangism