IRC channel logs

2013-05-14.log

back to list of logs

***mario-go` is now known as mario-goulart
<nalaginrut>morning guilers~
<b4283>hiya
<nalaginrut>heya
<hypnocat>is there example of reading from a file from the following old guile FAQ too old to be useful for guile 1.8.8 ?
<hypnocat> https://www.gnu.org/software/guile/docs/faq/OLD-guile-faq.html#File%20by%20lines
<hypnocat>i'm getting an error about read-lines being an unbound variable
<wingo>do you want a list of lines or do you want the whole thing as a string?
<wingo>or something else
<hypnocat>i'd like to know how to do both
<hypnocat>and also to know why read-lines isn't bound
<hypnocat>oops, i mean read-line
<hypnocat>hmm... guile's 1.8 reference manual does mention read-line here:
<hypnocat> https://www.gnu.org/software/guile/docs/docs-1.8/guile-ref/Line_002fDelimited.html#Line_002fDelimited
<hypnocat>ooh.. i just noticed at the top, it had: (use-modules (ice-9 rdelim))
<hypnocat>ok, that seems to have fixed it
<hypnocat>and that should be enough to get me started
***mgsk is now known as wat
***wat is now known as mgs
***mgs is now known as yuk
***yuk is now known as markskilbeck
<wingo>hum, seems i wandered off and hypnocat's problem solved itself
<wingo>nice
<wingo>:)
***markskilbeck is now known as mgsk
<nalaginrut>yup, it's too old for our FAQ
***Guest90982 is now known as micro__
<wingo>mooo
<civodul>Hello Guilers!
<dsmith>Hey
<wingo>heya civodul :)
*wingo was doing some rtl hacking this morning
<civodul>yeah!
<civodul>how is it going?
<wingo>civodul: pretty good i think
<wingo>the assembler is now recording arity info and procedure properties but not yet writing to the elf file
<civodul>nice
<wingo>so next up would be writing docstrings (and wiring up the things to read them back using the existing interfaces)
<wingo>then the same for arity info
<wingo>and the same for generic procedure properties
<wingo>and after all that is done, i just need local variable info and line numbers
<wingo>i am a little scared about the cps compiler though -- sometimes i think it would be easier to do something less clever and then go more clever later
<wingo>dunno though, part of that is that i am not familiar with noah's recent work
<wingo>congrats on the guix release btw
<civodul>thanks
<civodul>yeah perhaps the cps part can be looked at later?
<civodul>but it's the only scheme->rtl compiler currently, right?
<wingo>right
*civodul is not quite up-to-date
<civodul>ok
<wingo>i would think you could do a tree-il->rtl compiler by just simulating the stack height
<wingo>and then making things that would reference temporaries from the stack instead reference indexed locals
<civodul>hmm, ok
<wingo>but i'm also sure that cps is the right thing in the end...
<wingo>well
<wingo>approximately sure :)
<civodul>heh
<wingo>anyway, debugging first, then we'll see
<civodul>though the direct compiler already does useful stuff
<civodul>dunno
<wingo>or we could actually normalize our existing tree-il to anf...
<wingo>which is a kind of capitulation but perhaps a prudent one :)
<wingo>that would let us re-use more of the stack machine's compiler because nothing would ever push on the stack
<wingo>anyway back to the (unrelated) hack
***yazdmich|znc is now known as yazdmich
***mario-go` is now known as mario-goulart
<stis>finally, the new guile-log undo/redo framework is debugged and ready
<stis>Also I submitted these ideas for a srfi just an hour ago!
<stis>Let's see what happens :-)
*stis should really prepare a new guile-log release!
<mgsk>Can I supress guile's "note source file newer than..." messages?
<mgsk>clear
<mgsk>oops
<taylanub>Apparently R5RS and R7RS-small define `let-syntax' such that it creates a scope, which means `define's directly inside a top-level `let-syntax' would *not* bind identifiers in the global scope, right ? Guile seems to support doing that though; should I rely on this in my code ?
<wingo>dunno :) r6rs does it the other way fwiw
<taylanub>I wonder if the same thing can be achieved another way, I use it in a file of mine and it decreases repetitive defines drastically. In worst case I would use a globally-defined macro I guess.
<civodul>aaargh
<civodul>terrible
<civodul>regexp-exec
<civodul>not thread-safe
<wingo>gaaargh
<civodul>terrrrible
<civodul>took me some time to find out what was going wrong
<wingo>but you found it!
<wingo>that's excellent :)
<civodul>yes!
<civodul>:-)
<civodul>argh, string->uri regexp-execs
<wingo>zow
<civodul> http://git.savannah.gnu.org/cgit/guix.git/commit/?id=0332386251ba001c0b0ec65fbfa1c06b826c6e47
<civodul>beware!