IRC channel logs

2013-04-22.log

back to list of logs

<cky>fbs: ->bool does exactly what you think it does. Returns #t if the given value is a true value, otherwise #f.
<cky>In Guile, every value is a true value except #f and #nil.
<fbs>cky: yeah thanks I found it, but why isnt it in the manual
<cky>As some here would say, patches welcome. ;-)
<fbs>ah
<fbs>I found it in some old code of mine, wondered where I found it back then
***adu_ is now known as adu
<nalaginrut>how to print source code in geiser?
<nalaginrut>or show
<civodul>Hello Guilers!
<wingo>morning :)
<DerGuteMoritz>hey guilers!
<wingo>good day, sir heidkamp :)
*DerGuteMoritz bows
<DerGuteMoritz>did you have a nice weekend?
<civodul>good, although i was sick on Friday
<DerGuteMoritz>oh no! the flu?
<wingo>winter's last spasm of cold, hopefully...
<civodul>yeah
<civodul>wingo: i'm doing JS via Hop these days :-)
<civodul>looks like JS is where schemers end
<civodul>we're brothers of the browser
<wingo>hah
<wingo>i have generators working in v8, whee
<nalaginrut>wingo: what generator?
<ijp> http://arewefastyet.com/ looks like firefox is catching up
<CaptainLex>Morning Guilers!
<add^_>Good afternoon. :-)
<nalaginrut>heya
<ijp>what do I need to import for pretty printing?
<ijp>oh, right (ice-9 pretty-print)
<wingo>nalaginrut: they're part of the next version of javascript
<fbs>hmm
<fbs>is there a way to get a useful backtrace for a VM stack overflow?
<civodul>,bt
<fbs>I already know where the bug is,
<fbs>civodul: 58:104809 (ssl? <network: localhost!>)
<fbs> 58:104808 (ssl? <network: localhost!>)
<fbs> 58:104807 (ssl? <network: localhost!>)
<civodul>what is it?
<fbs>its printing that ~1k times
<civodul>what is printing that?
<fbs>,bt
<fbs>I did (define (ssl? x) (->bool (ssl? x))) instead of get-ssl? x
<civodul>heh
<fbs>I guess its printing its whole stack
***serhart2 is now known as serhart
<lloda>i'm now ~40 patches deep into my attempt to fix vector/array bugs. I have added a number of tests and I there are no new bugs (that I know of). I have fixed a number a bugs in stable-2.0. But it's probably inappropriate to post 40 patches to guile-devel, and some of the patches implement behavior that isn't settled. So how should I proceed?
<civodul>lloda: perhaps post a general overview, and highlight the semantic/API changes or other possibly controversial issues for discussion first?
<civodul>40 patches is a lot
<lloda>they are small patches, for the most part
<lloda>some of the bugfixes are independent, but it would be some work to pick them out
<lloda>and I have fundamental problems, for example with strings as arrays
<civodul>argh
<lloda>for example #2a:0:2() fails at the REPL in stable-2.0
<lloda>this is because character arrays don't have a 'type size'
<lloda>(it is defined as 0 in uniform.c)
<lloda>and compile-assembly.scm uses uniform-array->bytevector, which fails
<civodul>ouch
*civodul points at wingo and hides away
<lloda>also string_get_handle puts NULL in h->elements
<lloda>so in practice strings cannot be used like arrays at all
<lloda>(I mean directly in C code by using pointers as with all other arrays)
<civodul>so that's good, IMO
<lloda>it would be worse if there was a pointer and the type size wasn't fixed, if that's what you mean
<lloda>because otherwise it doesn't seem good to me
<lloda>to me, it means that strings aren't arrays and array procedures should reject them
<civodul>i mean strings-as-arrays doesn't seem wise to me, at first sight
<lloda>require explicit conversion
<civodul>yeah
<lloda>I agree with that 100%
<lloda>probably earlier in Guile strings were simpler and it made sense
<lloda>but not anymore
<civodul>yep
<lloda>ok, I'll put the branch in Gitorious (is that ok)
<lloda>and send a summary to the list
<civodul>ok
<wingo>moo
*DerGuteMoritz is having the mondays
<ijp>neigh
*wingo trying to see if he can manage a trip to els2013
<wingo>hee hee #scheme
<wingo>also, what is sagittarius (sp?) scheme?
<dsmith-work>wingo: So what more needs to happen on wip-rtl? (just curious)
<DerGuteMoritz>that klrr guy is somewhat confused
<wingo>dsmith-work: http://git.savannah.gnu.org/gitweb/?p=guile.git;a=blob;f=module/system/vm/rtl.scm;h=8ca58b8a74dfe2f8902a8c4401b6882eb69888aa;hb=1cd4d792c4a0792edfb9ba56085ab434050b3d92#l37
<wingo>that's all that needs doing on the VM level
<wingo>then we just need a compiler to rtl that works, and we're good to go
<add^_>RTL? Register Transfer Language?
<wingo>yes, but just a name for a new register vm for guile
<add^_>Hm ok
<adu>hi wingo
<wingo>greets
<adu>I had a todo item
<adu>I forgot what it was
<adu>why is "GIMP interface" described as "Should be real easy."?
<ijp>we'd be better off removing that ideas page
<ijp>ah, I see it got a warning at the top, at least
<lloda>has someone tried to use Guile under OpenMP?
*wingo ignorant
<civodul>dunno
***Shozan is now known as 65MAAUGER
***65MAAUGER is now known as SHODAN