IRC channel logs

2013-04-04.log

back to list of logs

<davexunit>I want to write a procedure to help me with my coroutines called yield. yield is a built-in procedure for dealing with threads. is there any way to deal with this that doesn't involve changing the procedure name?
<mark_weaver>davexunit: sure. just redefine it. it'll only be changed in your modules, so it won't break anything else.
<mark_weaver>in general, you can redefine anything you want, in your own modules.
<davexunit>I seem to have issues when importing the module now.
<mark_weaver>ah yes. in the module that exports it, write: #:export (yield) #:replace (yield)
<davexunit>#:replace is what I was looking for. thanks.
<mark_weaver>np!
<mark_weaver>davexunit: actually, you don't need the #:export (yield). #:replace (yield) by itself is enough.
<davexunit>okay
<davexunit>that worked very well.
<davexunit>and it takes care of that pesky warning.
<mark_weaver>:)
***sneek_ is now known as sneek
<nalaginrut>I do think inner server should provide client IP, I prefer to put the client IP in request
<nalaginrut>or the web-framework can't record IP and for statistic
<nalaginrut>maybe put it in request-meta?
<nalaginrut>wingo: is there any paper for escape-continuation? I'm writing let/ec and call/ec docs
<wingo>nalaginrut: dunno; search for "one-shot" continuations
<nalaginrut>ok
<mark_weaver>nalaginrut: "Representing Control in the Presence of One-Shot Continuations" by Bruggeman, Waddell, and Dybvig.
<mark_weaver>
<janneke>morning!
<mark_weaver>but they use different names (not let/ec or call/ec), and it's mostly focused on low-level implementation details.
<janneke>wingo: is there a special trick to add multiple :gsignals to a class? re: http://pastebin.com/QAuywjTj
*janneke is missing something
<nalaginrut>OK, I'll give this paper name for reference to readers
<nalaginrut>I have to time to dig into for more detail example or explain
<wingo> http://www.gnu.org/software/guile-gnome/docs/gobject/html/gnome-gobject-gobject.html#gnome-gobject-gobject
<wingo>janneke: ^
<nalaginrut>mark_weaver: how to give the external link for the reference in our manual?
<nalaginrut>or just give the name
<mark_weaver>nalaginrut: See the SRFI-41 or SRFI-105 nodes in srfi-modules.texi for examples. One example: See @uref{http://srfi.schemers.org/srfi-105/srfi-105.html, the specification of SRFI-105}.
<mark_weaver>i.e. @uref{<url>, <text shown>}
<janneke>wingo i saw that one, but it doesn't really add multiple gsignals?
<mark_weaver>I don't know if it's a good idea to give a URL to that paper though. to be honest, I'm not sure it's worth linking to the paper at all. it describes implementation details that don't even match Guile's implementation.
<nalaginrut>nicely done~
<nalaginrut>I gave this url http://www.cs.indiana.edu/~bruggema/one-shots-abstract.html
<nalaginrut>not the illegal paper url
<nalaginrut>anyway, this paper was published in SiteSeerX, I think it's open
<nalaginrut>but I won't give the pdf url
<mark_weaver>well, the paper is legally available from dybvig's site: http://www.cs.indiana.edu/~dyb/pubs.html links to http://www.cs.indiana.edu/~dyb/pubs/call1cc.pdf
<mark_weaver>but again, I'm not sure it really makes sense to link to it from the manual.
<mark_weaver>it's really not relevant to users, and it doesn't match what guile actually does internally.
<mark_weaver>to do so would be like linking to the 'fixing letrec reloaded" paper in our 'letrec' documentation.
<nalaginrut>If I were (yes I am) an user, I do wish these references are all available
<nalaginrut>at least the paper name
<nalaginrut>or we have to explain it each time on IRC/Mail-list
<mark_weaver>"explain it each time"? That presupposes that this is a common event. In fact, it's extremely rare for readers of our manual to be interested in some random paper on how to implement some feature of the language, especially if it doesn't even describe the way guile does it. There already exists a resource for that: http://library.readscheme.org/
<mark_weaver>If a paper describes how to *use* a language construct, fine. If it describes how Guile actually implements the feature, then maybe. For the rest, I'd rather just link to http://library.readscheme.org/ in one place in the manual and be done with it. IMO, anyway.
<nalaginrut>hmm...agreed, but for this case, I think the paper is OK
<mark_weaver>Today is the 45th anniversary of the assassination of Martin Luther King.
<mark_weaver>and with that random fact, it is time for me to sleep. good night!
*mark_weaver --> zzz
<nalaginrut>night
<janneke>wingo: here are my edits to get that the 'frobate example to run: http://pastebin.com/VwcDfdvX
<janneke>wingo: i can only get one of the signals (either 'frobate or 'frobite) to work at the same time
<janneke>both work when the other is commented-out
<wingo>unfortunately i'm a bit busy atm
<wingo>can you send a mail to guile-user?
<janneke>wingo: sure, thanks!