IRC channel logs

2025-04-24.log

back to list of logs

<matrix_bridge><Andrius Štikonas> oriansj: could you please merge https://github.com/oriansj/stage0-posix-aarch64/pull/9 ?
<matrix_bridge><Andrius Štikonas> (cc: Jeremiah Orians)
<oriansj>sorry for the delays, have been out sick. stikonas, you should have merge permissions on aarch64 now.
<stikonas>no worries, hopefully you are better now
<oriansj>working on it.
<oriansj>eliwhitehouse_: sure, I'll give you an email with my phone number so we can chat if that helps.
<oriansj>As for the c library ordering problem; Turns out to be an old one in the C world and there are two solutions.
<oriansj>1) separate the body from the header (what M2libc tries to do) or 2) Turn off the feature in your C compiler that throws an error when it hit something undefined (not an option with M2-Planet)
<oriansj>so assuming the .h files only has externs and function prototypes, the order shouldn't matter as all of the .h headers needed would be loaded first and then after the .c bodies would be loaded.
<stikonas>hmm, in https://github.com/oriansj/M2-Mesoplanet/issues/15 though I think it is some kind of M2-Mesoplanet bug...
<stikonas>it should have included that header, though I didn't look too much into that...
<stikonas>anyway, I'm out at the moment, so can't look too much into it
<oriansj>if the .c has an include that the .h does not, could produce that behavior
<oriansj>in sys/stat.h you #include <sys/types.h> after including #include <amd64/linux/sys/stat.c> which requires sys/types.h for mode_t
<oriansj>but that file does include #include <sys/types.h>
<oriansj>which means the cc_reader.c in M2-Mesoplanet isn't seeing the #include for some reason
<matrix_bridge><gtker> stikonas, oriansj: In general it seems like M2-Mesoplanet expands (and then marks as already-seen) the includes before checking if they actually need to be expanded?